aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--java/jdk16/Makefile2
-rw-r--r--java/jdk16/files/patch-j2se-splashscreen-Makefile25
2 files changed, 23 insertions, 4 deletions
diff --git a/java/jdk16/Makefile b/java/jdk16/Makefile
index 50c181fc5ca5..7a20e63a951d 100644
--- a/java/jdk16/Makefile
+++ b/java/jdk16/Makefile
@@ -7,7 +7,7 @@
PORTNAME= jdk
PORTVERSION= ${JDK_VERSION}.${JDK_UPDATE_VERSION}p${JDK_PATCHSET_VERSION}
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= java devel
MASTER_SITES= # http://download.java.net/jdk6/
# http://www.eyesbeyond.com/freebsddom/java/jdk16.html
diff --git a/java/jdk16/files/patch-j2se-splashscreen-Makefile b/java/jdk16/files/patch-j2se-splashscreen-Makefile
index 8f340e32798e..c5661adb31cf 100644
--- a/java/jdk16/files/patch-j2se-splashscreen-Makefile
+++ b/java/jdk16/files/patch-j2se-splashscreen-Makefile
@@ -1,9 +1,18 @@
$FreeBSD$
---- ../../j2se/make/sun/splashscreen/Makefile.orig Sat Feb 16 11:45:24 2008
-+++ ../../j2se/make/sun/splashscreen/Makefile Sat Feb 16 11:45:37 2008
-@@ -47,7 +47,7 @@
+--- ../../j2se/make/sun/splashscreen/Makefile.orig 2008-10-13 20:02:03.000000000 -0700
++++ ../../j2se/make/sun/splashscreen/Makefile 2008-10-14 18:53:48.000000000 -0700
+@@ -45,9 +45,16 @@
+
+ ifneq ($(PLATFORM), windows)
CFLAGS += -DWITH_X11
++endif
++
++# Internal JDK include paths should come before system include paths
++CPPFLAGS += -I$(PLATFORM_SRC)/native/$(PKGDIR)/splashscreen -I$(SHARE_SRC)/native/$(PKGDIR)/splashscreen
++CPPFLAGS += -I$(SHARE_SRC)/native/$(PKGDIR)/image/jpeg -I$(SHARE_SRC)/native/java/util/zip/zlib-1.1.3
++
++ifneq ($(PLATFORM), windows)
ifeq ($(PLATFORM), bsd)
ifneq ($(OS_VENDOR), NetBSD)
- ICONV_DIR = /usr/local
@@ -11,3 +20,13 @@ $FreeBSD$
ICONV_LIB = -L$(ICONV_DIR)/lib -liconv
endif
CPPFLAGS += -I$(OPENWIN_HOME)/include \
+@@ -75,9 +82,6 @@
+ vpath %.c $(SHARE_SRC)/native/$(PKGDIR)/image/jpeg
+ vpath %.c $(PLATFORM_SRC)/native/$(PKGDIR)/splashscreen
+
+-CPPFLAGS += -I$(PLATFORM_SRC)/native/$(PKGDIR)/splashscreen -I$(SHARE_SRC)/native/$(PKGDIR)/splashscreen
+-CPPFLAGS += -I$(SHARE_SRC)/native/$(PKGDIR)/image/jpeg -I$(SHARE_SRC)/native/java/util/zip/zlib-1.1.3
+-
+ #
+ # Has been converted to the JNI: generate JNI-style header files
+ #