aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--games/openttd/Makefile7
-rw-r--r--games/openttd/distinfo4
-rw-r--r--security/vuxml/vuln.xml37
3 files changed, 42 insertions, 6 deletions
diff --git a/games/openttd/Makefile b/games/openttd/Makefile
index 786bb0bd025f..89d801c605f2 100644
--- a/games/openttd/Makefile
+++ b/games/openttd/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= openttd
-PORTVERSION= 1.3.2
+PORTVERSION= 1.3.3
CATEGORIES= games
MASTER_SITES= http://ftp.snt.utwente.nl/pub/games/openttd/binaries/releases/${PORTVERSION}/ \
http://us.binaries.openttd.org/binaries/releases/${PORTVERSION}/
@@ -21,7 +21,10 @@ USE_XZ= yes
HAS_CONFIGURE= yes
CONFIGURE_ENV= STRIP="${STRIP_CMD} ${STRIP}"
CONFIGURE_ARGS= --prefix-dir="${PREFIX}" --data-dir="${DATADIR_REL}"
-MAKE_ARGS= VERBOSE=1 # We want to see what's going on
+
+.if defined(BATCH) || defined(PACKAGE_BUILDING)
+MAKE_ARGS= VERBOSE=1
+.endif
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
CXXFLAGS= # Set to empty as OpenTTD treats it as an addition to CFLAGS
diff --git a/games/openttd/distinfo b/games/openttd/distinfo
index 0305d970fa7a..77956328617c 100644
--- a/games/openttd/distinfo
+++ b/games/openttd/distinfo
@@ -1,2 +1,2 @@
-SHA256 (openttd-1.3.2-source.tar.xz) = f6efc0cd0c4f4315a98844c331acc2e02322d5671ec376b9f0a11795b0eb270b
-SIZE (openttd-1.3.2-source.tar.xz) = 6347104
+SHA256 (openttd-1.3.3-source.tar.xz) = 6991ed2c0170481800c3a92a1b43546821a658de91d3ac7efe868588387eca5d
+SIZE (openttd-1.3.3-source.tar.xz) = 6370128
diff --git a/security/vuxml/vuln.xml b/security/vuxml/vuln.xml
index f8b2d732deeb..ffe37981f42a 100644
--- a/security/vuxml/vuln.xml
+++ b/security/vuxml/vuln.xml
@@ -51,6 +51,39 @@ Note: Please add new entries to the beginning of this file.
-->
<vuxml xmlns="http://www.vuxml.org/apps/vuxml-1">
+ <vuln vid="d2073237-5b52-11e3-80f7-c86000cbc6ec">
+ <topic>OpenTTD -- Denial of service using forcefully crashed aircrafts</topic>
+ <affects>
+ <package>
+ <name>openttd</name>
+ <range><ge>0.3.6</ge><lt>1.3.3</lt></range>
+ </package>
+ </affects>
+ <description>
+ <body xmlns="http://www.w3.org/1999/xhtml">
+ <p>The OpenTTD Team reports:</p>
+ <blockquote cite="https://security.openttd.org/en/CVE-2013-6411">
+ <p>The problem is caused by incorrectly handling the fact that
+ the aircraft circling the corner airport will be outside of the
+ bounds of the map. In the 'out of fuel' crash code the height
+ of the tile under the aircraft is determined. In this case
+ that means a tile outside of the allocated map array, which
+ could occasionally trigger invalid reads.</p>
+ </blockquote>
+ </body>
+ </description>
+ <references>
+ <cvename>CVE-2013-6411</cvename>
+ <url>https://security.openttd.org/en/CVE-2013-6411</url>
+ <url>http://bugs.openttd.org/task/5820</url>
+ <url>http://vcs.openttd.org/svn/changeset/26134</url>
+ </references>
+ <dates>
+ <discovery>2013-11-28</discovery>
+ <entry>2013-11-28</entry>
+ </dates>
+ </vuln>
+
<vuln vid="620cf713-5a99-11e3-878d-20cf30e32f6d">
<topic>monitorix -- serious bug in the built-in HTTP server</topic>
<affects>
@@ -12132,7 +12165,7 @@ executed in your Internet Explorer while displaying the email.</p>
</affects>
<description>
<body xmlns="http://www.w3.org/1999/xhtml">
- <p>OpenTTD reports:</p>
+ <p>The OpenTTD Team reports:</p>
<blockquote cite="http://security.openttd.org/en/CVE-2012-3436">
<p>Denial of service (server) using ships on half tiles and
landscaping.</p>
@@ -28394,7 +28427,7 @@ executed in your Internet Explorer while displaying the email.</p>
</affects>
<description>
<body xmlns="http://www.w3.org/1999/xhtml">
- <p>OpenTTD project reports:</p>
+ <p>The OpenTTD Team reports:</p>
<blockquote cite="http://security.openttd.org/en/CVE-2010-2534">
<p>When multiple commands are queued (at the server) for execution
in the next game tick and an client joins the server can get into