aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--archivers/ark/Makefile4
-rw-r--r--comms/kremotecontrol/Makefile4
-rw-r--r--deskutils/kcharselect/Makefile4
-rw-r--r--math/kcalc/Makefile4
-rw-r--r--misc/kdeutils3/Makefile4
-rw-r--r--misc/kdeutils4/Makefile4
-rw-r--r--security/kgpg-kde4/Makefile4
-rw-r--r--security/kwallet/Makefile4
-rw-r--r--sysutils/kdf/Makefile4
-rw-r--r--sysutils/kfloppy/Makefile4
-rw-r--r--sysutils/sweeper/Makefile4
11 files changed, 44 insertions, 0 deletions
diff --git a/archivers/ark/Makefile b/archivers/ark/Makefile
index cf65cf6d3400..f56bc6dbd9e4 100644
--- a/archivers/ark/Makefile
+++ b/archivers/ark/Makefile
@@ -48,5 +48,9 @@ DO_NOT_COMPILE+=klaptopdaemon
PLIST_APPEND+= plist.klaptop
.endif
+post-configure:
+ @${REINPLACE_CMD} -e 's|#define HAVE_L_FUNCS 1||g' \
+ ${WRKSRC}/config.h
+
.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
.include <bsd.port.mk>
diff --git a/comms/kremotecontrol/Makefile b/comms/kremotecontrol/Makefile
index cf65cf6d3400..f56bc6dbd9e4 100644
--- a/comms/kremotecontrol/Makefile
+++ b/comms/kremotecontrol/Makefile
@@ -48,5 +48,9 @@ DO_NOT_COMPILE+=klaptopdaemon
PLIST_APPEND+= plist.klaptop
.endif
+post-configure:
+ @${REINPLACE_CMD} -e 's|#define HAVE_L_FUNCS 1||g' \
+ ${WRKSRC}/config.h
+
.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
.include <bsd.port.mk>
diff --git a/deskutils/kcharselect/Makefile b/deskutils/kcharselect/Makefile
index cf65cf6d3400..f56bc6dbd9e4 100644
--- a/deskutils/kcharselect/Makefile
+++ b/deskutils/kcharselect/Makefile
@@ -48,5 +48,9 @@ DO_NOT_COMPILE+=klaptopdaemon
PLIST_APPEND+= plist.klaptop
.endif
+post-configure:
+ @${REINPLACE_CMD} -e 's|#define HAVE_L_FUNCS 1||g' \
+ ${WRKSRC}/config.h
+
.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
.include <bsd.port.mk>
diff --git a/math/kcalc/Makefile b/math/kcalc/Makefile
index cf65cf6d3400..f56bc6dbd9e4 100644
--- a/math/kcalc/Makefile
+++ b/math/kcalc/Makefile
@@ -48,5 +48,9 @@ DO_NOT_COMPILE+=klaptopdaemon
PLIST_APPEND+= plist.klaptop
.endif
+post-configure:
+ @${REINPLACE_CMD} -e 's|#define HAVE_L_FUNCS 1||g' \
+ ${WRKSRC}/config.h
+
.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
.include <bsd.port.mk>
diff --git a/misc/kdeutils3/Makefile b/misc/kdeutils3/Makefile
index cf65cf6d3400..f56bc6dbd9e4 100644
--- a/misc/kdeutils3/Makefile
+++ b/misc/kdeutils3/Makefile
@@ -48,5 +48,9 @@ DO_NOT_COMPILE+=klaptopdaemon
PLIST_APPEND+= plist.klaptop
.endif
+post-configure:
+ @${REINPLACE_CMD} -e 's|#define HAVE_L_FUNCS 1||g' \
+ ${WRKSRC}/config.h
+
.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
.include <bsd.port.mk>
diff --git a/misc/kdeutils4/Makefile b/misc/kdeutils4/Makefile
index cf65cf6d3400..f56bc6dbd9e4 100644
--- a/misc/kdeutils4/Makefile
+++ b/misc/kdeutils4/Makefile
@@ -48,5 +48,9 @@ DO_NOT_COMPILE+=klaptopdaemon
PLIST_APPEND+= plist.klaptop
.endif
+post-configure:
+ @${REINPLACE_CMD} -e 's|#define HAVE_L_FUNCS 1||g' \
+ ${WRKSRC}/config.h
+
.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
.include <bsd.port.mk>
diff --git a/security/kgpg-kde4/Makefile b/security/kgpg-kde4/Makefile
index cf65cf6d3400..f56bc6dbd9e4 100644
--- a/security/kgpg-kde4/Makefile
+++ b/security/kgpg-kde4/Makefile
@@ -48,5 +48,9 @@ DO_NOT_COMPILE+=klaptopdaemon
PLIST_APPEND+= plist.klaptop
.endif
+post-configure:
+ @${REINPLACE_CMD} -e 's|#define HAVE_L_FUNCS 1||g' \
+ ${WRKSRC}/config.h
+
.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
.include <bsd.port.mk>
diff --git a/security/kwallet/Makefile b/security/kwallet/Makefile
index cf65cf6d3400..f56bc6dbd9e4 100644
--- a/security/kwallet/Makefile
+++ b/security/kwallet/Makefile
@@ -48,5 +48,9 @@ DO_NOT_COMPILE+=klaptopdaemon
PLIST_APPEND+= plist.klaptop
.endif
+post-configure:
+ @${REINPLACE_CMD} -e 's|#define HAVE_L_FUNCS 1||g' \
+ ${WRKSRC}/config.h
+
.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
.include <bsd.port.mk>
diff --git a/sysutils/kdf/Makefile b/sysutils/kdf/Makefile
index cf65cf6d3400..f56bc6dbd9e4 100644
--- a/sysutils/kdf/Makefile
+++ b/sysutils/kdf/Makefile
@@ -48,5 +48,9 @@ DO_NOT_COMPILE+=klaptopdaemon
PLIST_APPEND+= plist.klaptop
.endif
+post-configure:
+ @${REINPLACE_CMD} -e 's|#define HAVE_L_FUNCS 1||g' \
+ ${WRKSRC}/config.h
+
.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
.include <bsd.port.mk>
diff --git a/sysutils/kfloppy/Makefile b/sysutils/kfloppy/Makefile
index cf65cf6d3400..f56bc6dbd9e4 100644
--- a/sysutils/kfloppy/Makefile
+++ b/sysutils/kfloppy/Makefile
@@ -48,5 +48,9 @@ DO_NOT_COMPILE+=klaptopdaemon
PLIST_APPEND+= plist.klaptop
.endif
+post-configure:
+ @${REINPLACE_CMD} -e 's|#define HAVE_L_FUNCS 1||g' \
+ ${WRKSRC}/config.h
+
.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
.include <bsd.port.mk>
diff --git a/sysutils/sweeper/Makefile b/sysutils/sweeper/Makefile
index cf65cf6d3400..f56bc6dbd9e4 100644
--- a/sysutils/sweeper/Makefile
+++ b/sysutils/sweeper/Makefile
@@ -48,5 +48,9 @@ DO_NOT_COMPILE+=klaptopdaemon
PLIST_APPEND+= plist.klaptop
.endif
+post-configure:
+ @${REINPLACE_CMD} -e 's|#define HAVE_L_FUNCS 1||g' \
+ ${WRKSRC}/config.h
+
.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
.include <bsd.port.mk>