aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/leatherman/Makefile2
-rw-r--r--devel/leatherman/distinfo6
-rw-r--r--devel/leatherman/files/patch-cmake_cflags.cmake4
-rw-r--r--devel/leatherman/files/patch-cmake_leatherman.cmake.in4
-rw-r--r--devel/leatherman/files/patch-json__container_tests_json__container__test.cc13
5 files changed, 21 insertions, 8 deletions
diff --git a/devel/leatherman/Makefile b/devel/leatherman/Makefile
index dc1ca6a41f28..8f24cdabccfd 100644
--- a/devel/leatherman/Makefile
+++ b/devel/leatherman/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= leatherman
-PORTVERSION= 1.1.1
+PORTVERSION= 1.1.2
CATEGORIES= devel
MAINTAINER= puppet@FreeBSD.org
diff --git a/devel/leatherman/distinfo b/devel/leatherman/distinfo
index e4f16d739b48..97d70cf122ae 100644
--- a/devel/leatherman/distinfo
+++ b/devel/leatherman/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1503479577
-SHA256 (puppetlabs-leatherman-1.1.1_GH0.tar.gz) = 5c277b094cdfd8bfec43aef57bd02443d8789e85c203821acb7d0fbe42fa20c3
-SIZE (puppetlabs-leatherman-1.1.1_GH0.tar.gz) = 429468
+TIMESTAMP = 1503861160
+SHA256 (puppetlabs-leatherman-1.1.2_GH0.tar.gz) = 1feca2ba8472252132ad90c6bcc3fba6dbb85ee912b1cbcde9853d812d54729f
+SIZE (puppetlabs-leatherman-1.1.2_GH0.tar.gz) = 430545
diff --git a/devel/leatherman/files/patch-cmake_cflags.cmake b/devel/leatherman/files/patch-cmake_cflags.cmake
index 182c10a8308f..d23bf62adf4e 100644
--- a/devel/leatherman/files/patch-cmake_cflags.cmake
+++ b/devel/leatherman/files/patch-cmake_cflags.cmake
@@ -1,4 +1,4 @@
---- cmake/cflags.cmake.orig
+--- cmake/cflags.cmake.orig 2017-08-25 18:32:21 UTC
+++ cmake/cflags.cmake
@@ -2,7 +2,7 @@
# Each of our project dirs sets CMAKE_CXX_FLAGS based on these. We do
@@ -9,7 +9,7 @@
# Clang warns that 'register' is deprecated; 'register' is used throughout boost, so it can't be an error yet.
# The warning flag is different on different clang versions so we need to extract the clang version.
-@@ -41,7 +41,7 @@
+@@ -41,7 +41,7 @@ elseif ("${CMAKE_CXX_COMPILER_ID}" STREQ
set(CMAKE_CXX_FLAGS "-Wno-maybe-uninitialized ${CMAKE_CXX_FLAGS}")
# missing-field-initializers is disabled because GCC can't make up their mind how to treat C++11 initializers
diff --git a/devel/leatherman/files/patch-cmake_leatherman.cmake.in b/devel/leatherman/files/patch-cmake_leatherman.cmake.in
index 2a62095621b8..959e5efc64d5 100644
--- a/devel/leatherman/files/patch-cmake_leatherman.cmake.in
+++ b/devel/leatherman/files/patch-cmake_leatherman.cmake.in
@@ -1,6 +1,6 @@
---- cmake/leatherman.cmake.in.orig
+--- cmake/leatherman.cmake.in.orig 2017-08-25 18:32:21 UTC
+++ cmake/leatherman.cmake.in
-@@ -83,11 +83,6 @@
+@@ -83,11 +83,6 @@ macro(leatherman_install)
RUNTIME DESTINATION bin
LIBRARY DESTINATION lib${LIB_SUFFIX}
ARCHIVE DESTINATION lib${LIB_SUFFIX})
diff --git a/devel/leatherman/files/patch-json__container_tests_json__container__test.cc b/devel/leatherman/files/patch-json__container_tests_json__container__test.cc
new file mode 100644
index 000000000000..72ec8f3beb09
--- /dev/null
+++ b/devel/leatherman/files/patch-json__container_tests_json__container__test.cc
@@ -0,0 +1,13 @@
+This is a workaround for this bug:
+https://github.com/philsquared/Catch/blob/master/docs/limitations.md#clangg----skipping-leaf-sections-after-an-exception
+--- json_container/tests/json_container_test.cc.orig 2017-08-25 18:32:21 UTC
++++ json_container/tests/json_container_test.cc
+@@ -80,7 +80,7 @@ TEST_CASE("JsonContainer::JsonContainer
+ json_value = "null";
+ }
+
+- REQUIRE_NOTHROW(JsonContainer { json_value });
++ REQUIRE_NOTHROW(if (json_value != "") { JsonContainer { json_value };});
+ }
+
+ SECTION("it should throw a data_parse_error in case of empty string") {