aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--www/Makefile1
-rw-r--r--www/mod_xsendfile/Makefile20
-rw-r--r--www/mod_xsendfile/distinfo3
-rw-r--r--www/mod_xsendfile/pkg-descr11
4 files changed, 35 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 5088335b69f6..e436075ec3d3 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -387,6 +387,7 @@
SUBDIR += mod_vhs
SUBDIR += mod_webapp
SUBDIR += mod_webkit
+ SUBDIR += mod_xsendfile
SUBDIR += mod_zap
SUBDIR += moinmoin
SUBDIR += momspider
diff --git a/www/mod_xsendfile/Makefile b/www/mod_xsendfile/Makefile
new file mode 100644
index 000000000000..4bb3103c92e3
--- /dev/null
+++ b/www/mod_xsendfile/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: mod_xsendfile Apache module
+# Date created: 2006-11-23
+# Whom: Andrew T. Bennett <potatosaladx@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_xsendfile
+PORTVERSION= 0.9
+CATEGORIES= www
+MASTER_SITES= http://celebnamer.celebworld.ws/stuff/mod_xsendfile/
+
+MAINTAINER= potatosaladx@gmail.com
+COMMENT= An Apache2 module that processes X-SENDFILE headers
+
+USE_APACHE= 2.0+
+AP_FAST_BUILD= yes
+AP_GENPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/www/mod_xsendfile/distinfo b/www/mod_xsendfile/distinfo
new file mode 100644
index 000000000000..8c48419ae7cd
--- /dev/null
+++ b/www/mod_xsendfile/distinfo
@@ -0,0 +1,3 @@
+MD5 (mod_xsendfile-0.9.tar.gz) = a7d22d4027386929c7d69c8f2b050c96
+SHA256 (mod_xsendfile-0.9.tar.gz) = 2f07f3ddd03a9493601fef35668c2f0feb279edba2ae0172cd44feb8d7514272
+SIZE (mod_xsendfile-0.9.tar.gz) = 10240
diff --git a/www/mod_xsendfile/pkg-descr b/www/mod_xsendfile/pkg-descr
new file mode 100644
index 000000000000..e976d5135316
--- /dev/null
+++ b/www/mod_xsendfile/pkg-descr
@@ -0,0 +1,11 @@
+mod_xsendfile is a small Apache2 module that processes X-SENDFILE headers
+registered by the original output handler.
+
+If it encounters the presence of such header it will discard all output and
+send the file specified by that header instead using Apache internals
+including all optimizations like caching-headers and sendfile or mmap if
+configured.
+
+It is useful for processing script-output of e.g. php, perl or any cgi.
+
+WWW: http://celebnamer.celebworld.ws/stuff/mod_xsendfile/