aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Mk/bsd.options.desc.mk1
-rw-r--r--graphics/jbig2dec/Makefile10
2 files changed, 7 insertions, 4 deletions
diff --git a/Mk/bsd.options.desc.mk b/Mk/bsd.options.desc.mk
index 1108afc0c2bb..1c268b1524ea 100644
--- a/Mk/bsd.options.desc.mk
+++ b/Mk/bsd.options.desc.mk
@@ -8,5 +8,6 @@ Options_Desc_MAINTAINER= ports@FreeBSD.org
DOCS_DESC?= Build and install the documentation
LDAP_DESC?= Enable LDAP support
NLS_DESC?= Build and install the localisation data
+PNG_DESC?= Enable PNG support
SSL_DESC?= Enable SSL support
TIDY_DESC?= Enable tidy html cleaner support
diff --git a/graphics/jbig2dec/Makefile b/graphics/jbig2dec/Makefile
index ccdfcef54ec1..e21364edbebc 100644
--- a/graphics/jbig2dec/Makefile
+++ b/graphics/jbig2dec/Makefile
@@ -20,8 +20,10 @@ GNU_CONFIGURE= yes
USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
-OPTIONS= PNG "Enable png support" On \
- TESTS "Download and use test-images for post-build testing" Off
+OPTIONS_DEFINE= PNG TESTS
+OPTIONS_DEFAULT= PNG
+
+TESTS_DESC= Download and use test-images for post-build testing
MAN1= jbig2dec.1
@@ -33,12 +35,12 @@ LICENSE_FILE= ${WRKSRC}/COPYING
.include <bsd.port.options.mk>
-.if defined(WITH_PNG)
+.if ${PORT_OPTIONS:MPNG}
LIB_DEPENDS+= png:${PORTSDIR}/graphics/png
CONFIGURE_ARGS+=--with-libpng=${LOCALBASE}
.endif
-.if defined(WITH_TESTS)
+.if ${PORT_OPTIONS:MTESTS}
MASTER_SITES+= http://jbig2dec.sourceforge.net/ubc/:tests
DISTFILES+= jb2streams.zip:tests
EXTRACT_ONLY= ${DISTFILES:M*xz}