aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net/rdesktop/Makefile15
1 files changed, 14 insertions, 1 deletions
diff --git a/net/rdesktop/Makefile b/net/rdesktop/Makefile
index 5be8cf1cfbc7..9c272c1a5f5c 100644
--- a/net/rdesktop/Makefile
+++ b/net/rdesktop/Makefile
@@ -22,10 +22,23 @@ GNU_CONFIGURE= yes
DOCS= doc/AUTHORS doc/TODO doc/*.txt
MAN1= rdesktop.1
-.if !defined(WITHOUT_IPV6)
+.if !defined(WITHOUT_RDESKTOP_IPV6) && !defined(WITHOUT_IPV6)
CONFIGURE_ARGS+= --with-ipv6
.endif
+.if defined(WITH_RDESKTOP_DEBUG)
+CONFIGURE_ARGS+= --with-debug\
+ --with-debug-kbd\
+ --with-debug-rdp5\
+ --with-debug-clipboard\
+ --with-debug-sound\
+ --with-debug-channel\
+ --with-debug-seamless
+
+post-configure:
+ ${ECHO} "#define WITH_DEBUG_SERIAL 1" >> ${WRKSRC}/rdesktop.h
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/rdesktop ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/doc/rdesktop.1 ${MAN1PREFIX}/man/man1