aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Mk/bsd.options.desc.mk1
-rw-r--r--sysutils/graveman/Makefile23
2 files changed, 12 insertions, 12 deletions
diff --git a/Mk/bsd.options.desc.mk b/Mk/bsd.options.desc.mk
index 7b7ad27f8042..3c9a1946315c 100644
--- a/Mk/bsd.options.desc.mk
+++ b/Mk/bsd.options.desc.mk
@@ -198,6 +198,7 @@ NTLM_DESC?= NTLM authentication support
NUMPY_DESC?= NumPy mathematical computing support
ODBC_DESC?= ODBC backend
ODF_DESC?= ODF file support
+OGG_DESC?= OGG support
OPENAL_DESC?= OpenAL support
OPENCV_DESC?= OpenCV support
OPENEXR_DESC?= HDR support via OpenEXR
diff --git a/sysutils/graveman/Makefile b/sysutils/graveman/Makefile
index 9c36a4db9ac6..0ad8b593ad88 100644
--- a/sysutils/graveman/Makefile
+++ b/sysutils/graveman/Makefile
@@ -15,7 +15,7 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:C/\.(.)$/-\1/}
MAINTAINER= ports@FreeBSD.org
COMMENT= Another GTK2 frontend for cdrecord, mkisofs, readcd, and sox
-LIB_DEPENDS= mng.1:${PORTSDIR}/graphics/libmng
+LIB_DEPENDS= mng:${PORTSDIR}/graphics/libmng
USE_BZIP2= yes
USE_GMAKE= yes
@@ -29,29 +29,28 @@ CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
MAN1= graveman.1
-OPTIONS= MP3 "MP3 Support" off \
- OGG "OGG Support" off \
- DVD "DVD+RW Support" off
+OPTIONS_DEFINE= MP3 OGG DVD
+DVD_DESC= DVD+RW support
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_MP3)
-LIB_DEPENDS+= mad.2:${PORTSDIR}/audio/libmad \
- id3tag.0:${PORTSDIR}/audio/libid3tag
+.if ${PORT_OPTIONS:MMP3}
+LIB_DEPENDS+= mad:${PORTSDIR}/audio/libmad \
+ id3tag:${PORTSDIR}/audio/libid3tag
RUN_DEPENDS+= sox:${PORTSDIR}/audio/sox
.else
CONFIGURE_ARGS+=--disable-mp3
.endif
-.if defined(WITH_OGG)
+.if ${PORT_OPTIONS:MOGG}
LIB_DEPENDS+= ogg:${PORTSDIR}/audio/libogg \
- vorbis.4:${PORTSDIR}/audio/libvorbis
+ vorbis:${PORTSDIR}/audio/libvorbis
.else
CONFIGURE_ARGS+=--disable-ogg
.endif
-.if defined(WITH_DVD)
+.if ${PORT_OPTIONS:MDVD}
RUN_DEPENDS+= growisofs:${PORTSDIR}/sysutils/dvd+rw-tools
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>