aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--editors/xemacs21-mule-common/Makefile13
-rw-r--r--editors/xemacs21-mule/Makefile10
2 files changed, 13 insertions, 10 deletions
diff --git a/editors/xemacs21-mule-common/Makefile b/editors/xemacs21-mule-common/Makefile
index 36b96486b79f..b260b992a703 100644
--- a/editors/xemacs21-mule-common/Makefile
+++ b/editors/xemacs21-mule-common/Makefile
@@ -3,7 +3,7 @@
# Date created: 5 Dec 1997
# Whom: Kazuyuki IENAGA <ienaga@jsys.co.jp>
#
-# $Id: Makefile,v 1.3 1998/12/02 08:01:14 asami Exp $
+# $Id: Makefile,v 1.4 1998/12/26 03:47:19 kuriyama Exp $
#
DISTNAME= xemacs-20.4
@@ -40,13 +40,10 @@ EXTRACT_ONLY= xemacs-20.4.tar.gz xemacs-20.4-elc.tar.gz \
japanese/xemacs-canna+wnn6 \
japanese/xemacs-wnn4 \
japanese/xemacs-wnn6
-.if exists(${WRKDIRPREFIX}${PORTSDIR}/${dir}/work/.install_done)
-WRKDIR= ${WRKDIRPREFIX}${PORTSDIR}/${dir}/work
-.if !exists(${WRKDIR}/.install_done-${PKGNAME})
-rvalue_touch!= ${TOUCH} ${WRKDIR}/.install_done-${PKGNAME}
-.endif
-.elif exists(${WRKDIRPREFIX}${PORTSDIR}/${dir}/work/.build_done)
-WRKDIR?= ${WRKDIRPREFIX}${PORTSDIR}/${dir}/work
+.if exists(${WRKDIRPREFIX}${.CURDIR}/../../${dir}/work/.install_done)
+WRKDIR= ${WRKDIRPREFIX}${.CURDIR}/../../${dir}/work
+.elif exists(${WRKDIRPREFIX}${.CURDIR}/../../${dir}/work/.build_done)
+WRKDIR?= ${WRKDIRPREFIX}${.CURDIR}/../../${dir}/work
.endif
.endfor
WRKSRC= ${WRKDIR}/xemacs-20.4
diff --git a/editors/xemacs21-mule/Makefile b/editors/xemacs21-mule/Makefile
index d2e4a5971618..af21c794d40b 100644
--- a/editors/xemacs21-mule/Makefile
+++ b/editors/xemacs21-mule/Makefile
@@ -3,7 +3,7 @@
# Date created: 5 Dec 1997
# Whom: Kazuyuki IENAGA <ienaga@jsys.co.jp>
#
-# $Id: Makefile,v 1.11 1998/11/11 12:55:23 asami Exp $
+# $Id: Makefile,v 1.12 1998/12/26 03:47:19 kuriyama Exp $
#
DISTNAME= xemacs-20.4
@@ -26,7 +26,7 @@ LIB_DEPENDS= Xpm.4:${PORTSDIR}/graphics/xpm \
png.2:${PORTSDIR}/graphics/png \
compface.1:${PORTSDIR}/mail/faces \
${LIB_INPUT_METHOD}
-RUN_DEPENDS= ${PREFIX}/lib/${XEMACS_DIR}/etc/BABYL:${PORTSDIR}/editors/xemacs-mule-common
+RUN_DEPENDS= ${PREFIX}/lib/${XEMACS_DIR}/lisp/x11/x-win-xfree86.elc:${PORTSDIR}/editors/xemacs-mule-common
EXTRACT_ONLY= xemacs-20.4.tar.gz xemacs-20.4-elc.tar.gz \
xemacs-20.4-info.tar.gz xemacs-20.4-mule.tar.gz
@@ -103,6 +103,12 @@ pre-build:
@${GZCAT} ${DISTDIR}/ps-print-jp.el.gz > ${WRKSRC}/lisp/packages/ps-print.el
.endif
+# for xemacs-mule-common in defining ${WRKDIRPREFIX}
+.if !exists(${WRKDIRPREFIX}${.CURDIR}/../../editors/xemacs-mule-common)
+post-build:
+ @${MKDIR} ${WRKDIRPREFIX}${.CURDIR}/../../editors/xemacs-mule-common
+.endif
+
post-install::
.for file in b2m ctags etags gnuclient xemacs-20.4
@strip ${PREFIX}/bin/${file}