aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Mk/bsd.openssl.mk10
-rw-r--r--security/openssl/Makefile4
2 files changed, 13 insertions, 1 deletions
diff --git a/Mk/bsd.openssl.mk b/Mk/bsd.openssl.mk
index ee13eeaac664..3515eb7b8451 100644
--- a/Mk/bsd.openssl.mk
+++ b/Mk/bsd.openssl.mk
@@ -2,7 +2,7 @@
# Date created: 31 May 2002
# Whom: dinoex
#
-# $FreeBSD: /tmp/pcvs/ports/Mk/bsd.openssl.mk,v 1.43 2009-05-07 08:19:02 dinoex Exp $
+# $FreeBSD: /tmp/pcvs/ports/Mk/bsd.openssl.mk,v 1.44 2009-07-21 17:51:43 dinoex Exp $
#
# Use of 'USE_OPENSSL=yes' includes this Makefile after bsd.ports.pre.mk
#
@@ -114,11 +114,19 @@ OPENSSL_SHLIBVER?= ${OPENSSL_SHLIBFILE:E}
.else
# PKG_DBDIR was not found, default
OPENSSL_PORT?= security/openssl
+.if ( ${OSVERSION} >= 800105 )
+OPENSSL_SHLIBVER?= 6
+.else
OPENSSL_SHLIBVER?= 5
.endif
.endif
+.endif
OPENSSL_PORT?= security/openssl
+.if ( ${OSVERSION} >= 800105 )
+OPENSSL_SHLIBVER?= 6
+.else
OPENSSL_SHLIBVER?= 5
+.endif
OPENSSLDIR= ${OPENSSLBASE}/openssl
BUILD_DEPENDS+= ${LOCALBASE}/lib/libcrypto.so.${OPENSSL_SHLIBVER}:${PORTSDIR}/${OPENSSL_PORT}
diff --git a/security/openssl/Makefile b/security/openssl/Makefile
index 7523ae8d5095..040740560401 100644
--- a/security/openssl/Makefile
+++ b/security/openssl/Makefile
@@ -855,7 +855,11 @@ MLINKS= dgst.1 md4.1 \
OPENSSL_BASE_SONAME!= readlink ${DESTDIR}/usr/lib/libcrypto.so || true
OPENSSL_SHLIBVER_BASE= ${OPENSSL_BASE_SONAME:E}
OPENSSL_BASE_SOPATH= ${OPENSSL_BASE_SONAME:H}
+.if ( ${OSVERSION} >= 800105 )
+OPENSSL_SHLIBVER?= 6
+.else
OPENSSL_SHLIBVER?= 5
+.endif
.if !defined(WITHOUT_SSE2)
# disable runtime SSE2 detection