aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--www/mod_php4/Makefile8
-rw-r--r--www/mod_php4/scripts/configure.php2
-rw-r--r--www/mod_php5/Makefile8
-rw-r--r--www/mod_php5/scripts/configure.php2
4 files changed, 6 insertions, 14 deletions
diff --git a/www/mod_php4/Makefile b/www/mod_php4/Makefile
index a467a671072a..9c7ba331528b 100644
--- a/www/mod_php4/Makefile
+++ b/www/mod_php4/Makefile
@@ -101,12 +101,6 @@ post-clean:
.include "${WRKDIRPREFIX}${.CURDIR}/Makefile.inc"
.endif
-post-extract:
-.if target(post-extract-jstring)
- ${MAKE} post-extract-jstring
-.endif
-.if target(post-extract-ming)
- ${MAKE} post-extract-ming
-.endif
+post-extract: ${POSTEXTRACT}
.include <bsd.port.mk>
diff --git a/www/mod_php4/scripts/configure.php b/www/mod_php4/scripts/configure.php
index 986fd90fe9a6..10fbfbec5abb 100644
--- a/www/mod_php4/scripts/configure.php
+++ b/www/mod_php4/scripts/configure.php
@@ -170,6 +170,7 @@ DISTFILES= \${DISTNAME}\${EXTRACT_SUFX} php-4.0RC2_jstring-1.0.tar.gz
CONFIGURE_ARGS+=--enable-jstring
BUILD_DEPENDS+= automake:\${PORTSDIR}/devel/automake
BUILD_DEPENDS+= autoconf:\${PORTSDIR}/devel/autoconf
+POSTEXTRACT+= post-extract-jstring
post-extract-jstring:
[ -d \${WRKDIR}/jstring ] && \\
@@ -193,6 +194,7 @@ BUILD_DEPENDS+= /nonexistent:\${PORTSDIR}/graphics/ming:extract
BUILD_DEPENDS+= automake:\${PORTSDIR}/devel/automake
BUILD_DEPENDS+= autoconf:\${PORTSDIR}/devel/autoconf
LIB_DEPENDS+= ming.2:\${PORTSDIR}/graphics/ming
+POSTEXTRACT+= post-extract-ming
post-extract-ming:
[ -d \${PORTSDIR}/graphics/ming/work ] && \\
diff --git a/www/mod_php5/Makefile b/www/mod_php5/Makefile
index a467a671072a..9c7ba331528b 100644
--- a/www/mod_php5/Makefile
+++ b/www/mod_php5/Makefile
@@ -101,12 +101,6 @@ post-clean:
.include "${WRKDIRPREFIX}${.CURDIR}/Makefile.inc"
.endif
-post-extract:
-.if target(post-extract-jstring)
- ${MAKE} post-extract-jstring
-.endif
-.if target(post-extract-ming)
- ${MAKE} post-extract-ming
-.endif
+post-extract: ${POSTEXTRACT}
.include <bsd.port.mk>
diff --git a/www/mod_php5/scripts/configure.php b/www/mod_php5/scripts/configure.php
index 986fd90fe9a6..10fbfbec5abb 100644
--- a/www/mod_php5/scripts/configure.php
+++ b/www/mod_php5/scripts/configure.php
@@ -170,6 +170,7 @@ DISTFILES= \${DISTNAME}\${EXTRACT_SUFX} php-4.0RC2_jstring-1.0.tar.gz
CONFIGURE_ARGS+=--enable-jstring
BUILD_DEPENDS+= automake:\${PORTSDIR}/devel/automake
BUILD_DEPENDS+= autoconf:\${PORTSDIR}/devel/autoconf
+POSTEXTRACT+= post-extract-jstring
post-extract-jstring:
[ -d \${WRKDIR}/jstring ] && \\
@@ -193,6 +194,7 @@ BUILD_DEPENDS+= /nonexistent:\${PORTSDIR}/graphics/ming:extract
BUILD_DEPENDS+= automake:\${PORTSDIR}/devel/automake
BUILD_DEPENDS+= autoconf:\${PORTSDIR}/devel/autoconf
LIB_DEPENDS+= ming.2:\${PORTSDIR}/graphics/ming
+POSTEXTRACT+= post-extract-ming
post-extract-ming:
[ -d \${PORTSDIR}/graphics/ming/work ] && \\