aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/hs-green-card/Makefile2
-rw-r--r--graphics/hs-HOpenGL/Makefile2
-rw-r--r--x11-toolkits/hs-frantk/Makefile4
-rw-r--r--x11-toolkits/hs-gtk+hs/Makefile4
4 files changed, 6 insertions, 6 deletions
diff --git a/devel/hs-green-card/Makefile b/devel/hs-green-card/Makefile
index b9b6c6642bc3..776e9595564e 100644
--- a/devel/hs-green-card/Makefile
+++ b/devel/hs-green-card/Makefile
@@ -15,7 +15,7 @@ DISTNAME= gc-${PORTVERSION}-src
MAINTAINER= obraun@FreeBSD.org
COMMENT= A foreign function interface preprocessor for Haskell
-BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc
+BUILD_DEPENDS= ghc-5.04.3:${PORTSDIR}/lang/ghc5
WRKSRC= ${WRKDIR}/gc-${PORTVERSION}
diff --git a/graphics/hs-HOpenGL/Makefile b/graphics/hs-HOpenGL/Makefile
index 88ce88a268c1..dd99dfaf72ab 100644
--- a/graphics/hs-HOpenGL/Makefile
+++ b/graphics/hs-HOpenGL/Makefile
@@ -17,7 +17,7 @@ COMMENT= Binding for OpenGL and GLUT for the lazy functional language Haskell
BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc \
green-card:${PORTSDIR}/devel/hs-green-card
-RUN_DEPENDS= ghc:${PORTSDIR}/lang/ghc
+RUN_DEPENDS= ghc:${PORTSDIR}/lang/ghc5
GNU_CONFIGURE= yes
USE_GMAKE= yes
diff --git a/x11-toolkits/hs-frantk/Makefile b/x11-toolkits/hs-frantk/Makefile
index 4a7ceb3aeac3..e3765befb5cd 100644
--- a/x11-toolkits/hs-frantk/Makefile
+++ b/x11-toolkits/hs-frantk/Makefile
@@ -18,8 +18,8 @@ COMMENT= A GUI library for Haskell on top of Tcl-Tk
LIB_DEPENDS= tk84.1:${PORTSDIR}/x11-toolkits/tk84
.if !defined(WITHOUT_GHC)
-BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc
-RUN_DEPENDS= ghc:${PORTSDIR}/lang/ghc
+BUILD_DEPENDS= ghc-5.04.3:${PORTSDIR}/lang/ghc5
+RUN_DEPENDS= ghc-5.04.3:${PORTSDIR}/lang/ghc5
.endif
USE_GMAKE= yes
diff --git a/x11-toolkits/hs-gtk+hs/Makefile b/x11-toolkits/hs-gtk+hs/Makefile
index 1b84ae810c37..fd069270c680 100644
--- a/x11-toolkits/hs-gtk+hs/Makefile
+++ b/x11-toolkits/hs-gtk+hs/Makefile
@@ -14,9 +14,9 @@ PKGNAMEPREFIX= hs-
MAINTAINER= obraun@FreeBSD.org
COMMENT= A GTK+ Binding for Haskell
-BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc \
+BUILD_DEPENDS= ghc-5.04.3:${PORTSDIR}/lang/ghc5 \
c2hs:${PORTSDIR}/devel/hs-c2hs
-RUN_DEPENDS= ghc:${PORTSDIR}/lang/ghc \
+RUN_DEPENDS= ghc-5.04.3:${PORTSDIR}/lang/ghc5 \
c2hs:${PORTSDIR}/devel/hs-c2hs
.if !defined(WITHOUT_IHASKELL)
RUN_DEPENDS+= ports-config:${PORTSDIR}/devel/hs-hpl