aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/gold/Makefile67
-rw-r--r--devel/gold/distinfo3
-rw-r--r--devel/gold/pkg-descr10
4 files changed, 81 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 8e51fecc8fec..36b7bacea718 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -463,6 +463,7 @@
SUBDIR += goffice04
SUBDIR += goffice06
SUBDIR += goffice1
+ SUBDIR += gold
SUBDIR += gonzui
SUBDIR += google-perftools
SUBDIR += google-sparsehash
diff --git a/devel/gold/Makefile b/devel/gold/Makefile
new file mode 100644
index 000000000000..36d503942455
--- /dev/null
+++ b/devel/gold/Makefile
@@ -0,0 +1,67 @@
+# New ports collection makefile for: gold
+# Date created: 16 Aug 2009
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= gold
+PORTVERSION= 1.9.0.2009.09.16
+CATEGORIES= devel
+MASTER_SITES= ftp://ftp.dinoex.de/pub/approved/
+DISTNAME= binutils-${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= Google Releases New and Improved GCC Linker
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_AUTOTOOLS= libtool:22
+USE_GMAKE= yes
+USE_PERL5_BUILD= yes
+
+WRKSRC= ${WRKDIR}/binutils
+PLIST_FILES= bin/ld-new
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_NLS)
+USE_GETTEXT= yes
+CFLAGS+= -I${LOCALBASE}/include
+.else
+CONFIGURE_ARGS+= --disable-nls
+.endif
+
+do-configure:
+.for i in . libiberty gold
+ -cd ${WRKSRC}/${i} && \
+ ${SET_LATE_CONFIGURE_ARGS} \
+ if ! ${SETENV} CC="${CC}" CXX="${CXX}" \
+ CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" \
+ INSTALL="/usr/bin/install -c ${_BINOWNGRP}" \
+ INSTALL_DATA="${INSTALL_DATA}" \
+ INSTALL_PROGRAM="${INSTALL_PROGRAM}" \
+ INSTALL_SCRIPT="${INSTALL_SCRIPT}" \
+ ${CONFIGURE_ENV} ./${CONFIGURE_SCRIPT} ${CONFIGURE_ARGS}; then \
+ ${ECHO_MSG} "===> Script \"${CONFIGURE_SCRIPT}\" failed unexpectedly."; \
+ (${ECHO_CMD} ${CONFIGURE_FAIL_MESSAGE}) | ${FMT} 75 79 ; \
+ ${FALSE}; \
+ fi
+.endfor
+
+do-build:
+.for i in . libiberty gold
+ -cd ${WRKSRC}/${i} && \
+ if ! ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${_MAKE_JOBS} ${MAKE_ARGS} ${ALL_TARGET}; then \
+ if [ x != x${BUILD_FAIL_MESSAGE} ] ; then \
+ ${ECHO_MSG} "===> Compilation failed unexpectedly."; \
+ (${ECHO_CMD} ${BUILD_FAIL_MESSAGE}) | ${FMT} 75 79 ; \
+ fi; \
+ ${FALSE}; \
+ fi
+.endfor
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/gold/ld-new ${PREFIX}/bin/
+
+.include <bsd.port.post.mk>
diff --git a/devel/gold/distinfo b/devel/gold/distinfo
new file mode 100644
index 000000000000..3d342c11d2f5
--- /dev/null
+++ b/devel/gold/distinfo
@@ -0,0 +1,3 @@
+MD5 (binutils-gold-1.9.0.2009.09.16.tar.bz2) = 03a4b0ae218b59a4771d38b6b278912b
+SHA256 (binutils-gold-1.9.0.2009.09.16.tar.bz2) = bfb5bbeb454a495e633321defb1bcfeec2c8f4cb251660f4115c19f4c7b74d55
+SIZE (binutils-gold-1.9.0.2009.09.16.tar.bz2) = 5966103
diff --git a/devel/gold/pkg-descr b/devel/gold/pkg-descr
new file mode 100644
index 000000000000..5921627fd8dd
--- /dev/null
+++ b/devel/gold/pkg-descr
@@ -0,0 +1,10 @@
+Gold is a new linker, written from scratch. It really only has one new feature
+compared to the current GNU linker: it's much faster. I've measured it as five
+times faster linking large C++ applications. Since for most programmers the
+linker is nothing more than a roadblock between writing code and running the
+program, I figure that speed and correctness are the only really important
+features of any linker.
+
+LICENSE: GPL3 or later
+
+WWW: http://google-opensource.blogspot.com/2008/04/gold-google-releases-new-and-improved.html