aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--audio/Makefile1
-rw-r--r--audio/ruby-freedb/Makefile39
-rw-r--r--audio/ruby-freedb/distinfo1
-rw-r--r--audio/ruby-freedb/pkg-comment1
-rw-r--r--audio/ruby-freedb/pkg-descr6
-rw-r--r--audio/ruby-freedb/pkg-plist5
6 files changed, 53 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 35e183f8432f..e5082ca0e943 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -181,6 +181,7 @@
SUBDIR += rplay
SUBDIR += rsynth
SUBDIR += ruby-audiofile
+ SUBDIR += ruby-freedb
SUBDIR += ruby-mp3tag
SUBDIR += ruby-qt2sound
SUBDIR += s3mod
diff --git a/audio/ruby-freedb/Makefile b/audio/ruby-freedb/Makefile
new file mode 100644
index 000000000000..481903e3128e
--- /dev/null
+++ b/audio/ruby-freedb/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: Ruby/Freedb
+# Date created: 16 January 2002
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= freedb
+PORTVERSION= 0.1
+CATEGORIES= audio net ruby
+MASTER_SITES= http://davedd.free.fr/%SUBDIR%/
+MASTER_SITE_SUBDIR= ruby-${PORTNAME}
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ruby-${PORTNAME}-${PORTVERSION}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+
+INSTALL_TARGET= site-install
+
+DOCS= README
+EXAMPLES= test.rb
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/${PORTNAME}
+.for f in ${EXAMPLES}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_EXAMPLESDIR}/${PORTNAME}/
+.endfor
+ ${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/${PORTNAME}/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/audio/ruby-freedb/distinfo b/audio/ruby-freedb/distinfo
new file mode 100644
index 000000000000..23e232d5e564
--- /dev/null
+++ b/audio/ruby-freedb/distinfo
@@ -0,0 +1 @@
+MD5 (ruby/ruby-freedb-0.1.tar.gz) = 40ed1131ec92769a3504b1a249923f44
diff --git a/audio/ruby-freedb/pkg-comment b/audio/ruby-freedb/pkg-comment
new file mode 100644
index 000000000000..49081dd2d3c0
--- /dev/null
+++ b/audio/ruby-freedb/pkg-comment
@@ -0,0 +1 @@
+A Ruby library that provides access to Freedb/CDDB servers
diff --git a/audio/ruby-freedb/pkg-descr b/audio/ruby-freedb/pkg-descr
new file mode 100644
index 000000000000..94b8c29852eb
--- /dev/null
+++ b/audio/ruby-freedb/pkg-descr
@@ -0,0 +1,6 @@
+Ruby/Freedb is a library that provides access to Freedb/CDDB servers
+to find some useful CD-Audio informations (CD-title, tracks titles).
+This library includes low-level functions to access CD-ROM device.
+
+Author: Guillaume Pierronnet <moumar@netcourrier.com>
+WWW: http://davedd.free.fr/ruby-freedb/
diff --git a/audio/ruby-freedb/pkg-plist b/audio/ruby-freedb/pkg-plist
new file mode 100644
index 000000000000..632b6821bf1f
--- /dev/null
+++ b/audio/ruby-freedb/pkg-plist
@@ -0,0 +1,5 @@
+%%RUBY_SITEARCHLIBDIR%%/Freedb.so
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/freedb/test.rb
+%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/freedb
+%%PORTDOCS%%%%RUBY_DOCDIR%%/freedb/README
+%%PORTDOCS%%@dirrm %%RUBY_DOCDIR%%/freedb