aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/yaf/Makefile33
-rw-r--r--net-mgmt/yaf/distinfo3
-rw-r--r--net-mgmt/yaf/pkg-descr8
-rw-r--r--net-mgmt/yaf/pkg-plist49
5 files changed, 94 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index 5cd4ad3efc7d..ecb6838d3391 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -265,6 +265,7 @@
SUBDIR += xymon-client
SUBDIR += xymon-server
SUBDIR += yabm
+ SUBDIR += yaf
SUBDIR += zabbix
SUBDIR += zabbix-agent
diff --git a/net-mgmt/yaf/Makefile b/net-mgmt/yaf/Makefile
new file mode 100644
index 000000000000..bfa61de4f313
--- /dev/null
+++ b/net-mgmt/yaf/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: yaf
+# Date created: 2009-06-29
+# Whom: Dikshie <dikshie@sfc.wide.ad.jp>
+#
+# $FreeBSD$
+
+PORTNAME= yaf
+PORTVERSION= 1.0.0.2
+CATEGORIES= net-mgmt
+MASTER_SITES= http://tools.netsa.cert.org/releases/
+
+MAINTAINER= dikshie@sfc.wide.ad.jp
+COMMENT= YAF is Yet Another Flowmeter
+
+LIB_DEPENDS= fixbuf:${PORTSDIR}/net/libfixbuf \
+ pcre.0:${PORTSDIR}/devel/pcre
+
+GNU_CONFIGURE= yes
+USE_GNOME= glib20 gnomehack
+USE_LDCONFIG= yes
+
+MAN1= airdaemon.1 filedaemon.1 yaf.1 yafscii.1
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|echo aout|echo elf|' ${WRKSRC}/configure
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700042
+BROKEN= does not build on 6.x.
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net-mgmt/yaf/distinfo b/net-mgmt/yaf/distinfo
new file mode 100644
index 000000000000..7f80cfc359d2
--- /dev/null
+++ b/net-mgmt/yaf/distinfo
@@ -0,0 +1,3 @@
+MD5 (yaf-1.0.0.2.tar.gz) = 3ea2dd554025ba9978c914386dd59d9c
+SHA256 (yaf-1.0.0.2.tar.gz) = adbab9968a34445517839b7c53f087c793952d54d0d6912b8e219776fbbe21c6
+SIZE (yaf-1.0.0.2.tar.gz) = 1090045
diff --git a/net-mgmt/yaf/pkg-descr b/net-mgmt/yaf/pkg-descr
new file mode 100644
index 000000000000..452cae3a6a97
--- /dev/null
+++ b/net-mgmt/yaf/pkg-descr
@@ -0,0 +1,8 @@
+YAF is Yet Another Flowmeter. It processes packet data from pcap(3)
+dumpfiles as generated by tcpdump(1) or via live capture from an
+interface using pcap(3) into bidirectional flows, then exports those
+flows to IPFIX Collecting Processes or in an IPFIX-based file format.
+YAF's output can be used with the SiLK flow analysis tools and any
+other IPFIX compliant toolchain.
+
+WWW: http://tools.netsa.cert.org/yaf/index.html
diff --git a/net-mgmt/yaf/pkg-plist b/net-mgmt/yaf/pkg-plist
new file mode 100644
index 000000000000..68cf69761102
--- /dev/null
+++ b/net-mgmt/yaf/pkg-plist
@@ -0,0 +1,49 @@
+bin/airdaemon
+bin/filedaemon
+bin/yaf
+bin/yafcollect
+bin/yafscii
+etc/yafApplabelRules.conf
+include/airframe/airlock.h
+include/airframe/airopt.h
+include/airframe/airutil.h
+include/airframe/autoinc.h
+include/airframe/daeconfig.h
+include/airframe/logconfig.h
+include/airframe/mio.h
+include/airframe/mio_config.h
+include/airframe/mio_sink_file.h
+include/airframe/mio_sink_multi.h
+include/airframe/mio_sink_tcp.h
+include/airframe/mio_sink_udp.h
+include/airframe/mio_source_file.h
+include/airframe/mio_source_pcap.h
+include/airframe/mio_source_tcp.h
+include/airframe/mio_source_udp.h
+include/airframe/mio_stdio.h
+include/airframe/privconfig.h
+include/ltdl.h
+include/yaf/autoinc.h
+include/yaf/decode.h
+include/yaf/picq.h
+include/yaf/ring.h
+include/yaf/yafcore.h
+include/yaf/yafrag.h
+include/yaf/yaftab.h
+lib/libairframe-1.0.0.2.so
+lib/libairframe-1.0.0.2.so.4
+lib/libairframe.a
+lib/libairframe.la
+lib/libairframe.so
+lib/libltdl.a
+lib/libltdl.la
+lib/libltdl.so.4.0
+lib/libyaf-1.0.0.2.so
+lib/libyaf-1.0.0.2.so.4
+lib/libyaf.a
+lib/libyaf.la
+lib/libyaf.so
+libdata/pkgconfig/libairframe.pc
+libdata/pkgconfig/libyaf.pc
+@dirrm include/yaf
+@dirrm include/airframe