aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/pwlib/Makefile4
-rw-r--r--devel/pwlib/files/patch-src::ptclib::asner.cxx58
-rw-r--r--devel/pwlib152/Makefile4
-rw-r--r--devel/pwlib152/files/patch-src::ptclib::asner.cxx58
-rw-r--r--net/asterisk-bristuff/Makefile1
-rw-r--r--net/asterisk-devel/Makefile1
-rw-r--r--net/asterisk/Makefile1
-rw-r--r--net/asterisk10/Makefile1
-rw-r--r--net/asterisk12/Makefile1
-rw-r--r--net/asterisk14/Makefile1
-rw-r--r--net/asterisk16/Makefile1
-rw-r--r--net/opal/Makefile4
-rw-r--r--net/opal3/Makefile4
-rw-r--r--net/openh323-112/Makefile4
-rw-r--r--net/openh323/Makefile4
15 files changed, 129 insertions, 18 deletions
diff --git a/devel/pwlib/Makefile b/devel/pwlib/Makefile
index 83314a970548..6c1c42b57c5d 100644
--- a/devel/pwlib/Makefile
+++ b/devel/pwlib/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pwlib
PORTVERSION= 1.5.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= devel
MASTER_SITES= http://www.openh323.org/bin/ \
http://www.de.openh323.org/bin/ \
@@ -17,8 +17,6 @@ DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= roger@FreeBSD.org
COMMENT= A cross platform C++ library, used by OpenH323
-FORBIDDEN= http://people.freebsd.org/~eik/portaudit/27c331d5-64c7-11d8-80e3-0020ed76ef5a.html
-
LIB_DEPENDS= expat.5:${PORTSDIR}/textproc/expat2
WRKSRC= ${WRKDIR}/${PORTNAME}
diff --git a/devel/pwlib/files/patch-src::ptclib::asner.cxx b/devel/pwlib/files/patch-src::ptclib::asner.cxx
new file mode 100644
index 000000000000..4776c3cab7f4
--- /dev/null
+++ b/devel/pwlib/files/patch-src::ptclib::asner.cxx
@@ -0,0 +1,58 @@
+
+$FreeBSD$
+
+--- src/ptclib/asner.cxx 2004/06/03 14:44:43 1.1
++++ src/ptclib/asner.cxx 2004/06/03 14:50:35
+@@ -4926,6 +4926,11 @@
+ return -1;
+
+ value += lower;
++
++ // clamp value to upper limit
++ if (value > upper)
++ value = upper;
++
+ return 0;
+ }
+
+@@ -4970,7 +4975,13 @@
+ unsigned base;
+ if (!MultiBitDecode(CountBits(upper - lower + 1), base))
+ return -1;
+- return lower + base; // 10.9.4.1
++ len = lower + base; // 10.9.4.1
++
++ // clamp value to upper limit
++ if (len > upper)
++ len = upper;
++
++ return len;
+ }
+
+ if (upper < 65536) // 10.9.3.3
+@@ -4981,13 +4992,20 @@
+ if (IsAtEnd())
+ return -1;
+
+- if (SingleBitDecode() == 0)
+- return MultiBitDecode(7, len) ? 0 : -1; // 10.9.3.6
++ if (SingleBitDecode() == 0) {
++ if (!MultiBitDecode(7, len)) // 10.9.3.6
++ return -1; // 10.9.3.8 unsupported
++ }
++ else if (SingleBitDecode() == 0) {
++ if (!MultiBitDecode(14, len)) // 10.9.3.7
++ return -1; // 10.9.3.8 unsupported
++ }
+
+- if (SingleBitDecode() == 0)
+- return MultiBitDecode(14, len) ? 0 : -1; // 10.9.3.7
++ // clamp value to upper limit
++ if (len > upper)
++ len = upper;
+
+- return -1; // 10.9.3.8 unsupported
++ return 0;
+ }
+
+
diff --git a/devel/pwlib152/Makefile b/devel/pwlib152/Makefile
index 83314a970548..6c1c42b57c5d 100644
--- a/devel/pwlib152/Makefile
+++ b/devel/pwlib152/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pwlib
PORTVERSION= 1.5.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= devel
MASTER_SITES= http://www.openh323.org/bin/ \
http://www.de.openh323.org/bin/ \
@@ -17,8 +17,6 @@ DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= roger@FreeBSD.org
COMMENT= A cross platform C++ library, used by OpenH323
-FORBIDDEN= http://people.freebsd.org/~eik/portaudit/27c331d5-64c7-11d8-80e3-0020ed76ef5a.html
-
LIB_DEPENDS= expat.5:${PORTSDIR}/textproc/expat2
WRKSRC= ${WRKDIR}/${PORTNAME}
diff --git a/devel/pwlib152/files/patch-src::ptclib::asner.cxx b/devel/pwlib152/files/patch-src::ptclib::asner.cxx
new file mode 100644
index 000000000000..4776c3cab7f4
--- /dev/null
+++ b/devel/pwlib152/files/patch-src::ptclib::asner.cxx
@@ -0,0 +1,58 @@
+
+$FreeBSD$
+
+--- src/ptclib/asner.cxx 2004/06/03 14:44:43 1.1
++++ src/ptclib/asner.cxx 2004/06/03 14:50:35
+@@ -4926,6 +4926,11 @@
+ return -1;
+
+ value += lower;
++
++ // clamp value to upper limit
++ if (value > upper)
++ value = upper;
++
+ return 0;
+ }
+
+@@ -4970,7 +4975,13 @@
+ unsigned base;
+ if (!MultiBitDecode(CountBits(upper - lower + 1), base))
+ return -1;
+- return lower + base; // 10.9.4.1
++ len = lower + base; // 10.9.4.1
++
++ // clamp value to upper limit
++ if (len > upper)
++ len = upper;
++
++ return len;
+ }
+
+ if (upper < 65536) // 10.9.3.3
+@@ -4981,13 +4992,20 @@
+ if (IsAtEnd())
+ return -1;
+
+- if (SingleBitDecode() == 0)
+- return MultiBitDecode(7, len) ? 0 : -1; // 10.9.3.6
++ if (SingleBitDecode() == 0) {
++ if (!MultiBitDecode(7, len)) // 10.9.3.6
++ return -1; // 10.9.3.8 unsupported
++ }
++ else if (SingleBitDecode() == 0) {
++ if (!MultiBitDecode(14, len)) // 10.9.3.7
++ return -1; // 10.9.3.8 unsupported
++ }
+
+- if (SingleBitDecode() == 0)
+- return MultiBitDecode(14, len) ? 0 : -1; // 10.9.3.7
++ // clamp value to upper limit
++ if (len > upper)
++ len = upper;
+
+- return -1; // 10.9.3.8 unsupported
++ return 0;
+ }
+
+
diff --git a/net/asterisk-bristuff/Makefile b/net/asterisk-bristuff/Makefile
index 363d7a4f78b9..161aa46bee94 100644
--- a/net/asterisk-bristuff/Makefile
+++ b/net/asterisk-bristuff/Makefile
@@ -7,6 +7,7 @@
PORTNAME= asterisk
PORTVERSION= 0.9.0
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ftp://ftp.asterisk.org/pub/telephony/asterisk/ \
ftp://ftp.asterisk.org/pub/telephony/asterisk/old-releases/
diff --git a/net/asterisk-devel/Makefile b/net/asterisk-devel/Makefile
index 363d7a4f78b9..161aa46bee94 100644
--- a/net/asterisk-devel/Makefile
+++ b/net/asterisk-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= asterisk
PORTVERSION= 0.9.0
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ftp://ftp.asterisk.org/pub/telephony/asterisk/ \
ftp://ftp.asterisk.org/pub/telephony/asterisk/old-releases/
diff --git a/net/asterisk/Makefile b/net/asterisk/Makefile
index 363d7a4f78b9..161aa46bee94 100644
--- a/net/asterisk/Makefile
+++ b/net/asterisk/Makefile
@@ -7,6 +7,7 @@
PORTNAME= asterisk
PORTVERSION= 0.9.0
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ftp://ftp.asterisk.org/pub/telephony/asterisk/ \
ftp://ftp.asterisk.org/pub/telephony/asterisk/old-releases/
diff --git a/net/asterisk10/Makefile b/net/asterisk10/Makefile
index 363d7a4f78b9..161aa46bee94 100644
--- a/net/asterisk10/Makefile
+++ b/net/asterisk10/Makefile
@@ -7,6 +7,7 @@
PORTNAME= asterisk
PORTVERSION= 0.9.0
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ftp://ftp.asterisk.org/pub/telephony/asterisk/ \
ftp://ftp.asterisk.org/pub/telephony/asterisk/old-releases/
diff --git a/net/asterisk12/Makefile b/net/asterisk12/Makefile
index 363d7a4f78b9..161aa46bee94 100644
--- a/net/asterisk12/Makefile
+++ b/net/asterisk12/Makefile
@@ -7,6 +7,7 @@
PORTNAME= asterisk
PORTVERSION= 0.9.0
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ftp://ftp.asterisk.org/pub/telephony/asterisk/ \
ftp://ftp.asterisk.org/pub/telephony/asterisk/old-releases/
diff --git a/net/asterisk14/Makefile b/net/asterisk14/Makefile
index 363d7a4f78b9..161aa46bee94 100644
--- a/net/asterisk14/Makefile
+++ b/net/asterisk14/Makefile
@@ -7,6 +7,7 @@
PORTNAME= asterisk
PORTVERSION= 0.9.0
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ftp://ftp.asterisk.org/pub/telephony/asterisk/ \
ftp://ftp.asterisk.org/pub/telephony/asterisk/old-releases/
diff --git a/net/asterisk16/Makefile b/net/asterisk16/Makefile
index 363d7a4f78b9..161aa46bee94 100644
--- a/net/asterisk16/Makefile
+++ b/net/asterisk16/Makefile
@@ -7,6 +7,7 @@
PORTNAME= asterisk
PORTVERSION= 0.9.0
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ftp://ftp.asterisk.org/pub/telephony/asterisk/ \
ftp://ftp.asterisk.org/pub/telephony/asterisk/old-releases/
diff --git a/net/opal/Makefile b/net/opal/Makefile
index d5ce2ec75d4d..e3117e0bfb3c 100644
--- a/net/opal/Makefile
+++ b/net/opal/Makefile
@@ -7,7 +7,7 @@
PORTNAME= openh323
PORTVERSION= 1.12.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net
MASTER_SITES= http://www.openh323.org/bin/ \
http://www.de.openh323.org/bin/ \
@@ -17,8 +17,6 @@ DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= roger@FreeBSD.org
COMMENT= A H323 Video Conferencing library
-FORBIDDEN= http://people.freebsd.org/~eik/portaudit/27c331d5-64c7-11d8-80e3-0020ed76ef5a.html
-
BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/devel/pwlib:build
LIB_DEPENDS= expat.5:${PORTSDIR}/textproc/expat2
diff --git a/net/opal3/Makefile b/net/opal3/Makefile
index d5ce2ec75d4d..e3117e0bfb3c 100644
--- a/net/opal3/Makefile
+++ b/net/opal3/Makefile
@@ -7,7 +7,7 @@
PORTNAME= openh323
PORTVERSION= 1.12.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net
MASTER_SITES= http://www.openh323.org/bin/ \
http://www.de.openh323.org/bin/ \
@@ -17,8 +17,6 @@ DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= roger@FreeBSD.org
COMMENT= A H323 Video Conferencing library
-FORBIDDEN= http://people.freebsd.org/~eik/portaudit/27c331d5-64c7-11d8-80e3-0020ed76ef5a.html
-
BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/devel/pwlib:build
LIB_DEPENDS= expat.5:${PORTSDIR}/textproc/expat2
diff --git a/net/openh323-112/Makefile b/net/openh323-112/Makefile
index d5ce2ec75d4d..e3117e0bfb3c 100644
--- a/net/openh323-112/Makefile
+++ b/net/openh323-112/Makefile
@@ -7,7 +7,7 @@
PORTNAME= openh323
PORTVERSION= 1.12.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net
MASTER_SITES= http://www.openh323.org/bin/ \
http://www.de.openh323.org/bin/ \
@@ -17,8 +17,6 @@ DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= roger@FreeBSD.org
COMMENT= A H323 Video Conferencing library
-FORBIDDEN= http://people.freebsd.org/~eik/portaudit/27c331d5-64c7-11d8-80e3-0020ed76ef5a.html
-
BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/devel/pwlib:build
LIB_DEPENDS= expat.5:${PORTSDIR}/textproc/expat2
diff --git a/net/openh323/Makefile b/net/openh323/Makefile
index d5ce2ec75d4d..e3117e0bfb3c 100644
--- a/net/openh323/Makefile
+++ b/net/openh323/Makefile
@@ -7,7 +7,7 @@
PORTNAME= openh323
PORTVERSION= 1.12.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net
MASTER_SITES= http://www.openh323.org/bin/ \
http://www.de.openh323.org/bin/ \
@@ -17,8 +17,6 @@ DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= roger@FreeBSD.org
COMMENT= A H323 Video Conferencing library
-FORBIDDEN= http://people.freebsd.org/~eik/portaudit/27c331d5-64c7-11d8-80e3-0020ed76ef5a.html
-
BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/devel/pwlib:build
LIB_DEPENDS= expat.5:${PORTSDIR}/textproc/expat2