aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--math/armadillo/Makefile3
-rw-r--r--math/armadillo/distinfo6
-rw-r--r--math/armadillo/files/patch-CMakeLists.txt2
-rw-r--r--math/armadillo/files/patch-include_armadillo__bits_config.hpp27
-rw-r--r--math/armadillo/pkg-plist8
5 files changed, 40 insertions, 6 deletions
diff --git a/math/armadillo/Makefile b/math/armadillo/Makefile
index 8d260f112cc9..e0bfbeba7888 100644
--- a/math/armadillo/Makefile
+++ b/math/armadillo/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= armadillo
-PORTVERSION= 7.100.3
+PORTVERSION= 7.300.1
CATEGORIES= math
MASTER_SITES= SF/arma
@@ -11,6 +11,7 @@ COMMENT= C++ linear algebra library
LICENSE= MPL
LIB_DEPENDS= libboost_date_time.so:devel/boost-libs \
+ libopenblasp.so:math/openblas \
libarpack.so:math/arpack \
libhdf5.so:science/hdf5 \
libsuperlu.so:math/superlu
diff --git a/math/armadillo/distinfo b/math/armadillo/distinfo
index fc381711e75d..6b2aea6c944b 100644
--- a/math/armadillo/distinfo
+++ b/math/armadillo/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1465123703
-SHA256 (armadillo-7.100.3.tar.xz) = 3fa4a2f84b54d48260efd587d7e6290618bc909d191bec0a3084a890af699d1e
-SIZE (armadillo-7.100.3.tar.xz) = 3715272
+TIMESTAMP = 1470241704
+SHA256 (armadillo-7.300.1.tar.xz) = 5404744e89294ad9d47d651f2f95325840ba268b7fe374e2e40ef217d2f44bce
+SIZE (armadillo-7.300.1.tar.xz) = 3994936
diff --git a/math/armadillo/files/patch-CMakeLists.txt b/math/armadillo/files/patch-CMakeLists.txt
index 2d047d5d5ee8..445cf3f7174a 100644
--- a/math/armadillo/files/patch-CMakeLists.txt
+++ b/math/armadillo/files/patch-CMakeLists.txt
@@ -1,4 +1,4 @@
---- CMakeLists.txt.orig 2016-05-25 08:46:44 UTC
+--- CMakeLists.txt.orig 2016-06-16 16:16:01 UTC
+++ CMakeLists.txt
@@ -368,12 +368,12 @@ if(NOT INSTALL_LIB_DIR)
message(STATUS "*** Detected 64 bit system")
diff --git a/math/armadillo/files/patch-include_armadillo__bits_config.hpp b/math/armadillo/files/patch-include_armadillo__bits_config.hpp
new file mode 100644
index 000000000000..c0e8b98954a2
--- /dev/null
+++ b/math/armadillo/files/patch-include_armadillo__bits_config.hpp
@@ -0,0 +1,27 @@
+--- include/armadillo_bits/config.hpp.orig 2016-08-03 19:20:44 UTC
++++ include/armadillo_bits/config.hpp
+@@ -32,13 +32,13 @@
+ #endif
+
+ #if !defined(ARMA_USE_ARPACK)
+-// #define ARMA_USE_ARPACK
++#define ARMA_USE_ARPACK
+ //// Uncomment the above line if you have ARPACK or a high-speed replacement for ARPACK.
+ //// ARPACK is required for eigen decompositions of complex sparse matrices
+ #endif
+
+ #if !defined(ARMA_USE_SUPERLU)
+-// #define ARMA_USE_SUPERLU
++#define ARMA_USE_SUPERLU
+ //// Uncomment the above line if you have SuperLU.
+ //// SuperLU is used for solving sparse linear systems via spsolve()
+ //// Caveat: only SuperLU version 5.2 can be used!
+@@ -76,7 +76,7 @@
+ //// Uncomment the above line if you want to use Intel MKL mkl_malloc() and mkl_free() instead of standard malloc() and free()
+
+ // #define ARMA_USE_ATLAS
+-// #define ARMA_ATLAS_INCLUDE_DIR /usr/include/
++#define ARMA_ATLAS_INCLUDE_DIR /usr/local/include/
+ //// If you're using ATLAS and the compiler can't find cblas.h and/or clapack.h
+ //// uncomment the above define and specify the appropriate include directory.
+ //// Make sure the directory has a trailing /
diff --git a/math/armadillo/pkg-plist b/math/armadillo/pkg-plist
index 9c49691aa633..c46075184d7d 100644
--- a/math/armadillo/pkg-plist
+++ b/math/armadillo/pkg-plist
@@ -137,6 +137,8 @@ include/armadillo_bits/fn_find_unique.hpp
include/armadillo_bits/fn_flip.hpp
include/armadillo_bits/fn_hist.hpp
include/armadillo_bits/fn_histc.hpp
+include/armadillo_bits/fn_index_max.hpp
+include/armadillo_bits/fn_index_min.hpp
include/armadillo_bits/fn_inplace_strans.hpp
include/armadillo_bits/fn_inplace_trans.hpp
include/armadillo_bits/fn_interp1.hpp
@@ -323,6 +325,10 @@ include/armadillo_bits/op_hist_bones.hpp
include/armadillo_bits/op_hist_meat.hpp
include/armadillo_bits/op_htrans_bones.hpp
include/armadillo_bits/op_htrans_meat.hpp
+include/armadillo_bits/op_index_max_bones.hpp
+include/armadillo_bits/op_index_max_meat.hpp
+include/armadillo_bits/op_index_min_bones.hpp
+include/armadillo_bits/op_index_min_meat.hpp
include/armadillo_bits/op_inv_bones.hpp
include/armadillo_bits/op_inv_meat.hpp
include/armadillo_bits/op_logmat_bones.hpp
@@ -474,7 +480,7 @@ include/armadillo_bits/xvec_htrans_bones.hpp
include/armadillo_bits/xvec_htrans_meat.hpp
lib/libarmadillo.so
lib/libarmadillo.so.7
-lib/libarmadillo.so.7.100.3
+lib/libarmadillo.so.7.300.0
share/Armadillo/CMake/ArmadilloConfig.cmake
share/Armadillo/CMake/ArmadilloConfigVersion.cmake
share/Armadillo/CMake/ArmadilloLibraryDepends-release.cmake