aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--x11/Makefile1
-rw-r--r--x11/metalock/Makefile62
-rw-r--r--x11/metalock/distinfo4
-rw-r--r--x11/metalock/pkg-descr16
-rw-r--r--x11/metalock/pkg-plist7
5 files changed, 90 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 9f52beb4c30f..ea44b54be716 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -194,6 +194,7 @@
SUBDIR += lxmenu-data
SUBDIR += lxpanel
SUBDIR += menu-cache
+ SUBDIR += metalock
SUBDIR += metisse
SUBDIR += mgapdesk
SUBDIR += mkcomposecache
diff --git a/x11/metalock/Makefile b/x11/metalock/Makefile
new file mode 100644
index 000000000000..6d63e601f88d
--- /dev/null
+++ b/x11/metalock/Makefile
@@ -0,0 +1,62 @@
+# New ports collection makefile for: metalock
+# Date created: 21 March 2012
+# Whom: Timothy Beyer <beyert@cs.ucr.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= metalock
+PORTVERSION= 0.8.0
+CATEGORIES= x11
+MASTER_SITES= BERLIOS GOOGLE_CODE
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
+ ${PORTNAME}_theme-Blue_Marble-1.3${EXTRACT_SUFX}
+
+MAINTAINER= beyert@cs.ucr.edu
+COMMENT= Enhanced X11 screen locker
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKDIR}/${DISTNAME}/LICENSE
+
+FETCH_ARGS= "-Fpr"
+USE_BZIP2= yes
+USE_XORG= x11 xt xproto xext xpm
+
+OPTIONS= IMLIB2 "Use Imlib2" on \
+ XFT "Use Xft Fonts" on \
+ ULTRAGETOPT "Use Ultragetopt" on
+
+.include <bsd.port.options.mk>
+
+.if !defined(WITHOUT_ULTRAGETOPT)
+LIB_DEPENDS+= ultragetopt.0:${PORTSDIR}/devel/ultragetopt
+USE_ULTRAGETOPT= yes
+.else
+USE_ULTRAGETOPT= no
+.endif
+
+.if !defined(WITHOUT_IMLIB2)
+USE_EFL= imlib2
+USE_IMLIB2= yes
+.else
+USE_IMLIB2= no
+.endif
+
+.if !defined(WITHOUT_XFT)
+USE_XORG+= xft
+USE_XFT= yes
+.else
+USE_XFT= no
+.endif
+
+MAKE_ARGS= PREFIX="${LOCALBASE}" DEST_PREFIX="${PREFIX}" CC="${CC}" \
+ USE_XFT="${USE_XFT}" USE_ULTRAGETOPT="${USE_ULTRAGETOPT}" \
+ USE_IMLIB2="${USE_IMLIB2}"
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/src
+
+post-extract:
+ ${MKDIR} ${WRKDIR}/${DISTNAME}/themes
+ ${CP} -pR ${WRKDIR}/Blue_Marble ${WRKDIR}/${DISTNAME}/themes/
+
+.include <bsd.port.mk>
diff --git a/x11/metalock/distinfo b/x11/metalock/distinfo
new file mode 100644
index 000000000000..0af0d3b7b109
--- /dev/null
+++ b/x11/metalock/distinfo
@@ -0,0 +1,4 @@
+SHA256 (metalock-0.8.0.tar.bz2) = 5a4a36b909ce8ad29fb84885ab5d978db81b36a3b17336008c8958893838cb12
+SIZE (metalock-0.8.0.tar.bz2) = 11919
+SHA256 (metalock_theme-Blue_Marble-1.3.tar.bz2) = 1ae914460290b637cc505f41d9b7f9884b1a751f3831ab522d8c8089f0499983
+SIZE (metalock_theme-Blue_Marble-1.3.tar.bz2) = 390567
diff --git a/x11/metalock/pkg-descr b/x11/metalock/pkg-descr
new file mode 100644
index 000000000000..a9a4a2421499
--- /dev/null
+++ b/x11/metalock/pkg-descr
@@ -0,0 +1,16 @@
+Metalock is an enhanced screen locker for the X11 windowing system. It is
+designed to be used with a background screen daemon, such as xidle.
+
+Current features include:
+ - Support for pixmap (image) xpm background and login box.
+ - It gives visual feedback as you type the password (Shows username and
+ * for each character of password typed.)
+ - Bind arbitrary commands to key combinations (allows tasks such as
+ pause/un-pause music without unlocking the screen)
+ - Optional XFT support for anti-aliased fonts. (This is optional in case
+ greater security is desired)
+ - Optional Imlib2 support for use of png or jpg formats, which are more
+ appropriate for photos or high-color images than xpm.
+ - Portable to most UNIX-like operating systems, developed on FreeBSD.
+
+WWW: http://chiselapp.com/user/beyert/repository/metalock/
diff --git a/x11/metalock/pkg-plist b/x11/metalock/pkg-plist
new file mode 100644
index 000000000000..e5162143e8e6
--- /dev/null
+++ b/x11/metalock/pkg-plist
@@ -0,0 +1,7 @@
+bin/metalock
+%%DATADIR%%/themes/Blue_Marble/bg.xpm.gz
+%%DATADIR%%/themes/Blue_Marble/box.xpm.gz
+%%DATADIR%%/themes/Blue_Marble/metadata.mk
+@dirrmtry %%DATADIR%%/themes/Blue_Marble
+@dirrmtry %%DATADIR%%/themes
+@dirrmtry %%DATADIR%%