aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--audio/libfishsound/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/audio/libfishsound/Makefile b/audio/libfishsound/Makefile
index eaa778b0a640..d599d5cca36a 100644
--- a/audio/libfishsound/Makefile
+++ b/audio/libfishsound/Makefile
@@ -21,15 +21,13 @@ OPTIONS_DEFINE= DOCS DOXYGEN
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-#NO_STAGE= yes
USES= pathfix pkgconfig
-PORTDOCS= *
-
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDOCS} && ${PORT_OPTIONS:MDOXYGEN}
BUILD_DEPENDS+= ${LOCALBASE}/bin/doxygen:${PORTSDIR}/devel/doxygen
+PORTDOCS= *
.endif
post-patch:
@@ -37,4 +35,7 @@ post-patch:
@${REINPLACE_CMD} -e '/^SUBDIRS = / s| doc||' ${WRKSRC}/Makefile.in
.endif
+post-build:
+ @${STRIP_CMD} ${WRKSRC}/src/libfishsound/.libs/libfishsound.so.4
+
.include <bsd.port.mk>