aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-Parse-CSV/Makefile25
-rw-r--r--textproc/p5-Parse-CSV/distinfo3
-rw-r--r--textproc/p5-Parse-CSV/pkg-descr19
-rw-r--r--textproc/p5-Parse-CSV/pkg-plist6
5 files changed, 54 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 1cf0ccc1cfb9..6cb30b577330 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -400,6 +400,7 @@
SUBDIR += p5-POSIX-Regex
SUBDIR += p5-PPI
SUBDIR += p5-PPI-HTML
+ SUBDIR += p5-Parse-CSV
SUBDIR += p5-Parse-FixedLength
SUBDIR += p5-Parse-Flex
SUBDIR += p5-Parse-PhoneNumber
diff --git a/textproc/p5-Parse-CSV/Makefile b/textproc/p5-Parse-CSV/Makefile
new file mode 100644
index 000000000000..f945bc40cef5
--- /dev/null
+++ b/textproc/p5-Parse-CSV/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Parse-CSV
+# Date created: 2006-10-19
+# Whom: Jin-Shan Tseng <tjs@cdpa.nsysu.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Parse-CSV
+PORTVERSION= 1.00
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Parse
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tjs@cdpa.nsysu.edu.tw
+COMMENT= Highly flexible CVS parser for large files
+
+RUN_DEPENDS= p5-Text-CSV_XS>=0.23:${PORTSDIR}/textproc/p5-Text-CSV_XS \
+ p5-Params-Util>=0.17:${PORTSDIR}/devel/p5-Params-Util
+
+PERL_CONFIGURE= yes
+
+MAN3= Parse::CSV.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-Parse-CSV/distinfo b/textproc/p5-Parse-CSV/distinfo
new file mode 100644
index 000000000000..990a534697b5
--- /dev/null
+++ b/textproc/p5-Parse-CSV/distinfo
@@ -0,0 +1,3 @@
+MD5 (Parse-CSV-1.00.tar.gz) = 16089fae987c5d52c0a13acdfc478632
+SHA256 (Parse-CSV-1.00.tar.gz) = 2328a28e58929d2bfdcd143aa4c3c03400e25b4aac7c4969885e81d2bba04442
+SIZE (Parse-CSV-1.00.tar.gz) = 25448
diff --git a/textproc/p5-Parse-CSV/pkg-descr b/textproc/p5-Parse-CSV/pkg-descr
new file mode 100644
index 000000000000..71b3839a08fc
--- /dev/null
+++ b/textproc/p5-Parse-CSV/pkg-descr
@@ -0,0 +1,19 @@
+Surely the CPAN doesn't need yet another CSV parsing module.
+
+Text::CSV_XS is the standard parser for CSV files. It is fast
+as hell, but unfortunately it can be a bit verbose to use.
+
+A number of other modules have attempted to put usability
+wrappers around this venerable module, but they have all
+focussed on parsing the entire file into memory at once.
+
+This method is fine unless your CSV files start to get large.
+Once that happens, the only existing option is to fall back
+on the relatively slow and heavyweight XML::SAXDriver::CSV
+module.
+
+Parse::CSV fills this functionality gap. It provides a flexible
+and light-weight streaming parser for large, extremely large,
+or arbitrarily large CSV files.
+
+WWW: http://search.cpan.org/dist/Parse-CSV/
diff --git a/textproc/p5-Parse-CSV/pkg-plist b/textproc/p5-Parse-CSV/pkg-plist
new file mode 100644
index 000000000000..c094468bde70
--- /dev/null
+++ b/textproc/p5-Parse-CSV/pkg-plist
@@ -0,0 +1,6 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/Parse/CSV.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Parse/CSV/.packlist
+@dirrmtry %%SITE_PERL%%/Parse
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Parse/CSV
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Parse