aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-AnyEvent-Gearman/Makefile37
-rw-r--r--devel/p5-AnyEvent-Gearman/distinfo2
-rw-r--r--devel/p5-AnyEvent-Gearman/pkg-descr4
-rw-r--r--devel/p5-AnyEvent-Gearman/pkg-plist18
5 files changed, 62 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index cd08b1d57e64..4ee1a7f01027 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1264,6 +1264,7 @@
SUBDIR += p5-AnyEvent-DBI-Abstract
SUBDIR += p5-AnyEvent-DBus
SUBDIR += p5-AnyEvent-Filesys-Notify
+ SUBDIR += p5-AnyEvent-Gearman
SUBDIR += p5-AnyEvent-Graphite
SUBDIR += p5-AnyEvent-I3
SUBDIR += p5-AnyEvent-Run
diff --git a/devel/p5-AnyEvent-Gearman/Makefile b/devel/p5-AnyEvent-Gearman/Makefile
new file mode 100644
index 000000000000..0bc9be5b9a53
--- /dev/null
+++ b/devel/p5-AnyEvent-Gearman/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: p5-AnyEvent-Gearman
+# Date created: 2012-04-15
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= AnyEvent-Gearman
+PORTVERSION= 0.09
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Asynchronous Gearman client/worker module for AnyEvent applications
+
+RUN_DEPENDS= p5-Any-Moose>=0:${PORTSDIR}/devel/p5-Any-Moose \
+ p5-AnyEvent>=0:${PORTSDIR}/devel/p5-AnyEvent \
+ p5-Mouse>=0:${PORTSDIR}/devel/p5-Mouse \
+ p5-MouseX-Foreign>=0:${PORTSDIR}/devel/p5-MouseX-Foreign \
+ p5-Object-Container>=0:${PORTSDIR}/devel/p5-Object-Container \
+ p5-Object-Event>=0:${PORTSDIR}/devel/p5-Object-Event
+
+PERL_CONFIGURE= yes
+
+MAN3= AnyEvent::Gearman.3 \
+ AnyEvent::Gearman::Client.3 \
+ AnyEvent::Gearman::Client::Connection.3 \
+ AnyEvent::Gearman::Connection.3 \
+ AnyEvent::Gearman::Constants.3 \
+ AnyEvent::Gearman::Job.3 \
+ AnyEvent::Gearman::Task.3 \
+ AnyEvent::Gearman::Types.3 \
+ AnyEvent::Gearman::Worker.3 \
+ AnyEvent::Gearman::Worker::Connection.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-AnyEvent-Gearman/distinfo b/devel/p5-AnyEvent-Gearman/distinfo
new file mode 100644
index 000000000000..40e2d780b75c
--- /dev/null
+++ b/devel/p5-AnyEvent-Gearman/distinfo
@@ -0,0 +1,2 @@
+SHA256 (AnyEvent-Gearman-0.09.tar.gz) = 20d21ae922a4219d0bbe74c287e544bb5f8b373b5ee34ee3a27c2489b40a13d2
+SIZE (AnyEvent-Gearman-0.09.tar.gz) = 65952
diff --git a/devel/p5-AnyEvent-Gearman/pkg-descr b/devel/p5-AnyEvent-Gearman/pkg-descr
new file mode 100644
index 000000000000..f6c122e266e0
--- /dev/null
+++ b/devel/p5-AnyEvent-Gearman/pkg-descr
@@ -0,0 +1,4 @@
+AnyEvent::Gearman is a module set of client/worker modules for Gearman for
+AnyEvent applications.
+
+WWW: http://search.cpan.org/dist/AnyEvent-Gearman/
diff --git a/devel/p5-AnyEvent-Gearman/pkg-plist b/devel/p5-AnyEvent-Gearman/pkg-plist
new file mode 100644
index 000000000000..80aeb452a930
--- /dev/null
+++ b/devel/p5-AnyEvent-Gearman/pkg-plist
@@ -0,0 +1,18 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/AnyEvent/Gearman/.packlist
+%%SITE_PERL%%/AnyEvent/Gearman.pm
+%%SITE_PERL%%/AnyEvent/Gearman/Client.pm
+%%SITE_PERL%%/AnyEvent/Gearman/Client/Connection.pm
+%%SITE_PERL%%/AnyEvent/Gearman/Connection.pm
+%%SITE_PERL%%/AnyEvent/Gearman/Constants.pm
+%%SITE_PERL%%/AnyEvent/Gearman/Job.pm
+%%SITE_PERL%%/AnyEvent/Gearman/Task.pm
+%%SITE_PERL%%/AnyEvent/Gearman/Types.pm
+%%SITE_PERL%%/AnyEvent/Gearman/Worker.pm
+%%SITE_PERL%%/AnyEvent/Gearman/Worker/Connection.pm
+@dirrmtry %%SITE_PERL%%/AnyEvent/Gearman/Worker
+@dirrmtry %%SITE_PERL%%/AnyEvent/Gearman/Client
+@dirrmtry %%SITE_PERL%%/AnyEvent/Gearman
+@dirrmtry %%SITE_PERL%%/AnyEvent
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/AnyEvent/Gearman
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/AnyEvent