aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--dns/bind910/Makefile2
-rw-r--r--dns/bind910/files/named.in9
-rw-r--r--dns/bind98/Makefile2
-rw-r--r--dns/bind98/files/named.in9
-rw-r--r--dns/bind99/Makefile2
-rw-r--r--dns/bind99/files/named.in9
6 files changed, 27 insertions, 6 deletions
diff --git a/dns/bind910/Makefile b/dns/bind910/Makefile
index 9e77fc0fe48b..5ec60754ce84 100644
--- a/dns/bind910/Makefile
+++ b/dns/bind910/Makefile
@@ -2,7 +2,7 @@
PORTNAME= bind
PORTVERSION= 9.10.0rc1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= dns net ipv6
MASTER_SITES= ${MASTER_SITE_ISC}
MASTER_SITE_SUBDIR= bind9/${ISCVERSION}
diff --git a/dns/bind910/files/named.in b/dns/bind910/files/named.in
index 7dc9329dcd4b..3207d3005f42 100644
--- a/dns/bind910/files/named.in
+++ b/dns/bind910/files/named.in
@@ -19,7 +19,7 @@ extra_commands=reload
start_precmd=named_prestart
start_postcmd=named_poststart
-reload_cmd="${command%/named}/rndc reload"
+reload_cmd=named_reload
stop_cmd=named_stop
named_enable=${named_enable:-"NO"} # Run named, the DNS server (or NO).
@@ -44,6 +44,13 @@ named_poststart()
fi
}
+named_reload()
+{
+ # This is a one line function, but ${command} is not defined early
+ # enough to be there when the reload_cmd variable is defined up there.
+ ${command%/named}/rndc reload
+}
+
find_pidfile()
{
if get_pidfile_from_conf pid-file $named_conf; then
diff --git a/dns/bind98/Makefile b/dns/bind98/Makefile
index 255dca447275..687749462858 100644
--- a/dns/bind98/Makefile
+++ b/dns/bind98/Makefile
@@ -2,7 +2,7 @@
PORTNAME= bind
PORTVERSION= 9.8.7
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= dns net ipv6
MASTER_SITES= ${MASTER_SITE_ISC}
MASTER_SITE_SUBDIR= bind9/${ISCVERSION}
diff --git a/dns/bind98/files/named.in b/dns/bind98/files/named.in
index 1411dfbe59b1..23296546f148 100644
--- a/dns/bind98/files/named.in
+++ b/dns/bind98/files/named.in
@@ -19,7 +19,7 @@ extra_commands=reload
start_precmd=named_prestart
start_postcmd=named_poststart
-reload_cmd="${command%/named}/rndc reload"
+reload_cmd=named_reload
stop_cmd=named_stop
named_enable=${named_enable:-"NO"} # Run named, the DNS server (or NO).
@@ -43,6 +43,13 @@ named_poststart()
fi
}
+named_reload()
+{
+ # This is a one line function, but ${command} is not defined early
+ # enough to be there when the reload_cmd variable is defined up there.
+ ${command%/named}/rndc reload
+}
+
find_pidfile()
{
if get_pidfile_from_conf pid-file $named_conf; then
diff --git a/dns/bind99/Makefile b/dns/bind99/Makefile
index 78e1f0081e88..9a7931ce223b 100644
--- a/dns/bind99/Makefile
+++ b/dns/bind99/Makefile
@@ -2,7 +2,7 @@
PORTNAME= bind
PORTVERSION= 9.9.5
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES= dns net ipv6
MASTER_SITES= ${MASTER_SITE_ISC}
MASTER_SITE_SUBDIR= bind9/${ISCVERSION}
diff --git a/dns/bind99/files/named.in b/dns/bind99/files/named.in
index 1411dfbe59b1..23296546f148 100644
--- a/dns/bind99/files/named.in
+++ b/dns/bind99/files/named.in
@@ -19,7 +19,7 @@ extra_commands=reload
start_precmd=named_prestart
start_postcmd=named_poststart
-reload_cmd="${command%/named}/rndc reload"
+reload_cmd=named_reload
stop_cmd=named_stop
named_enable=${named_enable:-"NO"} # Run named, the DNS server (or NO).
@@ -43,6 +43,13 @@ named_poststart()
fi
}
+named_reload()
+{
+ # This is a one line function, but ${command} is not defined early
+ # enough to be there when the reload_cmd variable is defined up there.
+ ${command%/named}/rndc reload
+}
+
find_pidfile()
{
if get_pidfile_from_conf pid-file $named_conf; then