aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--dns/dualserver/Makefile9
-rw-r--r--dns/dualserver/distinfo6
-rw-r--r--dns/dualserver/files/extra-patch-dualserver.cpp132
-rw-r--r--dns/dualserver/files/extra-patch-dualserver.h22
4 files changed, 83 insertions, 86 deletions
diff --git a/dns/dualserver/Makefile b/dns/dualserver/Makefile
index afdebf451a52..e046540e9b05 100644
--- a/dns/dualserver/Makefile
+++ b/dns/dualserver/Makefile
@@ -4,7 +4,7 @@
# $FreeBSD$
PORTNAME= dualserver
-PORTVERSION= 1.0
+PORTVERSION= 2.0
CATEGORIES= dns net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= dhcp-dns-server
@@ -13,7 +13,6 @@ DISTNAME= ${PORTNAME}V${PORTVERSION}
MAINTAINER= gkovesdan@t-hosting.hu
COMMENT= Combined DHCP/DNS server for small LANs
-USE_REINPLACE= YES
USE_RC_SUBR= dualserver.sh
WRKSRC= ${WRKDIR}/${PORTNAME}
PLIST_FILES= sbin/dualserver etc/dualserver.conf.sample
@@ -25,10 +24,8 @@ EXTRA_PATCHES+= ${FILESDIR}/extra-patch-dualserver.h \
${FILESDIR}/extra-patch-dualserver.cpp
.endif
-post-patch:
- ${REINPLACE_CMD} 's/[[:cntrl:]]*$$//' ${WRKSRC}/dualserver.cpp
- ${REINPLACE_CMD} 's/[[:cntrl:]]*$$//' ${WRKSRC}/dualserver.h
- ${REINPLACE_CMD} 's/[[:cntrl:]]*$$//' ${WRKSRC}/dualserver.ini
+pre-patch:
+ ${REINPLACE_CMD} 's/[[:cntrl:]]*$$//' ${WRKSRC}/*
${REINPLACE_CMD} 's|/etc/dualserver.ini|${PREFIX}/etc/dualserver.conf|' ${WRKSRC}/dualserver.cpp
${REINPLACE_CMD} 's|/etc/dualserver.state|/var/run/dualserver.state|' ${WRKSRC}/dualserver.cpp
diff --git a/dns/dualserver/distinfo b/dns/dualserver/distinfo
index 00657652ef25..2cd684d8b013 100644
--- a/dns/dualserver/distinfo
+++ b/dns/dualserver/distinfo
@@ -1,3 +1,3 @@
-MD5 (dualserverV1.0.tar.gz) = 279703af257c78a0f123cec194d8bdb8
-SHA256 (dualserverV1.0.tar.gz) = 37d0c6f8fd802bc94badae6b6043e3754ab5fa6781a271e8503457ca7d0faf8a
-SIZE (dualserverV1.0.tar.gz) = 39140
+MD5 (dualserverV2.0.tar.gz) = de37780d54f0b462e7bfc84503049605
+SHA256 (dualserverV2.0.tar.gz) = c6f96cbc1782cbd0813e1af10ebeba5949232369187a981d1a7a939dcd01154d
+SIZE (dualserverV2.0.tar.gz) = 49200
diff --git a/dns/dualserver/files/extra-patch-dualserver.cpp b/dns/dualserver/files/extra-patch-dualserver.cpp
index 2cedfe5194de..683447d9f554 100644
--- a/dns/dualserver/files/extra-patch-dualserver.cpp
+++ b/dns/dualserver/files/extra-patch-dualserver.cpp
@@ -1,66 +1,66 @@
---- dualserver.cpp.orig Mon Dec 12 10:41:03 2005
-+++ dualserver.cpp Mon Dec 12 10:43:53 2005
-@@ -349,8 +349,8 @@
- else
- {
- req->dnsp.header.ancount = 0;
-- req->dnsp.header.rcode = 3;
-- req->dnsp.header.ra = 0;
-+ req->dnsp.header.flags.rcode = 3;
-+ req->dnsp.header.flags.ra = 0;
- }
-
- if (cfig->servers[0])
-@@ -364,8 +364,8 @@
- req->dnsp.header.adcount = 0;
- }
-
-- req->dnsp.header.qr = 1;
-- req->dnsp.header.aa = 1;
-+ req->dnsp.header.flags.qr = 1;
-+ req->dnsp.header.flags.aa = 1;
-
- char *raw = req->dnsp.data;
-
-@@ -495,7 +495,7 @@
- if (!cfig->servers[0])
- glocal(cfig);
-
-- if (ntohs(req->dnsp.header.qdcount) == 1 && ntohs(req->dnsp.header.opcode) == 0)
-+ if (ntohs(req->dnsp.header.qdcount) == 1 && ntohs(req->dnsp.header.flags.opcode) == 0)
- {
- char *raw = req->dnsp.data;
- strcpy(req->raw_query, raw);
-@@ -619,7 +619,7 @@
-
- WORD fdnmess(data5 *req, data2 *cfig)
- {
-- if (!req->dnsp.header.rd)
-+ if (!req->dnsp.header.flags.rd)
- return 0;
-
- if (!cfig->dns[0])
-@@ -679,10 +679,10 @@
- else
- {
- req->dnsp.header.ancount = 0;
-- req->dnsp.header.rcode = 3;
-- req->dnsp.header.ra = 0;
-- req->dnsp.header.qr = 1;
-- req->dnsp.header.aa = 0;
-+ req->dnsp.header.flags.rcode = 3;
-+ req->dnsp.header.flags.ra = 0;
-+ req->dnsp.header.flags.qr = 1;
-+ req->dnsp.header.flags.aa = 0;
- req->BytesReady = req->BytesRecd;
- return 0;
- }
-@@ -754,7 +754,7 @@
- if (!found)
- req->BytesReady = 0;
-
-- req->dnsp.header.aa = 0;
-+ req->dnsp.header.flags.aa = 0;
- return req->BytesReady;
- }
-
+--- dualserver.cpp.orig Sun Apr 30 15:32:37 2006
++++ dualserver.cpp Sun Apr 30 15:36:39 2006
+@@ -463,8 +463,8 @@
+ if (!req->rtype)
+ {
+ req->dnsp.header.ancount = 0;
+- req->dnsp.header.rcode = 3;
+- req->dnsp.header.ra = 0;
++ req->dnsp.header.flags.rcode = 3;
++ req->dnsp.header.flags.ra = 0;
+ }
+
+ if (cfig->servers[0])
+@@ -478,8 +478,8 @@
+ req->dnsp.header.adcount = 0;
+ }
+
+- req->dnsp.header.qr = 1;
+- req->dnsp.header.aa = 1;
++ req->dnsp.header.flags.qr = 1;
++ req->dnsp.header.flags.aa = 1;
+
+ char *raw = req->dnsp.data;
+
+@@ -649,7 +649,7 @@
+ if (!cfig->dns[0])
+ getdnserv(cfig);
+
+- if (ntohs(req->dnsp.header.qdcount) == 1 && ntohs(req->dnsp.header.opcode) == 0)
++ if (ntohs(req->dnsp.header.qdcount) == 1 && ntohs(req->dnsp.header.flags.opcode) == 0)
+ {
+ char *raw = req->dnsp.data;
+ fQu(req->query, &req->dnsp, raw);
+@@ -853,7 +853,7 @@
+
+ WORD fdnmess(data5 *req, data2 *cfig)
+ {
+- if (!req->dnsp.header.rd)
++ if (!req->dnsp.header.flags.rd)
+ return 0;
+
+ if (!cfig->dns[0])
+@@ -923,10 +923,10 @@
+ else
+ {
+ req->dnsp.header.ancount = 0;
+- req->dnsp.header.rcode = 3;
+- req->dnsp.header.ra = 0;
+- req->dnsp.header.qr = 1;
+- req->dnsp.header.aa = 0;
++ req->dnsp.header.flags.rcode = 3;
++ req->dnsp.header.flags.ra = 0;
++ req->dnsp.header.flags.qr = 1;
++ req->dnsp.header.flags.aa = 0;
+ char *dp = req->dnsp.data;
+ dp += pQu(dp, req->query);
+ dp += pShort(dp, DNS_TYPE_A);
+@@ -1106,7 +1106,7 @@
+ if (!found)
+ req->bytes = 0;
+
+- req->dnsp.header.aa = 0;
++ req->dnsp.header.flags.aa = 0;
+ return req->bytes;
+ }
+
diff --git a/dns/dualserver/files/extra-patch-dualserver.h b/dns/dualserver/files/extra-patch-dualserver.h
index e9b922fb68c8..f1d0cf494f95 100644
--- a/dns/dualserver/files/extra-patch-dualserver.h
+++ b/dns/dualserver/files/extra-patch-dualserver.h
@@ -1,11 +1,11 @@
---- dualserver.h.orig Mon Dec 12 10:40:55 2005
-+++ dualserver.h Mon Dec 12 10:41:23 2005
-@@ -94,7 +94,7 @@
- BYTE rcode:4;
- BYTE z:3;
- BYTE ra:1;
-- };
-+ } flags;
- };
- union {
- WORD zcount;
+--- dualserver.h.orig Sun Apr 30 11:33:14 2006
++++ dualserver.h Sun Apr 30 11:33:37 2006
+@@ -98,7 +98,7 @@
+ BYTE rcode: 4;
+ BYTE z: 3;
+ BYTE ra: 1;
+- };
++ } flags;
+ };
+ union {
+ WORD zcount;