aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--databases/Makefile1
-rw-r--r--databases/qt-ibase-plugin/Makefile18
-rw-r--r--databases/qt-ibase-plugin/pkg-descr4
-rw-r--r--databases/qt-ibase-plugin/pkg-plist2
4 files changed, 25 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 96b817653d83..b2ecb00e01f3 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -223,6 +223,7 @@
SUBDIR += py-sybase
SUBDIR += pydbdesigner
SUBDIR += qdbm
+ SUBDIR += qt-ibase-plugin
SUBDIR += qt-mysql-plugin
SUBDIR += qt-odbc-plugin
SUBDIR += qt-pgsql-plugin
diff --git a/databases/qt-ibase-plugin/Makefile b/databases/qt-ibase-plugin/Makefile
new file mode 100644
index 000000000000..489ab5ceef9c
--- /dev/null
+++ b/databases/qt-ibase-plugin/Makefile
@@ -0,0 +1,18 @@
+# -*-mode: makefile-*-
+# New ports collection makefile for: qt-ibase-plugin
+# Date created: 27 February 2004
+# Whom: Michael Nottebrock <lofi@freebsd.org>
+#
+# $FreeBSD$
+#
+
+MAINTAINER= kde@freebsd.org
+COMMENT= A plugin for QT to connect to IBase/Firebird-Databases
+
+LIB_DEPENDS+= gds:${PORTSDIR}/databases/firebird
+
+DB= ibase
+
+DESCR= ${PORTSDIR}/databases/qt-ibase-plugin/pkg-descr
+
+.include "../qt-mysql-plugin/Makefile.dbplugin"
diff --git a/databases/qt-ibase-plugin/pkg-descr b/databases/qt-ibase-plugin/pkg-descr
new file mode 100644
index 000000000000..65136661f810
--- /dev/null
+++ b/databases/qt-ibase-plugin/pkg-descr
@@ -0,0 +1,4 @@
+The IBase/Firebird Plugin from Qt3, which provides an easy access method from
+within Qt applications.
+
+WWW: http://www.trolltech.com/products/qt/database.html
diff --git a/databases/qt-ibase-plugin/pkg-plist b/databases/qt-ibase-plugin/pkg-plist
new file mode 100644
index 000000000000..c99b046904e8
--- /dev/null
+++ b/databases/qt-ibase-plugin/pkg-plist
@@ -0,0 +1,2 @@
+lib/plugins/sqldrivers/libqsqlibase.so
+@dirrm lib/plugins/sqldrivers