aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--databases/hypertable/Makefile1
-rw-r--r--editors/yzis/Makefile1
-rw-r--r--games/wesnoth-devel/Makefile4
-rw-r--r--irc/quassel/Makefile6
-rw-r--r--irc/weechat-devel/Makefile4
-rw-r--r--irc/weechat/Makefile4
-rw-r--r--math/plplot/Makefile4
-rw-r--r--math/rkward-kde4/Makefile4
-rw-r--r--multimedia/gstreamer-qt4/Makefile9
-rw-r--r--net-im/qutim/Makefile1
-rw-r--r--science/kst2/Makefile2
-rw-r--r--science/paraview/Makefile8
-rw-r--r--security/quantis/Makefile4
-rw-r--r--textproc/wv2/Makefile8
14 files changed, 1 insertions, 59 deletions
diff --git a/databases/hypertable/Makefile b/databases/hypertable/Makefile
index 86817a4bd4ec..f5b85f97ea31 100644
--- a/databases/hypertable/Makefile
+++ b/databases/hypertable/Makefile
@@ -40,7 +40,6 @@ USE_BDB= yes
WANT_BDB_VER= 48
USE_CMAKE= yes
-CMAKE_BUILD_TYPE= RelWithDebinfo
CMAKE_INSTALL_PREFIX= ${PREFIX}/hypertable
CMAKE_SOURCE_PATH= ${WRKDIR}/${PORTNAME}-${DISTVERSION}
CMAKE_ARGS+= -DINSTALL_EXCLUDE_DEPENDENT_LIBS=1
diff --git a/editors/yzis/Makefile b/editors/yzis/Makefile
index 610d63094184..2e63486c4730 100644
--- a/editors/yzis/Makefile
+++ b/editors/yzis/Makefile
@@ -30,7 +30,6 @@ USE_PERL5= yes
USE_CMAKE= yes
CMAKE_USE_PTHREAD= yes
-CMAKE_BUILD_TYPE= Release
CMAKE_ARGS+= -DLOCALBASE:STRING="${LOCALBASE}" \
-DLUA_INCDIR:STRING="${LUA_INCDIR}" \
-DLUA_LIBDIR:STRING="${LUA_LIBDIR}" \
diff --git a/games/wesnoth-devel/Makefile b/games/wesnoth-devel/Makefile
index 3dc43f87e48d..df2faa39eac6 100644
--- a/games/wesnoth-devel/Makefile
+++ b/games/wesnoth-devel/Makefile
@@ -50,10 +50,6 @@ OPTIONS= ANA "Enable Asynchronous Network API (WIP)" On \
.include <bsd.port.options.mk>
-.if defined(WITH_DEBUG)
-CMAKE_BUILD_TYPE= debug
-.endif
-
# XXX: breaks compilation because of -Werror
.if !defined(WITH_STRICT)
CMAKE_ARGS+= -DENABLE_STRICT_COMPILATION=off
diff --git a/irc/quassel/Makefile b/irc/quassel/Makefile
index 767dac3280f1..3da43c7dc71b 100644
--- a/irc/quassel/Makefile
+++ b/irc/quassel/Makefile
@@ -74,12 +74,6 @@ QUASSEL_CLIENT= OFF
PLIST_SUB+= CLIENT="@comment "
.endif
-.if defined(WITH_DEBUG)
-CMAKE_BUILD_TYPE= RelWithDebugInfo
-.else
-CMAKE_BUILD_TYPE= Release
-.endif
-
pre-configure:
.if defined(WITHOUT_NLS)
${REINPLACE_CMD} -e '/add_subdirectory(i18n)/d' \
diff --git a/irc/weechat-devel/Makefile b/irc/weechat-devel/Makefile
index a16e46ac2b1b..0017cb17a982 100644
--- a/irc/weechat-devel/Makefile
+++ b/irc/weechat-devel/Makefile
@@ -41,10 +41,6 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-6929486
.include <bsd.port.options.mk>
-.if defined(WITH_DEBUG)
-CMAKE_BUILD_TYPE= Debug
-.endif
-
.if defined(WITHOUT_CHARSET)
CMAKE_ARGS+= -DENABLE_CHARSET=no
PLIST_SUB+= CHARSET="@comment "
diff --git a/irc/weechat/Makefile b/irc/weechat/Makefile
index 3507f0eca5bd..9cec4e8e0860 100644
--- a/irc/weechat/Makefile
+++ b/irc/weechat/Makefile
@@ -35,10 +35,6 @@ OPTIONS= RUBY "Ruby scripting support." Off \
.include <bsd.port.options.mk>
-.if defined(WITH_DEBUG)
-CMAKE_BUILD_TYPE= Debug
-.endif
-
.if defined(WITHOUT_CHARSET)
CMAKE_ARGS+= -DENABLE_CHARSET=no
PLIST_SUB+= CHARSET="@comment "
diff --git a/math/plplot/Makefile b/math/plplot/Makefile
index 0c79be276057..6508225bd687 100644
--- a/math/plplot/Makefile
+++ b/math/plplot/Makefile
@@ -106,10 +106,6 @@ PLIST_SUB+= QT="@comment "
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 700000
-BROKEN= does not compile on 6.X
-.endif
-
pre-everything::
@${ECHO_MSG} ""
@${ECHO_MSG} "PLplot has the following tunable options:"
diff --git a/math/rkward-kde4/Makefile b/math/rkward-kde4/Makefile
index ed0c75eccceb..1a381fbcee5f 100644
--- a/math/rkward-kde4/Makefile
+++ b/math/rkward-kde4/Makefile
@@ -47,10 +47,6 @@ BUILD_DEPENDS+= ${LOCALBASE}/share/xml/docbook/4.2/docbookx.dtd:${PORTSDIR}/text
PHP2FIX= rkward/settings/rksettingsmodulephp.cpp
-.if defined(WITH_DEBUG)
-CMAKE_ARGS+= -DCMAKE_BUILD_TYPE=Debug
-.endif
-
pre-configure:
${REINPLACE_CMD} -e 's|/usr/bin/php|${LOCALBASE}/bin/php|' \
${PHP2FIX:S|^|${WRKSRC}/|}
diff --git a/multimedia/gstreamer-qt4/Makefile b/multimedia/gstreamer-qt4/Makefile
index 74a42c0928c5..d1dfb327b5d6 100644
--- a/multimedia/gstreamer-qt4/Makefile
+++ b/multimedia/gstreamer-qt4/Makefile
@@ -30,8 +30,7 @@ USE_QT_VER= 4
QT_COMPONENTS= corelib gui \
qmake_build moc_build rcc_build uic_build
-PLIST_SUB= VERSION="${GST_VERSION}" \
- CMAKE_BUILD_TYPE="${CMAKE_BUILD_TYPE}"
+PLIST_SUB= VERSION="${GST_VERSION}"
GST_VERSION=${PORTVERSION:C/..$//}
@@ -41,12 +40,6 @@ CMAKE_ARGS+= \
-DCMAKE_MODULE_LINKER_FLAGS:STRING="-L${LOCALBASE}/lib" \
-DCMAKE_SHARED_LINKER_FLAGS:STRING="-L${LOCALBASE}/lib"
-.if !defined(WITH_DEBUG)
-CMAKE_BUILD_TYPE= release
-.else
-CMAKE_BUILD_TYPE= debug
-.endif
-
post-extract:
${REINPLACE_CMD} -e 's|$${LIB_INSTALL_DIR}/pkgconfig|libdata/pkgconfig|' \
${WRKSRC}/src/CMakeLists.txt
diff --git a/net-im/qutim/Makefile b/net-im/qutim/Makefile
index 95b925089b34..5d3323f16698 100644
--- a/net-im/qutim/Makefile
+++ b/net-im/qutim/Makefile
@@ -35,7 +35,6 @@ USE_XORG= xscrnsaver
MAKE_JOBS_SAFE= yes
USE_CMAKE= yes
-CMAKE_BUILD_TYPE= DEBUG
CMAKE_USE_PTHREAD= yes
CMAKE_VERBOSE= yes
CMAKE_ARGS+= -DUNIX:BOOL=1 -DBSD:BOOL=1
diff --git a/science/kst2/Makefile b/science/kst2/Makefile
index e49fedc64e88..c81bea5862d1 100644
--- a/science/kst2/Makefile
+++ b/science/kst2/Makefile
@@ -26,8 +26,6 @@ MAKE_JOBS_SAFE= yes
CMAKE_SOURCE_PATH= ${WRKSRC}/cmake
CMAKE_ARGS+= -Dkst_install_prefix=${PREFIX}
-#Kst does not support empty CMAKE_BUILD_TYPE
-CMAKE_BUILD_TYPE= Release
MAN1= kst2.1
diff --git a/science/paraview/Makefile b/science/paraview/Makefile
index 60d77a508413..59d7741d55ce 100644
--- a/science/paraview/Makefile
+++ b/science/paraview/Makefile
@@ -59,14 +59,6 @@ OPTIONS= OSMESA "Use Mesa for off-screen rendering" Off \
VERMAJORMINOR= ${PORTVERSION:R}
-# Temporary workaround until a fix will be committed to bsd.cmake.mk (ports/150363)
-.if defined(WITH_DEBUG)
-CMAKE_BUILD_TYPE?= Debug
-.else
-CMAKE_BUILD_TYPE?= Release
-.endif
-PLIST_SUB+= CMAKE_BUILD_TYPE="${CMAKE_BUILD_TYPE:L}"
-
.include <bsd.port.options.mk>
.if defined(WITH_OSMESA)
diff --git a/security/quantis/Makefile b/security/quantis/Makefile
index 9eabf4af2563..7b245da391e1 100644
--- a/security/quantis/Makefile
+++ b/security/quantis/Makefile
@@ -40,10 +40,6 @@ KMODDIR?= /boot/modules
PORTDOCS= *
PORTEXAMPLES= *
-.if defined(WITH_DEBUG)
-CMAKE_BUILD_TYPE=Debug
-.endif
-
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 700000
diff --git a/textproc/wv2/Makefile b/textproc/wv2/Makefile
index cc2960b0a7a3..a97db95c0102 100644
--- a/textproc/wv2/Makefile
+++ b/textproc/wv2/Makefile
@@ -21,12 +21,4 @@ USE_CMAKE= yes
USE_GMAKE= yes
USE_LDCONFIG= yes
-.if defined(WITH_DEBUG)
-CMAKE_BUILD_TYPE?= Debug
-.else
-CMAKE_BUILD_TYPE?= Release
-.endif
-
-PLIST_SUB= CMAKE_BUILD_TYPE="${CMAKE_BUILD_TYPE:L}"
-
.include <bsd.port.mk>