aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--multimedia/totem/Makefile3
-rw-r--r--multimedia/totem/distinfo4
-rw-r--r--multimedia/totem/files/patch-src_totem-disk.c22
-rw-r--r--multimedia/totem/pkg-plist22
4 files changed, 18 insertions, 33 deletions
diff --git a/multimedia/totem/Makefile b/multimedia/totem/Makefile
index 3aa705546a2f..0a8edd11115f 100644
--- a/multimedia/totem/Makefile
+++ b/multimedia/totem/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= totem
-PORTVERSION= 0.99.19
+PORTVERSION= 0.99.22
CATEGORIES= multimedia gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/...$//}
@@ -23,6 +23,7 @@ USE_X_PREFIX= yes
USE_GNOME= gnomeprefix intlhack gnomehack gnomedesktop desktopfileutils
USE_GMAKE= yes
USE_LIBTOOL_VER=15
+INSTALLS_OMF= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib -lXrandr"
diff --git a/multimedia/totem/distinfo b/multimedia/totem/distinfo
index 5f694a0fe5b8..b19a28ebea0c 100644
--- a/multimedia/totem/distinfo
+++ b/multimedia/totem/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/totem-0.99.19.tar.bz2) = e2d8c6cd39b0843d51d357cc3921873a
-SIZE (gnome2/totem-0.99.19.tar.bz2) = 1062379
+MD5 (gnome2/totem-0.99.22.tar.bz2) = 7843368e1e61921b0ae87a751ad91079
+SIZE (gnome2/totem-0.99.22.tar.bz2) = 1095821
diff --git a/multimedia/totem/files/patch-src_totem-disk.c b/multimedia/totem/files/patch-src_totem-disk.c
index 16213afd535a..f5d9c6848ad8 100644
--- a/multimedia/totem/files/patch-src_totem-disk.c
+++ b/multimedia/totem/files/patch-src_totem-disk.c
@@ -1,8 +1,8 @@
---- src/totem-disc.c.orig Mon Oct 18 14:00:05 2004
-+++ src/totem-disc.c Mon Oct 18 14:00:14 2004
-@@ -26,12 +26,34 @@
+--- src/totem-disc.c.orig Tue Nov 23 04:03:19 2004
++++ src/totem-disc.c Tue Nov 23 04:05:27 2004
+@@ -25,12 +25,35 @@
+ #include <stdio.h>
#include <stdlib.h>
- #include <unistd.h>
#include <errno.h>
-#include <mntent.h>
#include <string.h>
@@ -27,23 +27,13 @@
+#define CDS_DISC_OK 4
+#define CDS_XA_2_1 103
+#define CDS_XA_2_2 104
++#define CDC_DVD 0x8000
+#define ENOMEDIUM ENODEV
+#define CDROM_GET_CAPABILITY CDIOCCLRDEBUG
+#else
- #include <linux/cdrom.h>
+#include <mntent.h>
+ #include <linux/cdrom.h>
+#endif
#include <glib.h>
#include <glib/gi18n.h>
-@@ -395,8 +417,10 @@
- /* open disc, check capabilities and open mount */
- if (!cd_cache_open_device (cache, error))
- return MEDIA_TYPE_ERROR;
-+#ifdef __linux__
- if (!(cache->cap & CDC_DVD))
- return MEDIA_TYPE_DATA;
-+#endif
- if (!(dir = cd_cache_open_mountpoint (cache, error)))
- return MEDIA_TYPE_ERROR;
-
diff --git a/multimedia/totem/pkg-plist b/multimedia/totem/pkg-plist
index 49aade05c44e..c37924fdb7b8 100644
--- a/multimedia/totem/pkg-plist
+++ b/multimedia/totem/pkg-plist
@@ -4,8 +4,6 @@ libdata/bonobo/servers/Totem_properties.server
libexec/totem-properties-page
share/gnome/application-registry/totem.applications
share/gnome/applications/totem.desktop
-@exec update-desktop-database > /dev/null || /usr/bin/true
-@unexec update-desktop-database > /dev/null || /usr/bin/true
share/gnome/help/totem/C/figures/totem_next_button.png
share/gnome/help/totem/C/figures/totem_pause_button.png
share/gnome/help/totem/C/figures/totem_play_button.png
@@ -38,16 +36,13 @@ share/gnome/help/totem/es/legal.xml
share/gnome/help/totem/es/totem.xml
share/gnome/mime-info/totem.keys
share/gnome/omf/totem/totem-C.omf
-@exec scrollkeeper-install -q %D/share/gnome/omf/totem/totem-C.omf 2>/dev/null || /usr/bin/true
share/gnome/omf/totem/totem-de.omf
-@exec scrollkeeper-install -q %D/share/gnome/omf/totem/totem-de.omf 2>/dev/null || /usr/bin/true
share/gnome/omf/totem/totem-es.omf
-@exec scrollkeeper-install -q %D/share/gnome/omf/totem/totem-es.omf 2>/dev/null || /usr/bin/true
share/gnome/pixmaps/media-player-48.png
share/gnome/pixmaps/vanity.png
-share/gnome/totem/filmholes.png
share/gnome/totem/filmholes-big-left.png
share/gnome/totem/filmholes-big-right.png
+share/gnome/totem/filmholes.png
share/gnome/totem/media-player-48.png
share/gnome/totem/mozilla-viewer.glade
share/gnome/totem/playlist-16.png
@@ -92,8 +87,8 @@ share/locale/gu/LC_MESSAGES/totem.mo
share/locale/he/LC_MESSAGES/totem.mo
share/locale/hr/LC_MESSAGES/totem.mo
share/locale/hu/LC_MESSAGES/totem.mo
-share/locale/it/LC_MESSAGES/totem.mo
share/locale/is/LC_MESSAGES/totem.mo
+share/locale/it/LC_MESSAGES/totem.mo
share/locale/ja/LC_MESSAGES/totem.mo
share/locale/ko/LC_MESSAGES/totem.mo
share/locale/lt/LC_MESSAGES/totem.mo
@@ -120,15 +115,14 @@ share/locale/vi/LC_MESSAGES/totem.mo
share/locale/wa/LC_MESSAGES/totem.mo
share/locale/zh_CN/LC_MESSAGES/totem.mo
share/locale/zh_TW/LC_MESSAGES/totem.mo
-@dirrm share/gnome/help/totem/de/figures
-@dirrm share/gnome/help/totem/de
+@dirrm share/gnome/totem
+@dirrm share/gnome/omf/totem
@dirrm share/gnome/help/totem/es/figures
@dirrm share/gnome/help/totem/es
+@dirrm share/gnome/help/totem/de/figures
+@dirrm share/gnome/help/totem/de
@dirrm share/gnome/help/totem/C/figures
@dirrm share/gnome/help/totem/C
@dirrm share/gnome/help/totem
-@dirrm share/gnome/omf/totem
-@dirrm share/gnome/totem
-@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/totem/totem-de.omf 2>/dev/null || /usr/bin/true
-@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/totem/totem-es.omf 2>/dev/null || /usr/bin/true
-@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/totem/totem-C.omf 2>/dev/null || /usr/bin/true
+@exec update-desktop-database > /dev/null || /usr/bin/true
+@unexec update-desktop-database > /dev/null || /usr/bin/true