aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/gaphor/Makefile24
1 files changed, 4 insertions, 20 deletions
diff --git a/devel/gaphor/Makefile b/devel/gaphor/Makefile
index 91d1222572f1..a1686f87ec95 100644
--- a/devel/gaphor/Makefile
+++ b/devel/gaphor/Makefile
@@ -18,31 +18,15 @@ COMMENT= UML modeling environment written in Python
BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/diacanvas/_canvasmodule.so:${PORTSDIR}/graphics/diacanvas2
RUN_DEPENDS= ${BUILD_DEPENDS}
-
-USE_PYTHON= 2.2+
-
-.if !defined(DISPLAY)
+.if defined(PACKAGE_BUILDING)
BUILD_DEPENDS+= Xvfb:${X_VFBSERVER_PORT}
-DISPLAYHACK= localhost:1001
.endif
+BROKEN= Does not build with python 2.4
+USE_PYTHON= 2.2+
+
do-configure:
-.if exists(${WRKDIR}/.Xvfb.pid)
- @-${CAT} ${WRKDIR}/.Xvfb.pid | ${XARGS} kill
- @${RM} -f ${WRKDIR}/.Xvfb.pid
-.endif
-.if !defined(DISPLAY)
- #
- # This is a UGLY hack to not have to specify a X-Display.
- #
- ${X11BASE}/bin/Xvfb :1001 -screen 0 800x600x24 > /dev/null 2>&1 & ${ECHO} $$! > ${WRKDIR}/.Xvfb.pid
- @sleep 5
- @cd ${WRKSRC}; ${ENV} DISPLAY=${DISPLAYHACK} ${PYTHON_CMD} setup.py config
- @-${CAT} ${WRKDIR}/.Xvfb.pid | ${XARGS} kill
- @${RM} -f ${WRKDIR}/.Xvfb.pid
-.else
@cd ${WRKSRC}; ${PYTHON_CMD} setup.py config
-.endif
do-build:
@cd ${WRKSRC}; ${PYTHON_CMD} setup.py build; ${PYTHON_CMD} setup.py build_mo