aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net/wistumbler2/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/net/wistumbler2/Makefile b/net/wistumbler2/Makefile
index f615adb1f6f1..ba0dbe8f96ba 100644
--- a/net/wistumbler2/Makefile
+++ b/net/wistumbler2/Makefile
@@ -34,7 +34,15 @@ MAKE_ENV= PREFIX=${LOCALBASE} USE_GTK=0
# was not a FreeBSD version bump specifically for that. Use the
# nearest one.
.if ${OSVERSION} < 501107
-IGNORE= requires never kernel sources that include /sys/dev/owi/if_ieee80211.h
+IGNORE= requires newer kernel sources
+.endif
+
+post-patch:
+# Abovementioned header was removed. Patch for it.
+# This change is already included in the next version of wistumbler2
+.if ${OSVERSION} >= 700006
+ ${REINPLACE_CMD} -e 's,dev/owi/if_ieee80211.h,net80211/ieee80211.h,g' \
+ ${WRKSRC}/src/stumbler.h
.endif
pre-everything::