aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/spirit/Makefile4
-rw-r--r--devel/spirit/files/patch-libs::spirit::example::application::slex::lexer.hpp20
2 files changed, 20 insertions, 4 deletions
diff --git a/devel/spirit/Makefile b/devel/spirit/Makefile
index af9a3c7a508a..b4919de1626b 100644
--- a/devel/spirit/Makefile
+++ b/devel/spirit/Makefile
@@ -29,10 +29,6 @@ CONFIGURE_ARGS= --enable-spirit-threadsafe
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 502126
-BROKEN= "Does not compile on FreeBSD >= 5.x"
-.endif
-
.if ${ARCH} == "amd64"
IGNORE= does not build: cc1plus hangs forever (gcc bug)
.elif ${ARCH} != "i386" && ${ARCH} != "alpha"
diff --git a/devel/spirit/files/patch-libs::spirit::example::application::slex::lexer.hpp b/devel/spirit/files/patch-libs::spirit::example::application::slex::lexer.hpp
new file mode 100644
index 000000000000..c730680a694c
--- /dev/null
+++ b/devel/spirit/files/patch-libs::spirit::example::application::slex::lexer.hpp
@@ -0,0 +1,20 @@
+--- libs/spirit/example/application/slex/lexer.hpp.orig Fri Oct 15 11:57:49 2004
++++ libs/spirit/example/application/slex/lexer.hpp Fri Oct 15 11:58:01 2004
+@@ -2108,7 +2108,7 @@
+ s = dfa.transition_table[s][(uchar)*p];
+ if (s == invalid_node)
+ break;
+- if (token) token->append((string_t::size_type)1, *p);
++ if (token) token->append((typename string_t::size_type)1, *p);
+ ++p;
+ if (dfa.acceptance_index[s] != invalid_node)
+ {
+@@ -2163,7 +2163,7 @@
+ goto break_while;
+ }
+ }
+- if (token) token->append((string_t::size_type)1, *wp);
++ if (token) token->append((typename string_t::size_type)1, *wp);
+ ++wp;
+ if (dfa.acceptance_index[s] != invalid_node)
+ {