aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/librelp/Makefile28
-rw-r--r--devel/librelp/distinfo3
-rw-r--r--devel/librelp/pkg-descr14
-rw-r--r--sysutils/Makefile7
-rw-r--r--sysutils/rsyslog-gssapi/Makefile1
-rw-r--r--sysutils/rsyslog/Makefile3
-rw-r--r--sysutils/rsyslog3-dbi/Makefile15
-rw-r--r--sysutils/rsyslog3-gssapi/Makefile23
-rw-r--r--sysutils/rsyslog3-mysql/Makefile19
-rw-r--r--sysutils/rsyslog3-pgsql/Makefile19
-rw-r--r--sysutils/rsyslog3-relp/Makefile15
-rw-r--r--sysutils/rsyslog3-snmp/Makefile15
-rw-r--r--sysutils/rsyslog3/Makefile38
-rw-r--r--sysutils/rsyslog3/bsd.rsyslog.mk31
-rw-r--r--sysutils/rsyslog3/distinfo6
-rw-r--r--sysutils/rsyslog3/files/patch-syslogd.c22
-rw-r--r--sysutils/rsyslog3/files/pkg-message.in3
-rw-r--r--sysutils/rsyslog3/files/rsyslogd.in14
-rw-r--r--sysutils/rsyslog3/pkg-descr17
-rw-r--r--sysutils/rsyslog3/pkg-plist49
21 files changed, 213 insertions, 130 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 9f9dc54936c6..f3de34961b6d 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -666,6 +666,7 @@
SUBDIR += librcd
SUBDIR += libreadline-java
SUBDIR += libredblack
+ SUBDIR += librelp
SUBDIR += libruin
SUBDIR += libs11n
SUBDIR += libshbuf
diff --git a/devel/librelp/Makefile b/devel/librelp/Makefile
new file mode 100644
index 000000000000..2cadb76f2420
--- /dev/null
+++ b/devel/librelp/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: librelp
+# Date created: 1 April 2008
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= librelp
+PORTVERSION= 0.1.1
+CATEGORIES= devel
+MASTER_SITES= CENKES http://download.rsyslog.com/librelp/
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Reliable event logging protocol library
+
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-static
+PLIST_FILES= include/${PORTNAME}.h lib/${PORTNAME}.so lib/${PORTNAME}.so.0 \
+ lib/${PORTNAME}.la libdata/pkgconfig/relp.pc
+PORT_VERBS= relp
+
+post-patch:
+ @${REINPLACE_CMD} -e '/^pkgconfigdir =/s|=.*| \
+ = ${PREFIX}/libdata/pkgconfig|' ${WRKSRC}/Makefile.in
+ @${ECHO_CMD} "#include <sys/types.h>" >> ${WRKSRC}/src/relp.h
+
+.include <bsd.port.mk>
diff --git a/devel/librelp/distinfo b/devel/librelp/distinfo
new file mode 100644
index 000000000000..2a3b6e617b0f
--- /dev/null
+++ b/devel/librelp/distinfo
@@ -0,0 +1,3 @@
+MD5 (librelp-0.1.1.tar.gz) = 8d98ef2dadeff03b5bd40efed7ae418d
+SHA256 (librelp-0.1.1.tar.gz) = 57095df8936b7b85a7657c2d468081c6231270269f2501cc089cb2df92abd608
+SIZE (librelp-0.1.1.tar.gz) = 375399
diff --git a/devel/librelp/pkg-descr b/devel/librelp/pkg-descr
new file mode 100644
index 000000000000..681f447b7aba
--- /dev/null
+++ b/devel/librelp/pkg-descr
@@ -0,0 +1,14 @@
+librelp is an easy to use library for the RELP protocol. RELP in turn
+provides reliable event logging over the network (and consequently
+RELP stands for Reliable Event Logging Protocol).
+
+RELP (and hence) librelp assures that no message is lost, not even
+when connections break and a peer becomes unavailable. The current
+version of RELP has a minimal window of opportunity for message
+duplication after a session has been broken due to network problems.
+In this case, a few messages may be duplicated (a problem that also
+exists with plain tcp syslog). Future versions of RELP will address
+this shortcoming.
+
+WWW: http://www.librelp.com/
+Author: Rainer Gerhards <rgerhards@adiscon.com>
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 720ec136aac0..d6831e886d63 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -596,6 +596,13 @@
SUBDIR += rsyslog-gssapi
SUBDIR += rsyslog-mysql
SUBDIR += rsyslog-pgsql
+ SUBDIR += rsyslog3
+ SUBDIR += rsyslog3-dbi
+ SUBDIR += rsyslog3-gssapi
+ SUBDIR += rsyslog3-mysql
+ SUBDIR += rsyslog3-pgsql
+ SUBDIR += rsyslog3-relp
+ SUBDIR += rsyslog3-snmp
SUBDIR += rtty
SUBDIR += ruby-log4r
SUBDIR += ruby-quota
diff --git a/sysutils/rsyslog-gssapi/Makefile b/sysutils/rsyslog-gssapi/Makefile
index 699cfb44515a..32729e134f97 100644
--- a/sysutils/rsyslog-gssapi/Makefile
+++ b/sysutils/rsyslog-gssapi/Makefile
@@ -8,7 +8,6 @@
TYPE= gssapi
COMMENT= GSS API output module for rsyslog
PKGNAMESUFFIX= -${TYPE}
-PORTREVISION= 1
MASTERDIR= ${.CURDIR}/../rsyslog
CONFIGURE_ARGS+= --enable-${TYPE}-krb5
diff --git a/sysutils/rsyslog/Makefile b/sysutils/rsyslog/Makefile
index 2529906dfeed..968d0116c371 100644
--- a/sysutils/rsyslog/Makefile
+++ b/sysutils/rsyslog/Makefile
@@ -7,7 +7,7 @@
PORTNAME= rsyslog
PORTVERSION= 2.0.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils
MASTER_SITES= CENKES http://download.rsyslog.com/rsyslog/
@@ -22,6 +22,7 @@ MAN8= rfc3195d.8 rklogd.8 rsyslogd.8
MAN5= rsyslog.conf.5
.endif
+CONFLICTS= rsyslog-3.[0-9]*
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
GNU_CONFIGURE= yes
diff --git a/sysutils/rsyslog3-dbi/Makefile b/sysutils/rsyslog3-dbi/Makefile
new file mode 100644
index 000000000000..75b3fb7128e8
--- /dev/null
+++ b/sysutils/rsyslog3-dbi/Makefile
@@ -0,0 +1,15 @@
+# New ports collection makefile for: rsyslog3-dbi
+# Date created: 5 May 2008
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+COMMENT= LibDBI output module for rsyslog
+
+MNAME= libdbi
+MTYPES= om
+LIB_DEPENDS= dbi.0:${PORTSDIR}/databases/libdbi
+
+.include "${.CURDIR}/../rsyslog3/bsd.rsyslog.mk"
+.include <bsd.port.mk>
diff --git a/sysutils/rsyslog3-gssapi/Makefile b/sysutils/rsyslog3-gssapi/Makefile
index 699cfb44515a..a56917695dd9 100644
--- a/sysutils/rsyslog3-gssapi/Makefile
+++ b/sysutils/rsyslog3-gssapi/Makefile
@@ -1,25 +1,14 @@
-# New ports collection makefile for: rsyslog-gssapi
+# New ports collection makefile for: rsyslog3-gssapi
# Date created: 31 December 2007
# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
#
# $FreeBSD$
#
-TYPE= gssapi
-COMMENT= GSS API output module for rsyslog
-PKGNAMESUFFIX= -${TYPE}
-PORTREVISION= 1
+COMMENT= GSS API input/output module for rsyslog
-MASTERDIR= ${.CURDIR}/../rsyslog
-CONFIGURE_ARGS+= --enable-${TYPE}-krb5
-RUN_DEPENDS= rsyslog>=0:${PORTSDIR}/sysutils/rsyslog
-PLIST_FILES= lib/rsyslog/om${TYPE}.so
-PLIST_DIRS= lib/rsyslog
-PLIST= ""
+MNAME= gssapi
+MTYPES= im om
-do-install:
- @${INSTALL} -d ${PREFIX}/lib/rsyslog/
- @${INSTALL_PROGRAM} ${WRKSRC}/plugins/om${TYPE}/.libs/om${TYPE}.so \
- ${PREFIX}/lib/rsyslog/
-
-.include "${MASTERDIR}/Makefile"
+.include "${.CURDIR}/../rsyslog3/bsd.rsyslog.mk"
+.include <bsd.port.mk>
diff --git a/sysutils/rsyslog3-mysql/Makefile b/sysutils/rsyslog3-mysql/Makefile
index 4f87d4d1c85d..c2160ce2c98c 100644
--- a/sysutils/rsyslog3-mysql/Makefile
+++ b/sysutils/rsyslog3-mysql/Makefile
@@ -1,4 +1,4 @@
-# New ports collection makefile for: rsyslog-mysql
+# New ports collection makefile for: rsyslog3-mysql
# Date created: 13 December 2007
# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
#
@@ -6,19 +6,10 @@
#
COMMENT= MySQL output module for rsyslog
-PKGNAMESUFFIX= -mysql
-MASTERDIR= ${.CURDIR}/../rsyslog
+MNAME= mysql
+MTYPES= om
USE_MYSQL= yes
-CONFIGURE_ARGS+= --enable-mysql
-RUN_DEPENDS= rsyslog>=0:${PORTSDIR}/sysutils/rsyslog
-PLIST_FILES= lib/rsyslog/ommysql.so
-PLIST_DIRS= lib/rsyslog
-PLIST= ""
-do-install:
- @${INSTALL} -d ${PREFIX}/lib/rsyslog/
- @${INSTALL_PROGRAM} ${WRKSRC}/plugins/ommysql/.libs/ommysql.so \
- ${PREFIX}/lib/rsyslog/
-
-.include "${MASTERDIR}/Makefile"
+.include "${.CURDIR}/../rsyslog3/bsd.rsyslog.mk"
+.include <bsd.port.mk>
diff --git a/sysutils/rsyslog3-pgsql/Makefile b/sysutils/rsyslog3-pgsql/Makefile
index e8a0b5fdb889..e76bf2386991 100644
--- a/sysutils/rsyslog3-pgsql/Makefile
+++ b/sysutils/rsyslog3-pgsql/Makefile
@@ -1,4 +1,4 @@
-# New ports collection makefile for: rsyslog-pgsql
+# New ports collection makefile for: rsyslog3-pgsql
# Date created: 13 December 2007
# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
#
@@ -6,19 +6,10 @@
#
COMMENT= PostgreSQL output module for rsyslog
-PKGNAMESUFFIX= -pgsql
-MASTERDIR= ${.CURDIR}/../rsyslog
+MNAME= pgsql
+MTYPES= om
USE_PGSQL= yes
-CONFIGURE_ARGS+= --enable-pgsql
-RUN_DEPENDS= rsyslog>=0:${PORTSDIR}/sysutils/rsyslog
-PLIST_FILES= lib/rsyslog/ompgsql.so
-PLIST_DIRS= lib/rsyslog
-PLIST= ""
-do-install:
- @${INSTALL} -d ${PREFIX}/lib/rsyslog/
- @${INSTALL_PROGRAM} ${WRKSRC}/plugins/ompgsql/.libs/ompgsql.so \
- ${PREFIX}/lib/rsyslog/
-
-.include "${MASTERDIR}/Makefile"
+.include "${.CURDIR}/../rsyslog3/bsd.rsyslog.mk"
+.include <bsd.port.mk>
diff --git a/sysutils/rsyslog3-relp/Makefile b/sysutils/rsyslog3-relp/Makefile
new file mode 100644
index 000000000000..5dc330b168cf
--- /dev/null
+++ b/sysutils/rsyslog3-relp/Makefile
@@ -0,0 +1,15 @@
+# New ports collection makefile for: rsyslog3-relp
+# Date created: 6 May 2008
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+COMMENT= RELP input/output module for rsyslog
+
+MNAME= relp
+MTYPES= im om
+LIB_DEPENDS= relp.0:${PORTSDIR}/devel/librelp
+
+.include "${.CURDIR}/../rsyslog3/bsd.rsyslog.mk"
+.include <bsd.port.mk>
diff --git a/sysutils/rsyslog3-snmp/Makefile b/sysutils/rsyslog3-snmp/Makefile
new file mode 100644
index 000000000000..de911cbc30f6
--- /dev/null
+++ b/sysutils/rsyslog3-snmp/Makefile
@@ -0,0 +1,15 @@
+# New ports collection makefile for: rsyslog3-snmp
+# Date created: 6 May 2008
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+COMMENT= SNMP trap sender for rsyslog
+
+MNAME= snmp
+MTYPES= om
+LIB_DEPENDS= netsnmp.16:${PORTSDIR}/net-mgmt/net-snmp
+
+.include "${.CURDIR}/../rsyslog3/bsd.rsyslog.mk"
+.include <bsd.port.mk>
diff --git a/sysutils/rsyslog3/Makefile b/sysutils/rsyslog3/Makefile
index 2529906dfeed..c2fa4b40a45f 100644
--- a/sysutils/rsyslog3/Makefile
+++ b/sysutils/rsyslog3/Makefile
@@ -1,4 +1,4 @@
-# New ports collection makefile for: rsyslog
+# New ports collection makefile for: rsyslog3
# Date created: 9 July 2007
# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
#
@@ -6,55 +6,31 @@
#
PORTNAME= rsyslog
-PORTVERSION= 2.0.4
-PORTREVISION= 1
-CATEGORIES= sysutils
-MASTER_SITES= CENKES http://download.rsyslog.com/rsyslog/
-MAINTAINER= infofarmer@FreeBSD.org
-COMMENT?= Enhanced syslog daemon
+COMMENT= Enhanced syslog daemon
-LIB_DEPENDS= logging.0:${PORTSDIR}/devel/liblogging
-.ifndef PKGNAMESUFFIX
USE_RC_SUBR= ${PORTNAME}d
SUB_FILES= pkg-message
-MAN8= rfc3195d.8 rklogd.8 rsyslogd.8
+MAN8= rsyslogd.8
MAN5= rsyslog.conf.5
-.endif
-
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS= -L${LOCALBASE}/lib
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS+=--disable-klogd --disable-static
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-PORT_VERBS= rfc3195d rklogd ${PORTNAME}
+CONFIGURE_ARGS+=--enable-klog --disable-static --enable-mail \
+ --enable-imfile --enable-imtemplate --enable-openssl \
post-patch:
- @${REINPLACE_CMD} -e 's|<wait.h>|<sys/wait.h>|' ${WRKSRC}/srUtils.c
- @${REINPLACE_CMD} -e '/^rfc3195d_LDADD =/s|$$| -llogging|;s|-ldl||'\
- ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|/lib/rsyslog/|${PREFIX}/lib/rsyslog/|'\
- ${WRKSRC}/Makefile.in ${WRKSRC}/syslogd.c
- @${REINPLACE_CMD} -e 's|rs_strerror_r|strerror_r|g' ${WRKSRC}/rfc3195d.c
+ ${WRKSRC}/syslogd.c
@${GREP} -rl '/etc/rsyslog.conf' ${WRKSRC}|${XARGS} ${REINPLACE_CMD} -e\
's|/etc/rsyslog.conf|${PREFIX}/etc/rsyslog.conf|'
- @${ECHO_CMD} '#include <sys/socket.h>' >> ${WRKSRC}/net.h
- @${ECHO_CMD} '#include <paths.h>' >> ${WRKSRC}/omusrmsg.h
@${FIND} ${WRKSRC} -name '*.bak' -delete
-post-configure:
- @${ECHO_CMD} '#define FEATURE_RFC3195 1' >> ${WRKSRC}/config.h
- @${ECHO_CMD} '#define PATCHLEVEL "0"' >> ${WRKSRC}/config.h
-
-.ifndef PKGNAMESUFFIX
post-install:
.ifndef NOPORTDOCS
@${INSTALL} -d ${DOCSDIR}/
@${INSTALL_DATA} ${WRKSRC}/doc/*html ${DOCSDIR}/
.endif
@${CAT} ${PKGMESSAGE}
-.endif
+.include "${.CURDIR}/bsd.rsyslog.mk"
.include <bsd.port.mk>
diff --git a/sysutils/rsyslog3/bsd.rsyslog.mk b/sysutils/rsyslog3/bsd.rsyslog.mk
new file mode 100644
index 000000000000..d824cd55a0a8
--- /dev/null
+++ b/sysutils/rsyslog3/bsd.rsyslog.mk
@@ -0,0 +1,31 @@
+PORTNAME?= rsyslog
+PORTVERSION?= 3.17.2
+CATEGORIES?= sysutils
+MASTER_SITES?= CENKES http://download.rsyslog.com/rsyslog/
+MAINTAINER?= infofarmer@FreeBSD.org
+
+CONFLICTS= rsyslog-2.[0-9]*
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+GNU_CONFIGURE= yes
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+
+.ifdef MNAME
+PKGNAMESUFFIX?= -${MNAME}
+CONFIGURE_ARGS+= --enable-${MNAME:S|gssapi|gssapi-krb5|} \
+ --disable-rsyslogd --disable-klog
+RUN_DEPENDS= rsyslog>=3:${PORTSDIR}/sysutils/rsyslog3
+PLIST_FILES= ${MTYPES:S|^|lib/rsyslog/|:S|$|${MNAME}.so|}
+PLIST= ""
+DESCR?= ${.CURDIR}/../rsyslog3/pkg-descr
+MD5_FILE?= ${.CURDIR}/../rsyslog3/distinfo
+
+do-install:
+ @${INSTALL} -d ${PREFIX}/lib/rsyslog/
+.for _T in ${MTYPES}
+ @${INSTALL_PROGRAM} \
+ ${WRKSRC}/plugins/${_T}${MNAME}/.libs/${_T}${MNAME}.so \
+ ${PREFIX}/lib/rsyslog/
+.endfor
+ @${ECHO_CMD} '@unexec rmdir %D/lib/rsyslog 2>/dev/null || true' >> ${TMPPLIST}
+.endif # def MNAME
diff --git a/sysutils/rsyslog3/distinfo b/sysutils/rsyslog3/distinfo
index c2ea8219efae..c390847b6247 100644
--- a/sysutils/rsyslog3/distinfo
+++ b/sysutils/rsyslog3/distinfo
@@ -1,3 +1,3 @@
-MD5 (rsyslog-2.0.4.tar.gz) = bded1f647dd5a4a6bd40b9f6311aa34c
-SHA256 (rsyslog-2.0.4.tar.gz) = 15a60d36af7643db669af86293aba1a3f1da5d48b921e623212e9b836ef99f8b
-SIZE (rsyslog-2.0.4.tar.gz) = 697603
+MD5 (rsyslog-3.17.2.tar.gz) = bfec588a23adb2bebec83a7a2a5962d4
+SHA256 (rsyslog-3.17.2.tar.gz) = 8a1437434f5489d331b70dafe1a2874c9053f7f6df1c567f982e6d25f62ba3b5
+SIZE (rsyslog-3.17.2.tar.gz) = 1086281
diff --git a/sysutils/rsyslog3/files/patch-syslogd.c b/sysutils/rsyslog3/files/patch-syslogd.c
deleted file mode 100644
index f646cc94c27d..000000000000
--- a/sysutils/rsyslog3/files/patch-syslogd.c
+++ /dev/null
@@ -1,22 +0,0 @@
---- ./syslogd.c.orig 2007-08-25 20:07:21.000000000 +0400
-+++ ./syslogd.c 2007-08-25 20:08:39.000000000 +0400
-@@ -86,7 +86,6 @@
- #include "rsyslog.h"
-
- #ifdef __FreeBSD__
--#define BSD
- #endif
-
- /* change the following setting to e.g. 32768 if you would like to
-@@ -1877,6 +1876,11 @@
- return iRet;
- }
-
-+size_t strnlen (const char *string, size_t maxlen)
-+{
-+ const char *end = memchr (string, '\0', maxlen);
-+ return end ? (size_t) (end - string) : maxlen;
-+}
-
- /* rgerhards, 2005-10-24: crunch_list is called only during option processing. So
- * it is never called once rsyslogd is running (not even when HUPed). This code
diff --git a/sysutils/rsyslog3/files/pkg-message.in b/sysutils/rsyslog3/files/pkg-message.in
index a6d483ef34f4..e67f1b87ed51 100644
--- a/sysutils/rsyslog3/files/pkg-message.in
+++ b/sysutils/rsyslog3/files/pkg-message.in
@@ -10,7 +10,4 @@ this:
newsyslog(8) has the path of syslogd's pid file hardcoded. To
make it work seamlessly with rsyslog, add this:
rsyslogd_pidfile="/var/run/syslog.pid"
-rsyslogd(8) does not support logging /dev/klog. To enable a
-simple logger(1)-based workaround, add this:
- rsyslogd_klog_enable="YES"
===================================================================
diff --git a/sysutils/rsyslog3/files/rsyslogd.in b/sysutils/rsyslog3/files/rsyslogd.in
index d33e18b281c4..c260977562b8 100644
--- a/sysutils/rsyslog3/files/rsyslogd.in
+++ b/sysutils/rsyslog3/files/rsyslogd.in
@@ -16,8 +16,6 @@ load_rc_config $name
: ${rsyslogd_enable:="NO"}
: ${rsyslogd_pidfile:="/var/run/rsyslogd.pid"}
: ${rsyslogd_config:="%%PREFIX%%/etc/rsyslog.conf"}
-: ${rsyslogd_klog_enable:="NO"}
-: ${rsyslogd_klog_pidfile:="/var/run/rsyslog-klog.pid"}
pidfile="${rsyslogd_pidfile}"
command_args="-i ${pidfile} -f ${rsyslogd_config}"
required_files="${rsyslogd_config}"
@@ -29,20 +27,8 @@ sockfile="/var/run/rsyslogd.sockets"
evalargs="rc_flags=\"\`set_socketlist\` \$rc_flags\""
altlog_proglist="named"
-stop_precmd()
-{
- if [ -r ${rsyslogd_klog_pidfile} ]&&[ -s ${rsyslogd_klog_pidfile} ]; then
- kill `cat ${rsyslogd_klog_pidfile}`
- fi
- rm -f ${rsyslogd_klog_pidfile}
-}
-
rsyslogd_precmd()
{
- if checkyesno rsyslogd_klog_enable; then
- daemon -cfp ${rsyslogd_klog_pidfile}\
- logger -t kernel -p kern.notice -f /dev/klog
- fi
local _l _ldir
# Transitional symlink for old binaries
diff --git a/sysutils/rsyslog3/pkg-descr b/sysutils/rsyslog3/pkg-descr
index f62509fcdabf..9bcfe0aca39d 100644
--- a/sysutils/rsyslog3/pkg-descr
+++ b/sysutils/rsyslog3/pkg-descr
@@ -1,9 +1,12 @@
-Rsyslog is an enhanced multi-threaded syslogd supporting, among others,
-MySQL, syslog/tcp, RFC 3195, permitted sender lists, filtering on any
-message part, and fine grain output format control. It is quite
-compatible to stock sysklogd and can be used as a drop-in replacement.
-Its advanced features make it suitable for enterprise-class, encryption
-protected syslog relay chains while at the same time being very easy to
-setup for the novice user.
+Rsyslog is an enhanced multi-threaded syslogd supporting, among
+others, syslog/tcp, permitted sender lists, filtering on any message
+part, and fine grain output format control. Its advanced features
+make it suitable for enterprise-class, encryption protected syslog
+relay chains while at the same time being very easy to setup for the
+novice user.
+
+The following features are supported through modules: logging to
+MySQL, PostgreSQL, any libdbi-supported backend; SNMP trap sender, GSS
+API, RELP.
WWW: http://www.rsyslog.com/
diff --git a/sysutils/rsyslog3/pkg-plist b/sysutils/rsyslog3/pkg-plist
index 6d74db08d87b..5bb61f6b924c 100644
--- a/sysutils/rsyslog3/pkg-plist
+++ b/sysutils/rsyslog3/pkg-plist
@@ -1,19 +1,57 @@
-sbin/rfc3195d
-sbin/rklogd
+lib/rsyslog/imfile.la
+lib/rsyslog/imfile.so
+lib/rsyslog/imklog.la
+lib/rsyslog/imklog.so
+lib/rsyslog/immark.la
+lib/rsyslog/immark.so
+lib/rsyslog/imtcp.la
+lib/rsyslog/imtcp.so
+lib/rsyslog/imtemplate.la
+lib/rsyslog/imtemplate.so
+lib/rsyslog/imudp.la
+lib/rsyslog/imudp.so
+lib/rsyslog/imuxsock.la
+lib/rsyslog/imuxsock.so
+lib/rsyslog/lmnet.la
+lib/rsyslog/lmnet.so
+lib/rsyslog/lmregexp.la
+lib/rsyslog/lmregexp.so
+lib/rsyslog/lmtcpclt.la
+lib/rsyslog/lmtcpclt.so
+lib/rsyslog/lmtcpsrv.la
+lib/rsyslog/lmtcpsrv.so
+lib/rsyslog/ommail.la
+lib/rsyslog/ommail.so
+lib/rsyslog/omtesting.la
+lib/rsyslog/omtesting.so
sbin/rsyslogd
%%PORTDOCS%%%%DOCSDIR%%/bugs.html
%%PORTDOCS%%%%DOCSDIR%%/contributors.html
+%%PORTDOCS%%%%DOCSDIR%%/debug.html
+%%PORTDOCS%%%%DOCSDIR%%/dev_queue.html
+%%PORTDOCS%%%%DOCSDIR%%/expression.html
%%PORTDOCS%%%%DOCSDIR%%/features.html
%%PORTDOCS%%%%DOCSDIR%%/generic_design.html
%%PORTDOCS%%%%DOCSDIR%%/history.html
%%PORTDOCS%%%%DOCSDIR%%/how2help.html
+%%PORTDOCS%%%%DOCSDIR%%/imfile.html
+%%PORTDOCS%%%%DOCSDIR%%/imgssapi.html
+%%PORTDOCS%%%%DOCSDIR%%/imklog.html
+%%PORTDOCS%%%%DOCSDIR%%/imrelp.html
+%%PORTDOCS%%%%DOCSDIR%%/imtcp.html
+%%PORTDOCS%%%%DOCSDIR%%/imuxsock.html
%%PORTDOCS%%%%DOCSDIR%%/install.html
%%PORTDOCS%%%%DOCSDIR%%/ipv6.html
+%%PORTDOCS%%%%DOCSDIR%%/log_rotation_fix_size.html
%%PORTDOCS%%%%DOCSDIR%%/man_rsyslogd.html
%%PORTDOCS%%%%DOCSDIR%%/manual.html
%%PORTDOCS%%%%DOCSDIR%%/modules.html
+%%PORTDOCS%%%%DOCSDIR%%/omlibdbi.html
+%%PORTDOCS%%%%DOCSDIR%%/omsnmp.html
%%PORTDOCS%%%%DOCSDIR%%/professional_support.html
%%PORTDOCS%%%%DOCSDIR%%/property_replacer.html
+%%PORTDOCS%%%%DOCSDIR%%/queues.html
+%%PORTDOCS%%%%DOCSDIR%%/rainerscript.html
%%PORTDOCS%%%%DOCSDIR%%/rsconf1_actionexeconlywhenpreviousissuspended.html
%%PORTDOCS%%%%DOCSDIR%%/rsconf1_actionresumeinterval.html
%%PORTDOCS%%%%DOCSDIR%%/rsconf1_allowedsender.html
@@ -37,18 +75,23 @@ sbin/rsyslogd
%%PORTDOCS%%%%DOCSDIR%%/rsconf1_gssmode.html
%%PORTDOCS%%%%DOCSDIR%%/rsconf1_includeconfig.html
%%PORTDOCS%%%%DOCSDIR%%/rsconf1_mainmsgqueuesize.html
+%%PORTDOCS%%%%DOCSDIR%%/rsconf1_markmessageperiod.html
%%PORTDOCS%%%%DOCSDIR%%/rsconf1_moddir.html
%%PORTDOCS%%%%DOCSDIR%%/rsconf1_modload.html
%%PORTDOCS%%%%DOCSDIR%%/rsconf1_repeatedmsgreduction.html
%%PORTDOCS%%%%DOCSDIR%%/rsconf1_resetconfigvariables.html
%%PORTDOCS%%%%DOCSDIR%%/rsconf1_umask.html
+%%PORTDOCS%%%%DOCSDIR%%/rscript_abnf.html
%%PORTDOCS%%%%DOCSDIR%%/rsyslog_conf.html
+%%PORTDOCS%%%%DOCSDIR%%/rsyslog_high_database_rate.html
%%PORTDOCS%%%%DOCSDIR%%/rsyslog_mysql.html
+%%PORTDOCS%%%%DOCSDIR%%/rsyslog_ng_comparison.html
%%PORTDOCS%%%%DOCSDIR%%/rsyslog_packages.html
%%PORTDOCS%%%%DOCSDIR%%/rsyslog_php_syslog_ng.html
%%PORTDOCS%%%%DOCSDIR%%/rsyslog_recording_pri.html
%%PORTDOCS%%%%DOCSDIR%%/rsyslog_stunnel.html
-%%PORTDOCS%%%%DOCSDIR%%/status.html
%%PORTDOCS%%%%DOCSDIR%%/syslog-protocol.html
+%%PORTDOCS%%%%DOCSDIR%%/v3compatibility.html
%%PORTDOCS%%%%DOCSDIR%%/version_naming.html
+@dirrmtry lib/rsyslog
%%PORTDOCS%%@dirrm %%DOCSDIR%%