aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--astro/celestia/Makefile2
-rw-r--r--devel/lua-filename/Makefile2
-rw-r--r--devel/lua-posix/Makefile2
-rw-r--r--devel/lua-pty/Makefile4
-rw-r--r--devel/lua50-app/Makefile4
-rw-r--r--devel/lua50-compat51/Makefile2
-rw-r--r--devel/lua50-dfui/Makefile4
-rw-r--r--devel/lua50-filename/Makefile2
-rw-r--r--devel/lua50-posix/Makefile2
-rw-r--r--devel/lua50-pty/Makefile4
-rw-r--r--games/alephone/Makefile2
-rw-r--r--games/fillets-ng/Makefile2
-rw-r--r--games/stratagus/Makefile2
-rw-r--r--games/xmoto/Makefile2
-rw-r--r--lang/ruby-lua/Makefile2
-rw-r--r--lang/tolua++/Makefile2
-rw-r--r--lang/tolua++50/Makefile2
-rw-r--r--lang/tolua/Makefile2
-rw-r--r--lang/tolua50/Makefile2
-rw-r--r--mail/imapfilter/Makefile2
-rw-r--r--net-p2p/verlihub-plugins/Makefile2
-rw-r--r--net/luasocket/Makefile4
-rw-r--r--www/elinks/Makefile2
-rw-r--r--www/lighttpd/Makefile2
-rw-r--r--x11-wm/ion-2/Makefile2
-rw-r--r--x11-wm/ion-3/Makefile2
-rw-r--r--x11-wm/ion-3ds/Makefile2
-rw-r--r--x11-wm/ion3/Makefile2
-rw-r--r--x11/kdelibs3/Makefile2
-rw-r--r--x11/kdelibs4/Makefile2
30 files changed, 35 insertions, 35 deletions
diff --git a/astro/celestia/Makefile b/astro/celestia/Makefile
index 5889ad0e8988..1d038f33bd75 100644
--- a/astro/celestia/Makefile
+++ b/astro/celestia/Makefile
@@ -46,7 +46,7 @@ BROKEN= "Does not compile on FreeBSD 4.x"
.endif
.if defined(WITH_LUA)
-LIB_DEPENDS+= lua.5:${PORTSDIR}/lang/lua
+LIB_DEPENDS+= lua.5:${PORTSDIR}/lang/lua50
CONFIGURE_ARGS+= --with-lua
.endif
diff --git a/devel/lua-filename/Makefile b/devel/lua-filename/Makefile
index 3950ecb5e739..7b97eb46dc89 100644
--- a/devel/lua-filename/Makefile
+++ b/devel/lua-filename/Makefile
@@ -15,7 +15,7 @@ EXTRACT_ONLY=
MAINTAINER= andrew+ports@fubar.geek.nz
COMMENT= Filename-manipulating functions for Lua 5.0.x
-RUN_DEPENDS= ${LOCALBASE}/include/lua.h:${PORTSDIR}/lang/lua
+RUN_DEPENDS= ${LOCALBASE}/include/lua.h:${PORTSDIR}/lang/lua50
NO_WRKSUBDIR= yes
NO_BUILD= yes
diff --git a/devel/lua-posix/Makefile b/devel/lua-posix/Makefile
index 0e10e63b3bbc..26bfcb0a2000 100644
--- a/devel/lua-posix/Makefile
+++ b/devel/lua-posix/Makefile
@@ -14,7 +14,7 @@ DISTFILES= lposix.tar.gz
MAINTAINER= andrew+ports@fubar.geek.nz
COMMENT= A POSIX layer for Lua
-BUILD_DEPENDS= ${LOCALBASE}/include/lua.h:${PORTSDIR}/lang/lua
+BUILD_DEPENDS= ${LOCALBASE}/include/lua.h:${PORTSDIR}/lang/lua50
WRKSRC= ${WRKDIR}/posix
diff --git a/devel/lua-pty/Makefile b/devel/lua-pty/Makefile
index fa29708e8764..4758f2e58cbf 100644
--- a/devel/lua-pty/Makefile
+++ b/devel/lua-pty/Makefile
@@ -14,9 +14,9 @@ DISTFILES= pty.lua?rev=1.2 pty.c?rev=1.25
MAINTAINER= andrew+ports@fubar.geek.nz
COMMENT= Pty (pseudo-terminal) bindings for Lua 5.0.x
-BUILD_DEPENDS= ${LOCALBASE}/include/lua.h:${PORTSDIR}/lang/lua \
+BUILD_DEPENDS= ${LOCALBASE}/include/lua.h:${PORTSDIR}/lang/lua50 \
${NONEXISTENT}:${PORTSDIR}/devel/lua50-compat51:extract
-RUN_DEPENDS= ${LOCALBASE}/include/lua.h:${PORTSDIR}/lang/lua \
+RUN_DEPENDS= ${LOCALBASE}/include/lua.h:${PORTSDIR}/lang/lua50 \
${LOCALBASE}/share/lua/5.0/compat-5.1.lua:${PORTSDIR}/devel/lua50-compat51
LIBDIR= ${PREFIX}/lib/lua/5.0
diff --git a/devel/lua50-app/Makefile b/devel/lua50-app/Makefile
index 1407900a2665..ea99ea2fe84d 100644
--- a/devel/lua50-app/Makefile
+++ b/devel/lua50-app/Makefile
@@ -16,8 +16,8 @@ EXTRACT_ONLY=
MAINTAINER= andrew+ports@fubar.geek.nz
COMMENT= App framework for Lua 5.0.x
-BUILD_DEPENDS= ${LOCALBASE}/include/lua.h:${PORTSDIR}/lang/lua
-RUN_DEPENDS= ${LOCALBASE}/include/lua.h:${PORTSDIR}/lang/lua \
+BUILD_DEPENDS= ${LOCALBASE}/include/lua.h:${PORTSDIR}/lang/lua50
+RUN_DEPENDS= ${LOCALBASE}/include/lua.h:${PORTSDIR}/lang/lua50 \
${LOCALBASE}/share/lua/5.0/posix.lua:${PORTSDIR}/devel/lua50-posix \
${LOCALBASE}/share/lua/5.0/filename.lua:${PORTSDIR}/devel/lua50-filename \
${LOCALBASE}/share/lua/5.0/pty.lua:${PORTSDIR}/devel/lua50-pty
diff --git a/devel/lua50-compat51/Makefile b/devel/lua50-compat51/Makefile
index 81184fe7f65b..a4b7d5a7b8dc 100644
--- a/devel/lua50-compat51/Makefile
+++ b/devel/lua50-compat51/Makefile
@@ -14,7 +14,7 @@ DISTNAME= compat-${CVER}${CREV}.tar.gz
MAINTAINER= andrew+ports@fubar.geek.nz
COMMENT= Lua 5.1 package compatibility layer for Lua 5.0.x
-BUILD_DEPENDS= ${LOCALBASE}/include/lua.h:${PORTSDIR}/lang/lua
+BUILD_DEPENDS= ${LOCALBASE}/include/lua.h:${PORTSDIR}/lang/lua50
CONFLICTS= luasocket-2.0
diff --git a/devel/lua50-dfui/Makefile b/devel/lua50-dfui/Makefile
index fbf19ecc6f43..6901938edb6f 100644
--- a/devel/lua50-dfui/Makefile
+++ b/devel/lua50-dfui/Makefile
@@ -16,10 +16,10 @@ DISTNAME= lua-dfui-0.1.20050901
MAINTAINER= andrew+ports@fubar.geek.nz
COMMENT= DFUI binding for Lua 5.0.x
-BUILD_DEPENDS= ${LOCALBASE}/include/lua.h:${PORTSDIR}/lang/lua \
+BUILD_DEPENDS= ${LOCALBASE}/include/lua.h:${PORTSDIR}/lang/lua50 \
${NONEXISTENT}:${PORTSDIR}/devel/lua50-compat51:extract
LIB_DEPENDS= dfui4.4:${PORTSDIR}/devel/libdfui
-RUN_DEPENDS= ${LOCALBASE}/include/lua.h:${PORTSDIR}/lang/lua \
+RUN_DEPENDS= ${LOCALBASE}/include/lua.h:${PORTSDIR}/lang/lua50 \
${LOCALBASE}/share/lua/5.0/compat-5.1.lua:${PORTSDIR}/devel/lua50-compat51 \
${LOCALBASE}/share/lua/5.0/posix.lua:${PORTSDIR}/devel/lua50-posix
diff --git a/devel/lua50-filename/Makefile b/devel/lua50-filename/Makefile
index 3950ecb5e739..7b97eb46dc89 100644
--- a/devel/lua50-filename/Makefile
+++ b/devel/lua50-filename/Makefile
@@ -15,7 +15,7 @@ EXTRACT_ONLY=
MAINTAINER= andrew+ports@fubar.geek.nz
COMMENT= Filename-manipulating functions for Lua 5.0.x
-RUN_DEPENDS= ${LOCALBASE}/include/lua.h:${PORTSDIR}/lang/lua
+RUN_DEPENDS= ${LOCALBASE}/include/lua.h:${PORTSDIR}/lang/lua50
NO_WRKSUBDIR= yes
NO_BUILD= yes
diff --git a/devel/lua50-posix/Makefile b/devel/lua50-posix/Makefile
index 0e10e63b3bbc..26bfcb0a2000 100644
--- a/devel/lua50-posix/Makefile
+++ b/devel/lua50-posix/Makefile
@@ -14,7 +14,7 @@ DISTFILES= lposix.tar.gz
MAINTAINER= andrew+ports@fubar.geek.nz
COMMENT= A POSIX layer for Lua
-BUILD_DEPENDS= ${LOCALBASE}/include/lua.h:${PORTSDIR}/lang/lua
+BUILD_DEPENDS= ${LOCALBASE}/include/lua.h:${PORTSDIR}/lang/lua50
WRKSRC= ${WRKDIR}/posix
diff --git a/devel/lua50-pty/Makefile b/devel/lua50-pty/Makefile
index fa29708e8764..4758f2e58cbf 100644
--- a/devel/lua50-pty/Makefile
+++ b/devel/lua50-pty/Makefile
@@ -14,9 +14,9 @@ DISTFILES= pty.lua?rev=1.2 pty.c?rev=1.25
MAINTAINER= andrew+ports@fubar.geek.nz
COMMENT= Pty (pseudo-terminal) bindings for Lua 5.0.x
-BUILD_DEPENDS= ${LOCALBASE}/include/lua.h:${PORTSDIR}/lang/lua \
+BUILD_DEPENDS= ${LOCALBASE}/include/lua.h:${PORTSDIR}/lang/lua50 \
${NONEXISTENT}:${PORTSDIR}/devel/lua50-compat51:extract
-RUN_DEPENDS= ${LOCALBASE}/include/lua.h:${PORTSDIR}/lang/lua \
+RUN_DEPENDS= ${LOCALBASE}/include/lua.h:${PORTSDIR}/lang/lua50 \
${LOCALBASE}/share/lua/5.0/compat-5.1.lua:${PORTSDIR}/devel/lua50-compat51
LIBDIR= ${PREFIX}/lib/lua/5.0
diff --git a/games/alephone/Makefile b/games/alephone/Makefile
index c10d388146e2..457e78b9a102 100644
--- a/games/alephone/Makefile
+++ b/games/alephone/Makefile
@@ -17,7 +17,7 @@ COMMENT= The open source version of Bungie's Marathon game
BUILD_DEPENDS= ${LOCALBASE}/include/boost/function.hpp:${PORTSDIR}/devel/boost
LIB_DEPENDS= speex.3:${PORTSDIR}/audio/speex \
- lua.5:${PORTSDIR}/lang/lua
+ lua.5:${PORTSDIR}/lang/lua50
USE_X_PREFIX= yes
USE_GNOME= gnometarget
diff --git a/games/fillets-ng/Makefile b/games/fillets-ng/Makefile
index 0525f74f9557..c52baa160ea8 100644
--- a/games/fillets-ng/Makefile
+++ b/games/fillets-ng/Makefile
@@ -19,7 +19,7 @@ EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
MAINTAINER= amdmi3@mail.ru
COMMENT= A wonderful puzzle game
-LIB_DEPENDS= lua.5:${PORTSDIR}/lang/lua
+LIB_DEPENDS= lua.5:${PORTSDIR}/lang/lua50
USE_SDL= sdl mixer image ttf
USE_GMAKE= yes
diff --git a/games/stratagus/Makefile b/games/stratagus/Makefile
index 3c1110bd4ccc..2ae1d9462f9f 100644
--- a/games/stratagus/Makefile
+++ b/games/stratagus/Makefile
@@ -17,7 +17,7 @@ MAINTAINER= tlp@liquidx.org
COMMENT= Free cross-platform real-time strategy gaming engine
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
- lua.5:${PORTSDIR}/lang/lua
+ lua.5:${PORTSDIR}/lang/lua50
USE_SDL= yes
USE_XLIB= yes
diff --git a/games/xmoto/Makefile b/games/xmoto/Makefile
index 9bacefe05b36..f64ea62eabbf 100644
--- a/games/xmoto/Makefile
+++ b/games/xmoto/Makefile
@@ -18,7 +18,7 @@ COMMENT= Challenging 2D motocross platform game
LIB_DEPENDS= vorbis.3:${PORTSDIR}/audio/libvorbis \
png.5:${PORTSDIR}/graphics/png \
jpeg.9:${PORTSDIR}/graphics/jpeg \
- lua.5:${PORTSDIR}/lang/lua
+ lua.5:${PORTSDIR}/lang/lua50
BUILD_DEPENDS= ${X11BASE}/lib/libode.a:${PORTSDIR}/devel/ode
GNU_CONFIGURE= yes
diff --git a/lang/ruby-lua/Makefile b/lang/ruby-lua/Makefile
index 5576eaa9546a..9fbf12f09c4a 100644
--- a/lang/ruby-lua/Makefile
+++ b/lang/ruby-lua/Makefile
@@ -17,7 +17,7 @@ DIST_SUBDIR= ruby
MAINTAINER= ports@FreeBSD.org
COMMENT= A Ruby extension to make Lua script language as a class
-LIB_DEPENDS= lua.5:${PORTSDIR}/lang/lua
+LIB_DEPENDS= lua.5:${PORTSDIR}/lang/lua50
CONFLICTS= ${RUBY_PKGNAMEPREFIX}lua4-[0-9]*
diff --git a/lang/tolua++/Makefile b/lang/tolua++/Makefile
index 2775f1396d7e..e6d1d950c890 100644
--- a/lang/tolua++/Makefile
+++ b/lang/tolua++/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= aaron@FreeBSD.org
COMMENT= An extended version of tolua, a tool to integrate C/C++ code with Lua
BUILD_DEPENDS= ${LOCALBASE}/bin/scons:${PORTSDIR}/devel/scons
-LIB_DEPENDS= lua:${PORTSDIR}/lang/lua
+LIB_DEPENDS= lua:${PORTSDIR}/lang/lua50
WRKSRC= ${WRKDIR}/tolua++-${PORTVERSION}
USE_BZIP2= yes
diff --git a/lang/tolua++50/Makefile b/lang/tolua++50/Makefile
index 2775f1396d7e..e6d1d950c890 100644
--- a/lang/tolua++50/Makefile
+++ b/lang/tolua++50/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= aaron@FreeBSD.org
COMMENT= An extended version of tolua, a tool to integrate C/C++ code with Lua
BUILD_DEPENDS= ${LOCALBASE}/bin/scons:${PORTSDIR}/devel/scons
-LIB_DEPENDS= lua:${PORTSDIR}/lang/lua
+LIB_DEPENDS= lua:${PORTSDIR}/lang/lua50
WRKSRC= ${WRKDIR}/tolua++-${PORTVERSION}
USE_BZIP2= yes
diff --git a/lang/tolua/Makefile b/lang/tolua/Makefile
index 4c589077c09d..02c083a00bda 100644
--- a/lang/tolua/Makefile
+++ b/lang/tolua/Makefile
@@ -15,7 +15,7 @@ MASTER_SITES= ftp://ftp.tecgraf.puc-rio.br/pub/users/celes/tolua/ \
MAINTAINER= edwin@mavetju.org
COMMENT= toLua: accessing C/C++ code from Lua
-LIB_DEPENDS= lua:${PORTSDIR}/lang/lua
+LIB_DEPENDS= lua:${PORTSDIR}/lang/lua50
WRKSRC= ${WRKDIR}/${PORTNAME}-5.0
USE_GMAKE= yes
diff --git a/lang/tolua50/Makefile b/lang/tolua50/Makefile
index 4c589077c09d..02c083a00bda 100644
--- a/lang/tolua50/Makefile
+++ b/lang/tolua50/Makefile
@@ -15,7 +15,7 @@ MASTER_SITES= ftp://ftp.tecgraf.puc-rio.br/pub/users/celes/tolua/ \
MAINTAINER= edwin@mavetju.org
COMMENT= toLua: accessing C/C++ code from Lua
-LIB_DEPENDS= lua:${PORTSDIR}/lang/lua
+LIB_DEPENDS= lua:${PORTSDIR}/lang/lua50
WRKSRC= ${WRKDIR}/${PORTNAME}-5.0
USE_GMAKE= yes
diff --git a/mail/imapfilter/Makefile b/mail/imapfilter/Makefile
index f33b33c8dcb8..d6ac8773ed69 100644
--- a/mail/imapfilter/Makefile
+++ b/mail/imapfilter/Makefile
@@ -13,7 +13,7 @@ MASTER_SITES= http://imapfilter.hellug.gr/source/
MAINTAINER= lefcha@hellug.gr
COMMENT= IMAP mail filtering utility
-LIB_DEPENDS= lua.5:${PORTSDIR}/lang/lua
+LIB_DEPENDS= lua.5:${PORTSDIR}/lang/lua50
USE_BZIP2= yes
USE_OPENSSL= yes
diff --git a/net-p2p/verlihub-plugins/Makefile b/net-p2p/verlihub-plugins/Makefile
index 57241a04b3a1..3f170a029d17 100644
--- a/net-p2p/verlihub-plugins/Makefile
+++ b/net-p2p/verlihub-plugins/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= hurbold@yahoo.com
COMMENT= Plugins for the Verlihub Linux/Unix Direct Connect Hub Software
BUILD_DEPENDS= ${LOCALBASE}/bin/verlihub:${PORTSDIR}/net-p2p/verlihub
-LIB_DEPENDS= lua.5:${PORTSDIR}/lang/lua
+LIB_DEPENDS= lua.5:${PORTSDIR}/lang/lua50
WRKSRC= ${WRKDIR}/vh_plugins-0.1
diff --git a/net/luasocket/Makefile b/net/luasocket/Makefile
index 57acda30f23b..e780e68ede3a 100644
--- a/net/luasocket/Makefile
+++ b/net/luasocket/Makefile
@@ -14,8 +14,8 @@ MASTER_SITES= http://luaforge.net/frs/download.php/1097/
MAINTAINER= andrew+ports@fubar.geek.nz
COMMENT= IPv4 Sockets support for the Lua language
-BUILD_DEPENDS= ${LOCALBASE}/include/lua.h:${PORTSDIR}/lang/lua
-RUN_DEPENDS= ${LOCALBASE}/include/lua.h:${PORTSDIR}/lang/lua \
+BUILD_DEPENDS= ${LOCALBASE}/include/lua.h:${PORTSDIR}/lang/lua50
+RUN_DEPENDS= ${LOCALBASE}/include/lua.h:${PORTSDIR}/lang/lua50 \
${LOCALBASE}/share/lua/5.0/compat-5.1.lua:${PORTSDIR}/devel/lua50-compat51
USE_GMAKE= yes
diff --git a/www/elinks/Makefile b/www/elinks/Makefile
index e23183e1b0f5..dfc521f0941f 100644
--- a/www/elinks/Makefile
+++ b/www/elinks/Makefile
@@ -74,7 +74,7 @@ CONFIGURE_ARGS+= --without-guile
.endif
.if defined(WITH_LUASCRIPT)
-LIB_DEPENDS+= lua:${PORTSDIR}/lang/lua
+LIB_DEPENDS+= lua:${PORTSDIR}/lang/lua50
CONFIGURE_ARGS+= --with-lua
.else
CONFIGURE_ARGS+= --without-lua
diff --git a/www/lighttpd/Makefile b/www/lighttpd/Makefile
index 4af6b6541b6b..6e990c3e6718 100644
--- a/www/lighttpd/Makefile
+++ b/www/lighttpd/Makefile
@@ -59,7 +59,7 @@ CONFIGURE_ARGS+= --disable-ipv6
.endif
.if defined(WITH_CML)
-LIB_DEPENDS+= lua.5:${PORTSDIR}/lang/lua
+LIB_DEPENDS+= lua.5:${PORTSDIR}/lang/lua50
CONFIGURE_ARGS+= --with-lua
CONFIGURE_ENV+= CFLAGS=-I${LOCALBASE}/include LDFLAGS=-L/${LOCALBASE}/lib
.endif
diff --git a/x11-wm/ion-2/Makefile b/x11-wm/ion-2/Makefile
index 4d7fad126cda..5bdd1fc06fdd 100644
--- a/x11-wm/ion-2/Makefile
+++ b/x11-wm/ion-2/Makefile
@@ -15,7 +15,7 @@ MASTER_SITES= http://modeemi.fi/~tuomov/ion/dl/
MAINTAINER= anthony.ginepro@laposte.net
COMMENT= Ion is a tiling tabbed window manager
-LIB_DEPENDS= lua.5:${PORTSDIR}/lang/lua
+LIB_DEPENDS= lua.5:${PORTSDIR}/lang/lua50
CONFLICTS= ion-2002* ion-devel-* pwm-*
diff --git a/x11-wm/ion-3/Makefile b/x11-wm/ion-3/Makefile
index f3935a60e119..a7229de0e44d 100644
--- a/x11-wm/ion-3/Makefile
+++ b/x11-wm/ion-3/Makefile
@@ -13,7 +13,7 @@ MASTER_SITES= http://modeemi.fi/~tuomov/ion/dl/
MAINTAINER= ed@fxq.nl
COMMENT= The development version of the Ion window manager
-LIB_DEPENDS= lua.5:${PORTSDIR}/lang/lua
+LIB_DEPENDS= lua.5:${PORTSDIR}/lang/lua50
RUN_DEPENDS= run-mailcap:${PORTSDIR}/misc/mime-support
CONFLICTS= ion-2002* pwm-[0-9]* ion-2*
diff --git a/x11-wm/ion-3ds/Makefile b/x11-wm/ion-3ds/Makefile
index f3935a60e119..a7229de0e44d 100644
--- a/x11-wm/ion-3ds/Makefile
+++ b/x11-wm/ion-3ds/Makefile
@@ -13,7 +13,7 @@ MASTER_SITES= http://modeemi.fi/~tuomov/ion/dl/
MAINTAINER= ed@fxq.nl
COMMENT= The development version of the Ion window manager
-LIB_DEPENDS= lua.5:${PORTSDIR}/lang/lua
+LIB_DEPENDS= lua.5:${PORTSDIR}/lang/lua50
RUN_DEPENDS= run-mailcap:${PORTSDIR}/misc/mime-support
CONFLICTS= ion-2002* pwm-[0-9]* ion-2*
diff --git a/x11-wm/ion3/Makefile b/x11-wm/ion3/Makefile
index 4d7fad126cda..5bdd1fc06fdd 100644
--- a/x11-wm/ion3/Makefile
+++ b/x11-wm/ion3/Makefile
@@ -15,7 +15,7 @@ MASTER_SITES= http://modeemi.fi/~tuomov/ion/dl/
MAINTAINER= anthony.ginepro@laposte.net
COMMENT= Ion is a tiling tabbed window manager
-LIB_DEPENDS= lua.5:${PORTSDIR}/lang/lua
+LIB_DEPENDS= lua.5:${PORTSDIR}/lang/lua50
CONFLICTS= ion-2002* ion-devel-* pwm-*
diff --git a/x11/kdelibs3/Makefile b/x11/kdelibs3/Makefile
index a94d1ae0d82c..b7f2cfe0d4c8 100644
--- a/x11/kdelibs3/Makefile
+++ b/x11/kdelibs3/Makefile
@@ -27,7 +27,7 @@ LIB_DEPENDS= IlmImf:${PORTSDIR}/graphics/OpenEXR \
dns_sd:${PORTSDIR}/net/mDNSResponder \
idn:${PORTSDIR}/dns/libidn \
jasper:${PORTSDIR}/graphics/jasper \
- lua.5:${PORTSDIR}/lang/lua \
+ lua.5:${PORTSDIR}/lang/lua50 \
pcre:${PORTSDIR}/devel/pcre \
tiff.4:${PORTSDIR}/graphics/tiff \
xml2.5:${PORTSDIR}/textproc/libxml2 \
diff --git a/x11/kdelibs4/Makefile b/x11/kdelibs4/Makefile
index a94d1ae0d82c..b7f2cfe0d4c8 100644
--- a/x11/kdelibs4/Makefile
+++ b/x11/kdelibs4/Makefile
@@ -27,7 +27,7 @@ LIB_DEPENDS= IlmImf:${PORTSDIR}/graphics/OpenEXR \
dns_sd:${PORTSDIR}/net/mDNSResponder \
idn:${PORTSDIR}/dns/libidn \
jasper:${PORTSDIR}/graphics/jasper \
- lua.5:${PORTSDIR}/lang/lua \
+ lua.5:${PORTSDIR}/lang/lua50 \
pcre:${PORTSDIR}/devel/pcre \
tiff.4:${PORTSDIR}/graphics/tiff \
xml2.5:${PORTSDIR}/textproc/libxml2 \