aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--sysutils/cronolog/Makefile16
-rw-r--r--sysutils/grub2/Makefile9
-rw-r--r--sysutils/klaptopdaemon/Makefile19
-rw-r--r--sysutils/nitrogen/Makefile13
-rw-r--r--sysutils/nut22/Makefile41
-rw-r--r--sysutils/reed/Makefile3
-rw-r--r--textproc/libtranslate/Makefile32
-rw-r--r--textproc/sml-fxp/Makefile43
-rw-r--r--textproc/tdhkit/Makefile22
9 files changed, 87 insertions, 111 deletions
diff --git a/sysutils/cronolog/Makefile b/sysutils/cronolog/Makefile
index 24c6128caf19..6b78e28f5477 100644
--- a/sysutils/cronolog/Makefile
+++ b/sysutils/cronolog/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: cronolog
-# Date created: 20 January 2000
-# Whom: Mark Blackman <tmb_ports@maddog.u-net.com>
-#
+# Created by: Mark Blackman <tmb_ports@maddog.u-net.com>
# $FreeBSD$
-#
PORTNAME= cronolog
PORTVERSION= 1.6.2
@@ -21,14 +17,16 @@ MAN1= cronolog.1m cronosplit.1m
GNU_CONFIGURE= yes
-OPTIONS= SETUID_PATCH "Build with setuid functionality" On
+OPTIONS_DEFINE= SETUID_PATCH
+OPTIONS_DEFAULT= SETUID_PATCH
+SETUID_PATCH_DESC= Build with setuid functionality
EXTRA_PATCHES= ${FILESDIR}/extrapatch-src_cronoutils.c
PATCH_STRIP= -p1
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_SETUID_PATCH)
+.if ${PORT_OPTIONS:MSETUID_PATCH}
MASTER_SITES+= http://cronolog.org/patches/:patches
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} cronolog-setugid-patch.txt:patches
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
@@ -40,4 +38,4 @@ post-extract:
@cd ${WRKSRC} && ${TOUCH} aclocal.m4 Makefile.in */Makefile.in
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/grub2/Makefile b/sysutils/grub2/Makefile
index 084774f6be15..b9f3988d0a0b 100644
--- a/sysutils/grub2/Makefile
+++ b/sysutils/grub2/Makefile
@@ -21,11 +21,12 @@ ONLY_FOR_ARCHS= i386 amd64
INFO= grub
-OPTIONS= MKFONT "Build grub-mkfont (require freetype2)" off
+OPTIONS_DEFINE= MKFONT
+MKFONT_DESC= Build grub-mkfont (require freetype2)
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_MKFONT)
+.if ${PORT_OPTIONS:MMKFONT}
LIB_DEPENDS+= freetype.9:${PORTSDIR}/print/freetype2
.else
MKFONT= "@comment "
@@ -36,4 +37,4 @@ PLIST_SUB+= MKFONT=${MKFONT}
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/klaptopdaemon/Makefile b/sysutils/klaptopdaemon/Makefile
index b6619679c5cb..c27d275e52a4 100644
--- a/sysutils/klaptopdaemon/Makefile
+++ b/sysutils/klaptopdaemon/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: klaptopdaemon
-# Date created: July 08 2004
-# Whom: Michael Nottebrock <lofi@FreeBSD.org>
-#
+# Created by: Michael Nottebrock <lofi@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= klaptopdaemon
PORTVERSION= ${KDE_VERSION}
@@ -18,7 +14,8 @@ DIST_SUBDIR= KDE
MAINTAINER= ports@FreeBSD.org
COMMENT= APM monitor for KDE
-OPTIONS= #no options for amd64
+OPTIONS_DEFINE_i386= ACPI
+ACPI_DESC= Contributed ACPI support patch
USE_KDELIBS_VER=3
@@ -33,15 +30,7 @@ USE_LDCONFIG= yes
.include <bsd.port.pre.mk>
-.if ${ARCH} == "i386"
-OPTIONS= ACPI "Contributed ACPI support patch" off
-.endif
-
-.if ${ARCH} == "amd64"
-WITH_ACPI= yes
-.endif
-
-.if defined(WITH_ACPI)
+.if ${PORT_OPTIONS:MACPI} || ${ARCH} == "amd64"
EXTRA_PATCHES+= ${PATCHDIR}/extrapatch-acpi-support
ONLY_FOR_ARCHS+=amd64
.endif
diff --git a/sysutils/nitrogen/Makefile b/sysutils/nitrogen/Makefile
index f1ca9dcbbca7..142decb936a7 100644
--- a/sysutils/nitrogen/Makefile
+++ b/sysutils/nitrogen/Makefile
@@ -23,21 +23,22 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-inotify
CXXFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
-OPTIONS= XINERAMA "Xinerama support" on
+OPTIONS_DEFINE= XINERAMA
+OPTIONS_DEFAULT= XINERAMA
MAN1= nitrogen.1
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITHOUT_XINERAMA)
-CONFIGURE_ARGS+=--disable-xinerama
-.else
+.if ${PORT_OPTIONS:MXINERAMA}
CONFIGURE_ARGS+=--enable-xinerama
USE_XORG+= xinerama
+.else
+CONFIGURE_ARGS+=--disable-xinerama
.endif
post-patch:
@${REINPLACE_CMD} -e 's,#!/bin/bash,#!${LOCALBASE}/bin/bash,' \
${WRKSRC}/data/icon-theme-installer
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/nut22/Makefile b/sysutils/nut22/Makefile
index 52342e9bb8b0..cae0333a09c6 100644
--- a/sysutils/nut22/Makefile
+++ b/sysutils/nut22/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: nut
-# Date created: 08 Jan 2000
-# Whom: Boris Popov <bp@freebsd.org>
-#
+# Created by: Boris Popov <bp@freebsd.org>
# $FreeBSD$
-#
PORTNAME= nut
PORTVERSION= 2.2.2
@@ -28,14 +24,13 @@ NUT_USER?= uucp
NUT_GROUP?= uucp
STATEDIR?= /var/db/nut
-OPTIONS= SERIAL "SERIAL support" on \
- USB "USB support" on \
- SNMP "SNMP support" on \
- NEON "NEON XML/HTTP support" on \
- HAL "HAL support" off \
- IPV6 "IPV6 support" on \
- DEVEL "Install header files" off \
- CGI "Web CGI interface" off \
+OPTIONS_DEFINE= SERIAL USB SNMP NEON HAL IPV6 DEVEL CGI DOCS
+OPTIONS_DEFAULT= SERIAL USB SNMP NEON IPV6
+SERIAL_DESC= SERIAL support
+USB_DESC= USB support
+NEON_DESC= NEON XML/HTTP support
+DEVEL_DESC= Install header files
+CGI_DESC= Web CGI interface
USE_RC_SUBR= nut nut_upsmon nut_upslog
SUB_LIST+= STATEDIR=${STATEDIR}
@@ -64,7 +59,7 @@ CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc/nut \
--with-user=${NUT_USER} \
--with-group=${NUT_GROUP}
-.if defined(WITH_CGI)
+.if ${PORT_OPTIONS:MCGI}
LIB_DEPENDS+= gd.4:${PORTSDIR}/graphics/gd
MAN5+= hosts.conf.5 upsset.conf.5 upsstats.html.5
MAN8+= upsset.cgi.8 upsstats.cgi.8 upsimage.cgi.8
@@ -82,7 +77,7 @@ CONFIGURE_ARGS+= --without-cgi
PLIST_SUB+= NUT_CGI="@comment "
.endif
-.if !defined(WITHOUT_SERIAL)
+.if ${PORT_OPTIONS:MSERIAL}
CONFIGURE_ARGS+= --with-serial
MAN8+= al175.8 apcsmart.8 bcmxcp.8 belkin.8 belkinunv.8 \
bestuferrups.8 bestups.8 bestfcom.8 cpsups.8 cyberpower.8 \
@@ -97,7 +92,7 @@ CONFIGURE_ARGS+= --without-serial
PLIST_SUB+= NUT_SERIAL="@comment "
.endif
-.if !defined(WITHOUT_USB)
+.if ${PORT_OPTIONS:MUS}
. if ${OSVERSION} < 800069
LIB_DEPENDS+= usb-0.1.8:${PORTSDIR}/devel/libusb
. else
@@ -111,7 +106,7 @@ CONFIGURE_ARGS+= --without-usb
PLIST_SUB+= NUT_USB="@comment "
.endif
-.if !defined(WITHOUT_SNMP)
+.if ${PORT_OPTIONS:MSNMP}
LIB_DEPENDS+= netsnmp.30:${PORTSDIR}/net-mgmt/net-snmp
CONFIGURE_ARGS+= --with-snmp
MAN8+= snmp-ups.8
@@ -121,7 +116,7 @@ CONFIGURE_ARGS+= --without-snmp
PLIST_SUB+= NUT_SNMP="@comment "
.endif
-.if !defined(WITHOUT_NEON)
+.if ${PORT_OPTIONS:MNEON}
LIB_DEPENDS+= neon.27:${PORTSDIR}/www/neon29
CONFIGURE_ARGS+= --with-neonxml
MAN8+= netxml-ups.8
@@ -131,8 +126,8 @@ CONFIGURE_ARGS+= --without-neonxml
PLIST_SUB+= NUT_NEON="@comment "
.endif
-.if defined(WITH_HAL)
-. if defined(WITHOUT_USB)
+.if ${PORT_OPTIONS:MHAL}
+. if empty(PORT_OPTIONS:MUSB}
BROKEN= HAL is only usable with USB support enabled. Run 'make config' again!
. endif
LIB_DEPENDS+= hal.1:${PORTSDIR}/sysutils/hal
@@ -144,13 +139,13 @@ CONFIGURE_ARGS+= --without-hal
PLIST_SUB+= NUT_HAL="@comment "
.endif
-.if !defined(WITHOUT_IPV6)
+.if ${PORT_OPTIONS:MIPV6}
CONFIGURE_ARGS+= --with-ipv6
.else
CONFIGURE_ARGS+= --without-ipv6
.endif
-.if defined(WITH_DEVEL)
+.if ${PORT_OPTIONS:MDEVEL}
CONFIGURE_ARGS+= --with-dev
MAN3+= upscli_connect.3 upscli_disconnect.3 upscli_fd.3 \
upscli_get.3 upscli_list_next.3 upscli_list_start.3 \
@@ -170,7 +165,7 @@ pre-install:
@${CHOWN} ${NUT_USER}:${NUT_GROUP} ${STATEDIR}
@${CHMOD} 0750 ${STATEDIR}
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
post-install:
@${MKDIR} ${DOCSDIR}/cables
${INSTALL_DATA} ${WRKSRC}/docs/cables/*.txt ${DOCSDIR}/cables
diff --git a/sysutils/reed/Makefile b/sysutils/reed/Makefile
index 4734a5d17829..f5c29649703d 100644
--- a/sysutils/reed/Makefile
+++ b/sysutils/reed/Makefile
@@ -14,6 +14,9 @@ MASTER_SITES= http://www.sacredchao.net/~piman/archive/
MAINTAINER= ports@FreeBSD.org
COMMENT= A text pager with autoscrolling and more
+DEPRECATED= No more public distfiles
+EXPIRATION_DATE= 2012-10-20
+
USE_PERL5= yes
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= configures
diff --git a/textproc/libtranslate/Makefile b/textproc/libtranslate/Makefile
index e3777685f66c..acd42cbdaa94 100644
--- a/textproc/libtranslate/Makefile
+++ b/textproc/libtranslate/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: libtranslate
-# Date created: 15 Jan 2005
-# Whom: Jean-Yves Lefort <jylefort@brutele.be>
-#
+# Created by: Jean-Yves Lefort <jylefort@brutele.be>
# $FreeBSD$
-#
PORTNAME= libtranslate
PORTVERSION= 0.99
@@ -30,8 +26,10 @@ LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc
MAKE_JOBS_SAFE= yes
-OPTIONS= GENERIC "generic module" on \
- TALKFILTERS "talkfilters module" on
+OPTIONS_DEFINE= GENERIC TALKFILTERS
+OPTIONS_DEFAULT= GENERIC TALKFILTERS
+GENERIC_DESC= generic module
+TALKFILTERS_DESC= talkfilters module
MAN1= translate.1
@@ -39,12 +37,9 @@ post-patch::
@${REINPLACE_CMD} -e 's|echo aout|echo elf|' \
-e 's|libsoup-2.2|libsoup-2.4|g' ${WRKSRC}/configure
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITHOUT_GENERIC)
-CONFIGURE_ARGS+= --disable-generic
-PLIST_SUB+= GENERIC="@comment "
-.else
+.if ${PORT_OPTIONS:MGENERIC}
PLIST_SUB+= GENERIC=""
USE_GNOME+= libxml2
LIB_DEPENDS+= soup-2.4:${PORTSDIR}/devel/libsoup
@@ -57,14 +52,17 @@ post-patch::
${SED} s,SOUP_MESSAGE_RESPONSE_,trans_SOUP_MESSAGE_RESPONSE_,g \
${DISTDIR}/libtranslate-0.99-libsoup24.diff \
| ${PATCH} -d ${WRKSRC} -p1
+.else
+CONFIGURE_ARGS+= --disable-generic
+PLIST_SUB+= GENERIC="@comment "
.endif
-.if defined(WITHOUT_TALKFILTERS)
-CONFIGURE_ARGS+= --disable-talkfilters
-PLIST_SUB+= TALKFILTERS="@comment "
-.else
+.if ${PORT_OPTIONS:MTALKFILTERS}
PLIST_SUB+= TALKFILTERS=""
LIB_DEPENDS+= talkfilters:${PORTSDIR}/misc/talkfilters
+.else
+CONFIGURE_ARGS+= --disable-talkfilters
+PLIST_SUB+= TALKFILTERS="@comment "
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/sml-fxp/Makefile b/textproc/sml-fxp/Makefile
index c4f16c3efee2..ffef37b04fdd 100644
--- a/textproc/sml-fxp/Makefile
+++ b/textproc/sml-fxp/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: sml-fxp
-# Date created: 16 Sep 2007
-# Whom: Timothy Bourke <timbob@bigpond.com>
-#
+# Created by: Timothy Bourke <timbob@bigpond.com>
# $FreeBSD$
-#
PORTNAME= sml-fxp
PORTVERSION= 2.0
@@ -25,19 +21,20 @@ COMMENT= Validating XML parser with Standard ML interface
# On Off On build apps and stabilize with sml-nj-devel
# Off On On apps with mlton, stabilize for sml-nj
# On On On apps with mlton, stabilize for sml-nj-devel
-OPTIONS= X11 "Build with X11 support" on \
- STABILIZATION "Stabilize the libraries for SML/NJ." on \
- DEVEL "Prefer the devel version of SML/NJ." on \
- MLTON "Build executables with mlton." off
+OPTIONS_DEFINE= X11 STABILIZATION DEVEL MLTON DOCS
+OPTIONS_DEFAULT= X11 STABILIZATION DEVEL
+STABILIZATION_DESC= Stabilize the libraries for SML/NJ.
+DEVEL_DESC= Prefer the devel version of SML/NJ.
+MLTON_DESC= Build executables with mlton.
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_X11)
+.if ${PORT_OPTIONS:MX11}
RUN_DEPENDS+= xvcg:${PORTSDIR}/graphics/vcg
.endif
-.if defined(WITH_STABILIZATION) || defined(WITHOUT_MLTON)
-.if defined(WITH_DEVEL)
+.if ${PORT_OPTIONS:MSTABILITATION} || empty(PORT_OPTIONS:MMLTON)
+.if ${PORT_OPTIONS:MDEVEL}
BUILD_DEPENDS+= smlnj-devel>=110.65:${PORTSDIR}/lang/sml-nj-devel
MAKE_ENV+= SMLNJ_DEVEL=yes
@@ -49,20 +46,18 @@ MAKE_ENV+= SMLNJ=yes
.endif
.endif
-.if defined(WITH_MLTON)
+.if ${PORT_OPTIONS:MMLTON}
PLIST_SUB+= SML_EXEC="@comment " SML_EXEC_DEVEL="@comment "
-.else
-.if defined(WITH_DEVEL)
+.elif ${PORT_OPTIONS:MDEVEL}
PLIST_SUB+= SML_EXEC="@comment " SML_EXEC_DEVEL=""
.else
PLIST_SUB+= SML_EXEC="" SML_EXEC_DEVEL="@comment "
.endif
-.endif
-.if defined(WITH_STABILIZATION)
+.if ${PORT_OPTIONS:MSTABILIZATION}
MAKE_ENV+= STABILIZE=yes
-.if defined(WITH_DEVEL)
+.if ${PORT_OPTIONS:MDEVEL}
PLIST_SUB+= STABLE="@comment " STABLE_DEVEL=""
.else
PLIST_SUB+= STABLE="" STABLE_DEVEL="@comment "
@@ -72,23 +67,23 @@ PLIST_SUB+= STABLE="" STABLE_DEVEL="@comment "
PLIST_SUB+= STABLE="@comment " STABLE_DEVEL="@comment "
.endif
-.if defined(WITH_STABILIZATION) && defined(WITH_DEVEL)
+.if ${PORT_OPTIONS:MSTABILITATION} || !empty(PORT_OPTIONS:MDEVEL)
RUN_DEPENDS+= smlnj-devel>=110.65:${PORTSDIR}/lang/sml-nj-devel
.endif
-.if defined(WITH_MLTON)
+.if ${PORT_OPTIONS:MMLTON}
BUILD_DEPENDS+= mlton:${PORTSDIR}/lang/mlton
MAKE_ENV+= MLTON_BUILD=yes
.endif
-.if defined(WITHOUT_MLTON) && defined(WITHOUT_DEVEL)
+.if empty(PORT_OPTIONS:MMLTON) && empty(PORT_OPTIONS:MDEVEL)
MAKE_ENV+= NO_HEAP2EXEC=yes
PLIST_SUB+= SML_EXEC=""
.else
PLIST_SUB+= SML_EXEC="@comment "
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
INSTALL_TARGET=install install-doc
.endif
@@ -130,4 +125,4 @@ post-patch:
${MV} ${WRKSRC}/$$e.sml.orig ${WRKSRC}/$$e.orig.sml; \
done
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/tdhkit/Makefile b/textproc/tdhkit/Makefile
index fbd13c562514..d531a07fd2ee 100644
--- a/textproc/tdhkit/Makefile
+++ b/textproc/tdhkit/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# Ports collection makefile for: tdhkit
-# Date created: 2 Mar 2010
-# Whom: corky1951@comcast.net
-#
+# Created by: corky1951@comcast.net
# $FreeBSD$
-#
PORTNAME= tdhkit
PORTVERSION= 1.0
@@ -15,11 +10,12 @@ DISTNAME= ${PORTNAME}${PORTVERSION:C/\.//1}
MAINTAINER= ports@FreeBSD.org
COMMENT= Set of programs for working with tabular ASCII data
-OPTIONS= LIBCHRON "Install libchron" Off
+OPTIONS_DEFINE= LIBCHRON DOCS
+LIBCHRON_DESC= Install libchron
.include <bsd.port.options.mk>
-.if defined(WITH_LIBCHRON)
+.if ${PORT_OPTIONS:MLIBCHRON}
PLIST_SUB+= LIBCHRON=""
.else
PLIST_SUB+= LIBCHRON="@comment "
@@ -37,7 +33,7 @@ MAN1= dateconvert.1 \
xlcells.1 \
xlcleaner.1
-.if defined(WITH_LIBCHRON)
+.if ${PORT_OPTIONS:MLIBCHRON}
MAN3= libchron.3
.endif
MANCOMPRESSED= no
@@ -48,7 +44,7 @@ do-build:
${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS}
cd ${WRKSRC}/src && ${SETENV} ${MAKE_ENV} \
${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS}
-.if defined(WITH_LIBCHRON)
+.if ${PORT_OPTIONS:MLIBCHRON}
cd ${WRKSRC}/libsrc && ${SETENV} ${MAKE_ENV} \
${MAKE} ${MAKE_FLAGS} ${MAKEFILE} libchron
.endif
@@ -56,7 +52,7 @@ do-build:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/* ${PREFIX}/bin
-.if defined(WITH_LIBCHRON)
+.if ${PORT_OPTIONS:MLIBCHRON}
${INSTALL_PROGRAM} ${WRKSRC}/libchron.a ${PREFIX}/lib
.endif
@@ -64,12 +60,12 @@ do-install:
.for manpage in ${MAN1}
${INSTALL_MAN} ${WRKSRC}/man/mantdh/${manpage} ${MAN1PREFIX}/man/man1
.endfor
-.if defined(WITH_LIBCHRON)
+.if ${PORT_OPTIONS:MLIBCHRON}
${INSTALL_MAN} ${WRKSRC}/man/mantdh/${MAN3} ${MAN3PREFIX}/man/man3
.endif
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/man/html/* ${DOCSDIR}
.endif