aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--security/Makefile1
-rw-r--r--security/pear-Horde_Crypt/Makefile29
-rw-r--r--security/pear-Horde_Crypt/distinfo2
-rw-r--r--security/pear-Horde_Crypt/pkg-descr4
4 files changed, 36 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 4b16d9072940..fbb9d1e8e637 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -606,6 +606,7 @@
SUBDIR += pear-File_SMBPasswd
SUBDIR += pear-HTML_Crypt
SUBDIR += pear-Horde_Auth
+ SUBDIR += pear-Horde_Crypt
SUBDIR += pear-Horde_Group
SUBDIR += pear-Horde_Perms
SUBDIR += pear-Horde_Secret
diff --git a/security/pear-Horde_Crypt/Makefile b/security/pear-Horde_Crypt/Makefile
new file mode 100644
index 000000000000..39d9dc96b5d2
--- /dev/null
+++ b/security/pear-Horde_Crypt/Makefile
@@ -0,0 +1,29 @@
+# Ports collection makefile for: pear-Horde_Crypt
+# Date created: 7 July 2011
+# Whom: Martin Matuska <mm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Horde_Crypt
+PORTVERSION= 1.0.3
+CATEGORIES= security www pear
+PKGNAMEPREFIX= pear-
+
+MAINTAINER= mm@FreeBSD.org
+COMMENT= Horde Cryptography API
+
+OPTIONS= BCMATH "Depend on bcmath PHP extension" Off
+
+USE_HORDE_RUN= Horde_Exception Horde_Mime Horde_Stream_Filter \
+ Horde_Translation Horde_Util
+USE_PHP= hash openssl
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_BCMATH)
+USE_PHP+= bcmath
+.endif
+
+.include "${PORTSDIR}/devel/pear-channel-horde/bsd.horde.mk"
+.include <bsd.port.post.mk>
diff --git a/security/pear-Horde_Crypt/distinfo b/security/pear-Horde_Crypt/distinfo
new file mode 100644
index 000000000000..9b098e9809b8
--- /dev/null
+++ b/security/pear-Horde_Crypt/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Horde/Horde_Crypt-1.0.3.tgz) = 1bf0a812e86e1559b88b44a58091d45ab27b7536bd18d97e86b27438e0ff1250
+SIZE (Horde/Horde_Crypt-1.0.3.tgz) = 127188
diff --git a/security/pear-Horde_Crypt/pkg-descr b/security/pear-Horde_Crypt/pkg-descr
new file mode 100644
index 000000000000..57339e09d060
--- /dev/null
+++ b/security/pear-Horde_Crypt/pkg-descr
@@ -0,0 +1,4 @@
+The Horde_Crypt package class provides an API for various cryptographic
+systems.
+
+WWW: http://pear.horde.org