aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--games/ioquake3-devel/Makefile5
-rw-r--r--games/ioquake3-devel/distinfo6
-rw-r--r--games/ioquake3-devel/pkg-descr12
-rw-r--r--games/ioquake3/Makefile30
-rw-r--r--games/ioquake3/pkg-descr12
5 files changed, 43 insertions, 22 deletions
diff --git a/games/ioquake3-devel/Makefile b/games/ioquake3-devel/Makefile
index a94250652ed8..9bfa4f6d5062 100644
--- a/games/ioquake3-devel/Makefile
+++ b/games/ioquake3-devel/Makefile
@@ -7,18 +7,17 @@
PORTNAME= ioquake3-devel
DISTVERSION= 1.36_SVN${SVNREVISION}
+PORTREVISION= 0
MASTER_SITES= ftp://deponie.yamagi.org/freebsd/distfiles/ioquake3/ \
http://deponie.yamagi.org/freebsd/distfiles/ioquake3/
MAINTAINER= kamikaze@bsdforen.de
COMMENT= Development SVN snapshots of ioquake3
-BUILD_DEPENDS+= svnversion:${PORTSDIR}/devel/subversion
-
PLIST= ${.CURDIR}/../ioquake3/pkg-plist
PATCHDIR= ${WRKDIR}/freebsd-patchset/
-SVNREVISION= 1754
+SVNREVISION= 1771
BINSUFFIX= -devel
.include "${.CURDIR}/../ioquake3/Makefile"
diff --git a/games/ioquake3-devel/distinfo b/games/ioquake3-devel/distinfo
index bea4e67f3870..0b3a5d6750fe 100644
--- a/games/ioquake3-devel/distinfo
+++ b/games/ioquake3-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (ioquake3-devel-1.36_SVN1754.zip) = 163fe62d8540244a9eda8af66ae62fb2
-SHA256 (ioquake3-devel-1.36_SVN1754.zip) = f743e4454bb445fd58188107ee0c36eb4ee3be0f9dce9667bec7516bec59136f
-SIZE (ioquake3-devel-1.36_SVN1754.zip) = 5017181
+MD5 (ioquake3-devel-1.36_SVN1771.zip) = 651a912a4cebb68f33a9f7fc63a3ec0e
+SHA256 (ioquake3-devel-1.36_SVN1771.zip) = 75aecab911f880e19d319c9e508fc4495b1d53e22207fae26d0a1b436817b4d9
+SIZE (ioquake3-devel-1.36_SVN1771.zip) = 4927089
diff --git a/games/ioquake3-devel/pkg-descr b/games/ioquake3-devel/pkg-descr
index d49d4c07954b..b43e2fb2ddf0 100644
--- a/games/ioquake3-devel/pkg-descr
+++ b/games/ioquake3-devel/pkg-descr
@@ -1,11 +1,5 @@
-This project, icculus.org/quake3 (sometimes referred to ioquake3, or ioq3 for
-short) aims to build upon id Software's Quake 3 source code release. The
-source code was released on August 20, 2005 under the GPL. Since then, we have
-been cleaning up, fixing bugs, and adding features. Our permanent goal is to
-create the open source Quake 3 distribution upon which people base their games
-and projects. We also seek to have the perfect version of the engine for
-playing Quake 3: Arena, Team Arena, and all popular mods. This distribution of
-the engine has been ported to many new platforms and has had a slew of new
-features added, along with massive bug extermination.
+This port builds development snapshots of icculus.org/quake3. The project is
+known to seldomly produce releases. Due to the conservative development goals
+of the project, development snapshots are generally considered reliable.
WWW: http://ioquake3.org/
diff --git a/games/ioquake3/Makefile b/games/ioquake3/Makefile
index 0c86a277433e..9ff06eadb05b 100644
--- a/games/ioquake3/Makefile
+++ b/games/ioquake3/Makefile
@@ -7,6 +7,7 @@
PORTNAME?= ioquake3
DISTVERSION?= 1.36
+PORTREVISION?= 1
CATEGORIES= games
MASTER_SITES?= http://ioquake3.org/files/${DISTVERSION}/
@@ -20,16 +21,20 @@ USE_ZIP?= yes
.endif
USE_GMAKE= yes
-OPTIONS= CLIENT "Build client" on \
+OPTIONS+= CLIENT "Build client" on \
GAMELIBS "Build game libraries (when not mandatory)" off \
DEDICATED "Build dedicated server" on \
+ CURL "Enable cURL for http/ftp download" on \
+ OPENAL "Enable OpenAL audio output" on \
+ MUMBLE "Enable Mumble support (no dependencies)" on \
VORBIS "Enable Ogg Vorbis support" on
MAKE_ARGS+= DEFAULT_BASEDIR="${Q3DIR}" \
DEFAULT_LIBDIR="${LIBDIR}" \
HOMEPATH="/.${PORTNAME}" \
+ VERSION="${DISTVERSION}" \
ARCH="${ARCH}"
-PLIST_SUB= LIBDIR="${LIBDIR:S/${PREFIX}\///}" \
+PLIST_SUB+= LIBDIR="${LIBDIR:S/${PREFIX}\///}" \
ARCH="${ARCH}" \
BINSUFFIX="${BINSUFFIX}"
ALL_TARGET= release
@@ -45,7 +50,7 @@ ONLY_FOR_ARCHS= amd64 i386
MACHINE_ARCH= ${ARCH}
.include <bsd.cpu.mk>
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if defined(WITHOUT_CLIENT) && defined(WITHOUT_DEDICATED) && \
defined(WITHOUT_SMP)
@@ -53,8 +58,19 @@ IGNORE= needs at least one of CLIENT, DEDICATED and SMP options
.endif
.if defined(WITH_CLIENT) || defined(WITH_SMP)
+# cURL
+.if defined(WITH_CURL)
+LIB_DEPENDS+= curl.5:${PORTSDIR}/ftp/curl
+#MAKE_ARGS+= USE_CURL_DLOPEN=0
+.else
+MAKE_ARGS+= USE_CURL=0
+.endif
# OpenAL
+.if defined(WITH_OPENAL)
LIB_DEPENDS+= openal.0:${PORTSDIR}/audio/openal
+.else
+MAKE_ARGS+= USE_OPENAL=0
+.endif
# SDL
USE_SDL= sdl
# Vorbis
@@ -62,6 +78,12 @@ USE_SDL= sdl
LIB_DEPENDS+= vorbis.4:${PORTSDIR}/audio/libvorbis
MAKE_ARGS+= USE_CODEC_VORBIS=1
.endif
+# Mumble
+.if defined(WITH_MUMBLE)
+MAKE_ARGS+= USE_MUMBLE=1
+.else
+MAKE_ARGS+= USE_MUMBLE=0
+.endif
.endif
# SMP is only built with CLIENT.
@@ -119,4 +141,4 @@ post-install:
@${ECHO_CMD}
.include "${.CURDIR}/../quake3-data/Makefile.include"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/ioquake3/pkg-descr b/games/ioquake3/pkg-descr
index 1e21a579ceb5..d49d4c07954b 100644
--- a/games/ioquake3/pkg-descr
+++ b/games/ioquake3/pkg-descr
@@ -1,5 +1,11 @@
-This port creates development snapshots of icculus.org/quake3. The project is
-known to seldomly produce releases. Due to the conservative development goals
-of the project, development snapshots are generally considered reliable.
+This project, icculus.org/quake3 (sometimes referred to ioquake3, or ioq3 for
+short) aims to build upon id Software's Quake 3 source code release. The
+source code was released on August 20, 2005 under the GPL. Since then, we have
+been cleaning up, fixing bugs, and adding features. Our permanent goal is to
+create the open source Quake 3 distribution upon which people base their games
+and projects. We also seek to have the perfect version of the engine for
+playing Quake 3: Arena, Team Arena, and all popular mods. This distribution of
+the engine has been ported to many new platforms and has had a slew of new
+features added, along with massive bug extermination.
WWW: http://ioquake3.org/