aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/py-rss2gen/Makefile21
-rw-r--r--textproc/py-rss2gen/distinfo2
-rw-r--r--textproc/py-rss2gen/pkg-descr3
-rw-r--r--textproc/py-rss2gen/pkg-plist3
5 files changed, 30 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 24e30a5aebd6..949e4dc9183a 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -513,6 +513,7 @@
SUBDIR += py-martel
SUBDIR += py-pyx12
SUBDIR += py-rdflib
+ SUBDIR += py-rss2gen
SUBDIR += py-rxp
SUBDIR += py-sgrep
SUBDIR += py-syck
diff --git a/textproc/py-rss2gen/Makefile b/textproc/py-rss2gen/Makefile
new file mode 100644
index 000000000000..4d48086be82c
--- /dev/null
+++ b/textproc/py-rss2gen/Makefile
@@ -0,0 +1,21 @@
+# Ports collection makefile for: py-rss2gen
+# Date created: 30 Sep 2004
+# Whom: "Choe, Cheng-Dae" whitekid
+#
+# $FreeBSD$
+#
+
+PORTNAME= rss2gen
+PORTVERSION= 0.0
+CATEGORIES= textproc python
+MASTER_SITES= http://www.dalkescientific.com/Python/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= PyRSS2Gen-${PORTVERSION}
+
+MAINTAINER= whitekid@gmail.com
+COMMENT= A Python library for generating RSS 2.0 feeds
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=yes
+
+.include <bsd.port.mk>
diff --git a/textproc/py-rss2gen/distinfo b/textproc/py-rss2gen/distinfo
new file mode 100644
index 000000000000..f4b26c212697
--- /dev/null
+++ b/textproc/py-rss2gen/distinfo
@@ -0,0 +1,2 @@
+MD5 (PyRSS2Gen-0.0.tar.gz) = 5f05762c356594f6de60f19a1e17e277
+SIZE (PyRSS2Gen-0.0.tar.gz) = 8246
diff --git a/textproc/py-rss2gen/pkg-descr b/textproc/py-rss2gen/pkg-descr
new file mode 100644
index 000000000000..6ee2ae1b5c05
--- /dev/null
+++ b/textproc/py-rss2gen/pkg-descr
@@ -0,0 +1,3 @@
+RSS2Gen is a Python library for generating RSS 2.0 feeds.
+
+WWW: http://www.dalkescientific.com/Python/PyRSS2Gen.html
diff --git a/textproc/py-rss2gen/pkg-plist b/textproc/py-rss2gen/pkg-plist
new file mode 100644
index 000000000000..a29049f41d42
--- /dev/null
+++ b/textproc/py-rss2gen/pkg-plist
@@ -0,0 +1,3 @@
+%%PYTHON_SITELIBDIR%%/PyRSS2Gen.py
+%%PYTHON_SITELIBDIR%%/PyRSS2Gen.pyc
+%%PYTHON_SITELIBDIR%%/PyRSS2Gen.pyo