aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--www/Makefile1
-rw-r--r--www/tidy-html5/Makefile30
-rw-r--r--www/tidy-html5/distinfo2
-rw-r--r--www/tidy-html5/pkg-descr11
-rw-r--r--www/tidy-html5/pkg-plist8
5 files changed, 52 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index b0f18d19a830..888739f25119 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -2011,6 +2011,7 @@
SUBDIR += tickr
SUBDIR += tidy
SUBDIR += tidy-devel
+ SUBDIR += tidy-html5
SUBDIR += tidy-lib
SUBDIR += tikiwiki
SUBDIR += tinymce
diff --git a/www/tidy-html5/Makefile b/www/tidy-html5/Makefile
new file mode 100644
index 000000000000..591db321fafb
--- /dev/null
+++ b/www/tidy-html5/Makefile
@@ -0,0 +1,30 @@
+# Created by: Thierry Thomas <thierry@pompo.net>
+# $FreeBSD$
+
+PORTNAME= tidy-html5
+PORTVERSION= 4.9.18
+CATEGORIES= www
+
+MAINTAINER= thierry@FreeBSD.org
+COMMENT= Tidy tidies HTML and XML documents
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+USE_GITHUB= yes
+GH_ACCOUNT= htacg
+GH_PROJECT= ${PORTNAME}
+GH_TAGNAME= ${GH_COMMIT}
+GH_COMMIT= 2e383c6
+
+USES= cmake
+
+CMAKE_ARGS= -DBUILD_SHARED_LIB:BOOL=ON
+
+pre-configure:
+ ${REINPLACE_CMD} -e 's|build/cmake/||' ${WRKSRC}/test/testone.sh
+
+regression-test:
+ (cd ${WRKSRC}/test && ./testall.sh)
+
+.include <bsd.port.mk>
diff --git a/www/tidy-html5/distinfo b/www/tidy-html5/distinfo
new file mode 100644
index 000000000000..9a4c2252b0e3
--- /dev/null
+++ b/www/tidy-html5/distinfo
@@ -0,0 +1,2 @@
+SHA256 (tidy-html5-4.9.18.tar.gz) = b426adf4bd389add6f8442790177bf479457c36f4fc91a73e2b166f9ee371b58
+SIZE (tidy-html5-4.9.18.tar.gz) = 492762
diff --git a/www/tidy-html5/pkg-descr b/www/tidy-html5/pkg-descr
new file mode 100644
index 000000000000..071889785d93
--- /dev/null
+++ b/www/tidy-html5/pkg-descr
@@ -0,0 +1,11 @@
+Tidy is a console application. It corrects and cleans up HTML and XML documents
+by fixing markup errors and upgrading legacy code to modern standards.
+
+TidyLib is a C static or dynamic library that developers can integrate into
+their applications in order to bring all of Tidy's power to your favorite tools.
+TidyLib is used today in desktop applications, web servers, and more.
+
+This is yet a development version. When it will become stable, it will
+supersedes the ports www/tidy-devel and www/tidy-lib.
+
+WWW: http://www.html-tidy.org/
diff --git a/www/tidy-html5/pkg-plist b/www/tidy-html5/pkg-plist
new file mode 100644
index 000000000000..901dc9727912
--- /dev/null
+++ b/www/tidy-html5/pkg-plist
@@ -0,0 +1,8 @@
+bin/tidy5
+include/buffio.h
+include/platform.h
+include/tidy.h
+include/tidyenum.h
+lib/libtidy5.so
+lib/libtidy5.so.4
+lib/libtidy5.so.4.9.18