aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--science/cdo/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/science/cdo/Makefile b/science/cdo/Makefile
index 2670df8ec841..7bd6a8a4c5d0 100644
--- a/science/cdo/Makefile
+++ b/science/cdo/Makefile
@@ -32,6 +32,7 @@ CONFIGURE_ARGS= --disable-cgribex \
--with-zlib=/usr
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
+TEST_TARGET= check
USE_LDCONFIG= yes
USES= gmake libtool pathfix
@@ -67,10 +68,7 @@ post-patch:
@${REINPLACE_CMD} -e 's|$$(libdir)/\($$$$pkgconfigfile\)|${PREFIX}/libdata/\1|' ${WRKSRC}/libcdi/src/Makefile.in
@${REINPLACE_CMD} -e 's|unsigned32 |uint32_t |' ${WRKSRC}/libcdi/src/cdilib.c ${WRKSRC}/libcdi/src/util.c
-regression-test test: build
-.if ${PORT_OPTIONS:MNETCDF}
+test-NETCDF-on:
@cd ${WRKSRC}/ && ${SETENV} CDO_PATH=src/cdo src/cdotest
-.endif
- cd ${WRKSRC}/ && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} check
.include <bsd.port.post.mk>