aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/py-elasticsearch-py/Makefile21
-rw-r--r--textproc/py-elasticsearch-py/distinfo2
-rw-r--r--textproc/py-elasticsearch-py/pkg-descr5
4 files changed, 29 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index ea2bf3b5a6f6..7b67e89d6373 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1145,6 +1145,7 @@
SUBDIR += py-creole
SUBDIR += py-docutils
SUBDIR += py-dsv
+ SUBDIR += py-elasticsearch-py
SUBDIR += py-elib.intl
SUBDIR += py-empy
SUBDIR += py-enchant
diff --git a/textproc/py-elasticsearch-py/Makefile b/textproc/py-elasticsearch-py/Makefile
new file mode 100644
index 000000000000..abc7824265be
--- /dev/null
+++ b/textproc/py-elasticsearch-py/Makefile
@@ -0,0 +1,21 @@
+# Created by: Ryan Steinmetz <zi@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= elasticsearch-py
+PORTVERSION= 1.0.0
+CATEGORIES= textproc python
+MASTER_SITES= #
+
+MAINTAINER= zi@FreeBSD.org
+COMMENT= Official Python low-level client for Elasticsearch
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}urllib3>=1.8.2:${PORTSDIR}/net/py-urllib3
+
+USE_GITHUB= yes
+GH_ACCOUNT= elasticsearch
+GH_COMMIT= 9bd4303
+USE_PYTHON= yes
+USE_PYDISTUTILS=yes
+PYDISTUTILS_AUTOPLIST=yes
+
+.include <bsd.port.mk>
diff --git a/textproc/py-elasticsearch-py/distinfo b/textproc/py-elasticsearch-py/distinfo
new file mode 100644
index 000000000000..5b4ee7eee70a
--- /dev/null
+++ b/textproc/py-elasticsearch-py/distinfo
@@ -0,0 +1,2 @@
+SHA256 (elasticsearch-py-1.0.0.tar.gz) = 690fef5ce825785de219c34d29912e5e23a7379f42d9dcee871b5dde7843c2b0
+SIZE (elasticsearch-py-1.0.0.tar.gz) = 63202
diff --git a/textproc/py-elasticsearch-py/pkg-descr b/textproc/py-elasticsearch-py/pkg-descr
new file mode 100644
index 000000000000..e6c321ce9722
--- /dev/null
+++ b/textproc/py-elasticsearch-py/pkg-descr
@@ -0,0 +1,5 @@
+Official low-level client for Elasticsearch. It's goal is to provide common
+ground for all Elasticsearch-related code in Python; because of this it tries
+to be opinion-free and very extendable.
+
+WWW: http://elasticsearch-py.readthedocs.org/en/master/