aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--cad/openscad/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/cad/openscad/Makefile b/cad/openscad/Makefile
index dc6f1db37f9f..7cf04e7eecbf 100644
--- a/cad/openscad/Makefile
+++ b/cad/openscad/Makefile
@@ -36,7 +36,13 @@ QMAKE_ARGS+= VERSION=${PORTVERSION} \
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
post-patch:
- ${REINPLACE_CMD} -e 's,share/man,man,' \
+ @${REINPLACE_CMD} -e 's,share/man,man,' \
${WRKSRC}/openscad.pro
+.include <bsd.port.options.mk>
+
+.if ${ARCH} == i386 && ${OPSYS} == FreeBSD && ${OSVERSION} >= 1100000
+BROKEN= does not build (libstdc++/libc++ incompatibility in cgal/boost)
+.endif
+
.include <bsd.port.mk>