aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--emulators/Makefile1
-rw-r--r--emulators/advancemame/Makefile56
-rw-r--r--emulators/advancemame/distinfo3
-rw-r--r--emulators/advancemame/pkg-descr22
-rw-r--r--emulators/advancemame/pkg-plist62
-rw-r--r--emulators/advancemess/Makefile58
-rw-r--r--emulators/advancemess/distinfo3
-rw-r--r--emulators/advancemess/files/patch-advance__advance.mak63
-rw-r--r--emulators/advancemess/pkg-descr22
-rw-r--r--emulators/advancemess/pkg-message8
-rw-r--r--emulators/advancemess/pkg-plist9
11 files changed, 307 insertions, 0 deletions
diff --git a/emulators/Makefile b/emulators/Makefile
index 65a69b8de7c7..14929fdd7850 100644
--- a/emulators/Makefile
+++ b/emulators/Makefile
@@ -5,6 +5,7 @@
SUBDIR += adamem
SUBDIR += advancemame
+ SUBDIR += advancemess
SUBDIR += aftp
SUBDIR += atari800
SUBDIR += basiliskII
diff --git a/emulators/advancemame/Makefile b/emulators/advancemame/Makefile
new file mode 100644
index 000000000000..3f9db06a23dd
--- /dev/null
+++ b/emulators/advancemame/Makefile
@@ -0,0 +1,56 @@
+# New ports collection makefile for: advancemame
+# Date created: 2007-01-10
+# Whom: alepulver
+#
+# $FreeBSD$
+#
+
+PORTNAME= advancemame
+PORTVERSION= 0.106.0
+CATEGORIES= emulators
+MASTER_SITES= SF
+
+MAINTAINER= alepulver@FreeBSD.org
+COMMENT= SDL MAME port with advanced TV and monitor video support
+
+LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
+
+USE_GL= yes
+USE_GMAKE= yes
+USE_SDL= sdl
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CFLAGS="${CFLAGS} -idirafter ${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+OPTIONS= FREETYPE "Enable FreeType2 support" off \
+ SLANG "Enable sLang support (for video driver)" off
+
+MAN1= advdev.1 advj.1 advk.1 advm.1 advmame.1 advs.1
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "i386"
+BUILD_DEPENDS+= nasm:${PORTSDIR}/devel/nasm
+.endif
+
+.if defined(WITH_FREETYPE)
+LIB_DEPENDS+= freetype.9:${PORTSDIR}/print/freetype2
+.else
+CONFIGURE_ARGS+=--disable-freetype
+.endif
+
+.if defined(WITH_SLANG)
+LIB_DEPENDS+= slang.2:${PORTSDIR}/devel/libslang2
+.else
+CONFIGURE_ARGS+=--disable-slang
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -Ee 's|^(pkg.*)/advance|\1/${PORTNAME}|' \
+ ${WRKSRC}/advance/advance.mak
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e '/pkgdocdir/d' ${WRKSRC}/advance/advance.mak
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/emulators/advancemame/distinfo b/emulators/advancemame/distinfo
new file mode 100644
index 000000000000..6b7610ca165e
--- /dev/null
+++ b/emulators/advancemame/distinfo
@@ -0,0 +1,3 @@
+MD5 (advancemame-0.106.0.tar.gz) = aa097a4a9046124e17aa83a215e454ea
+SHA256 (advancemame-0.106.0.tar.gz) = 2752b16ccbff2eb04b36ab4152901b9e483ef84f780b80596fb5fd1495bf6425
+SIZE (advancemame-0.106.0.tar.gz) = 16284344
diff --git a/emulators/advancemame/pkg-descr b/emulators/advancemame/pkg-descr
new file mode 100644
index 000000000000..4a03e51cf5ac
--- /dev/null
+++ b/emulators/advancemame/pkg-descr
@@ -0,0 +1,22 @@
+AdvanceMAME and AdvanceMESS are unofficial MAME and MESS versions with an
+advanced video support for helping the use with TVs, Arcade Monitors, Fixed
+Frequencies Monitors and also for PC Monitors.
+
+They run in GNU/Linux, Mac OS X, DOS, Windows and in all the other platforms
+supported by the SDL library.
+
+The main difference compared with the official emulators is that the Advance
+versions are able to program directly the video board to always get a video
+mode with the correct size and frequency.
+
+Generally the Advance emulators are able to use a video mode which doesn't
+require any stretching or other unneeded effects to match the original arcade
+display.
+
+The direct video board programming is fully supported in Linux and DOS. It's
+partially supported in Windows. It isn't supported in Mac OS X and other
+platforms.
+
+See website for other improvements.
+
+WWW: http://advancemame.sourceforge.net/
diff --git a/emulators/advancemame/pkg-plist b/emulators/advancemame/pkg-plist
new file mode 100644
index 000000000000..18bb23078a34
--- /dev/null
+++ b/emulators/advancemame/pkg-plist
@@ -0,0 +1,62 @@
+@exec for i in artwork crc image rom sample; do mkdir -p %D/%%DATADIR%%/${i}; done
+bin/advj
+bin/advk
+bin/advm
+bin/advmame
+bin/advs
+%%DATADIR%%/event.dat
+%%DATADIR%%/hiscore.dat
+%%DATADIR%%/history.dat
+%%PORTDOCS%%%%DOCSDIR%%/advcfg.html
+%%PORTDOCS%%%%DOCSDIR%%/advcfg.txt
+%%PORTDOCS%%%%DOCSDIR%%/advdev.html
+%%PORTDOCS%%%%DOCSDIR%%/advdev.txt
+%%PORTDOCS%%%%DOCSDIR%%/advj.html
+%%PORTDOCS%%%%DOCSDIR%%/advj.txt
+%%PORTDOCS%%%%DOCSDIR%%/advk.html
+%%PORTDOCS%%%%DOCSDIR%%/advk.txt
+%%PORTDOCS%%%%DOCSDIR%%/advline.html
+%%PORTDOCS%%%%DOCSDIR%%/advline.txt
+%%PORTDOCS%%%%DOCSDIR%%/advm.html
+%%PORTDOCS%%%%DOCSDIR%%/advm.txt
+%%PORTDOCS%%%%DOCSDIR%%/advmame.html
+%%PORTDOCS%%%%DOCSDIR%%/advmame.txt
+%%PORTDOCS%%%%DOCSDIR%%/advs.html
+%%PORTDOCS%%%%DOCSDIR%%/advs.txt
+%%PORTDOCS%%%%DOCSDIR%%/advv.html
+%%PORTDOCS%%%%DOCSDIR%%/advv.txt
+%%PORTDOCS%%%%DOCSDIR%%/authors.html
+%%PORTDOCS%%%%DOCSDIR%%/authors.txt
+%%PORTDOCS%%%%DOCSDIR%%/build.html
+%%PORTDOCS%%%%DOCSDIR%%/build.txt
+%%PORTDOCS%%%%DOCSDIR%%/carddos.html
+%%PORTDOCS%%%%DOCSDIR%%/carddos.txt
+%%PORTDOCS%%%%DOCSDIR%%/cardlinx.html
+%%PORTDOCS%%%%DOCSDIR%%/cardlinx.txt
+%%PORTDOCS%%%%DOCSDIR%%/cardwin.html
+%%PORTDOCS%%%%DOCSDIR%%/cardwin.txt
+%%PORTDOCS%%%%DOCSDIR%%/cost.html
+%%PORTDOCS%%%%DOCSDIR%%/cost.txt
+%%PORTDOCS%%%%DOCSDIR%%/faq.html
+%%PORTDOCS%%%%DOCSDIR%%/faq.txt
+%%PORTDOCS%%%%DOCSDIR%%/histemu.html
+%%PORTDOCS%%%%DOCSDIR%%/histemu.txt
+%%PORTDOCS%%%%DOCSDIR%%/install.html
+%%PORTDOCS%%%%DOCSDIR%%/install.txt
+%%PORTDOCS%%%%DOCSDIR%%/license.html
+%%PORTDOCS%%%%DOCSDIR%%/license.txt
+%%PORTDOCS%%%%DOCSDIR%%/reademu.html
+%%PORTDOCS%%%%DOCSDIR%%/reademu.txt
+%%PORTDOCS%%%%DOCSDIR%%/releemu.html
+%%PORTDOCS%%%%DOCSDIR%%/releemu.txt
+%%PORTDOCS%%%%DOCSDIR%%/script.html
+%%PORTDOCS%%%%DOCSDIR%%/script.txt
+%%PORTDOCS%%%%DOCSDIR%%/svgawin.html
+%%PORTDOCS%%%%DOCSDIR%%/svgawin.txt
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm %%DATADIR%%/sample
+@dirrm %%DATADIR%%/rom
+@dirrm %%DATADIR%%/image
+@dirrm %%DATADIR%%/crc
+@dirrm %%DATADIR%%/artwork
+@dirrm %%DATADIR%%
diff --git a/emulators/advancemess/Makefile b/emulators/advancemess/Makefile
new file mode 100644
index 000000000000..1113314fb252
--- /dev/null
+++ b/emulators/advancemess/Makefile
@@ -0,0 +1,58 @@
+# New ports collection makefile for: advancemess
+# Date created: 2007-01-10
+# Whom: alepulver
+#
+# $FreeBSD$
+#
+
+PORTNAME= advancemess
+PORTVERSION= 0.102.0.1
+CATEGORIES= emulators
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR= advancemame
+
+MAINTAINER= alepulver@FreeBSD.org
+COMMENT= SDL MESS port with advanced TV and monitor video support
+
+LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
+
+USE_GL= yes
+USE_GMAKE= yes
+USE_SDL= sdl
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CFLAGS="${CFLAGS} -idirafter ${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+OPTIONS= FREETYPE "Enable FreeType2 support" off \
+ SLANG "Enable sLang support (for video driver)" off
+
+MAN1= advmess.1
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "i386"
+BUILD_DEPENDS+= nasm:${PORTSDIR}/devel/nasm
+.endif
+
+.if defined(WITH_FREETYPE)
+LIB_DEPENDS+= freetype.9:${PORTSDIR}/print/freetype2
+.else
+CONFIGURE_ARGS+=--disable-freetype
+.endif
+
+.if defined(WITH_SLANG)
+LIB_DEPENDS+= slang.2:${PORTSDIR}/devel/libslang2
+.else
+CONFIGURE_ARGS+=--disable-slang
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e '/pkgdocdir/d' ${WRKSRC}/advance/advance.mak
+
+post-install:
+ @${ECHO_CMD}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_CMD}
+
+.include <bsd.port.post.mk>
diff --git a/emulators/advancemess/distinfo b/emulators/advancemess/distinfo
new file mode 100644
index 000000000000..b0d0a74f512b
--- /dev/null
+++ b/emulators/advancemess/distinfo
@@ -0,0 +1,3 @@
+MD5 (advancemess-0.102.0.1.tar.gz) = 2915778038418b6a7eb194723c654718
+SHA256 (advancemess-0.102.0.1.tar.gz) = 78966d25399a3f70801fb5ac3e93c6fcb14c94991f37d587e9b57bb8a403f7f9
+SIZE (advancemess-0.102.0.1.tar.gz) = 6903540
diff --git a/emulators/advancemess/files/patch-advance__advance.mak b/emulators/advancemess/files/patch-advance__advance.mak
new file mode 100644
index 000000000000..87c4a11ce45a
--- /dev/null
+++ b/emulators/advancemess/files/patch-advance__advance.mak
@@ -0,0 +1,63 @@
+--- ./advance/advance.mak.orig Sun Dec 11 10:10:33 2005
++++ ./advance/advance.mak Sat Jan 20 17:02:36 2007
+@@ -24,8 +24,6 @@
+ ifneq ($(wildcard $(EMUSRC)),)
+ INSTALL_DIRS += $(OBJ)
+ INSTALL_BINFILES += $(OBJ)/$(EMUNAME)$(EXE)
+-INSTALL_MANFILES += $(DOCOBJ)/advmame.1
+-INSTALL_MANFILES += $(DOCOBJ)/advdev.1
+ ifeq ($(CONF_EMU),mame)
+ INSTALL_DATAFILES += $(srcdir)/support/event.dat
+ INSTALL_DATAFILES += $(srcdir)/support/history.dat
+@@ -42,40 +40,6 @@
+ INSTALL_BINFILES += $(MENUOBJ)/advmenu$(EXE)
+ INSTALL_MANFILES += $(DOCOBJ)/advmenu.1
+ endif
+-ifeq ($(CONF_LIB_DIRECT),yes)
+-ifneq ($(wildcard $(srcdir)/advance/cfg.mak),)
+-INSTALL_DIRS += $(CFGOBJ)
+-INSTALL_BINFILES += $(CFGOBJ)/advcfg$(EXE)
+-INSTALL_MANFILES += $(DOCOBJ)/advcfg.1
+-endif
+-ifneq ($(wildcard $(srcdir)/advance/v.mak),)
+-INSTALL_DIRS += $(VOBJ)
+-INSTALL_BINFILES += $(VOBJ)/advv$(EXE)
+-INSTALL_MANFILES += $(DOCOBJ)/advv.1
+-endif
+-endif
+-ifneq ($(CONF_SYSTEM),windows)
+-ifneq ($(wildcard $(srcdir)/advance/s.mak),)
+-INSTALL_DIRS += $(SOBJ)
+-INSTALL_BINFILES += $(SOBJ)/advs$(EXE)
+-INSTALL_MANFILES += $(DOCOBJ)/advs.1
+-endif
+-ifneq ($(wildcard $(srcdir)/advance/k.mak),)
+-INSTALL_DIRS += $(KOBJ)
+-INSTALL_BINFILES += $(KOBJ)/advk$(EXE)
+-INSTALL_MANFILES += $(DOCOBJ)/advk.1
+-endif
+-ifneq ($(wildcard $(srcdir)/advance/j.mak),)
+-INSTALL_DIRS += $(JOBJ)
+-INSTALL_BINFILES += $(JOBJ)/advj$(EXE)
+-INSTALL_MANFILES += $(DOCOBJ)/advj.1
+-endif
+-ifneq ($(wildcard $(srcdir)/advance/m.mak),)
+-INSTALL_DIRS += $(MOBJ)
+-INSTALL_BINFILES += $(MOBJ)/advm$(EXE)
+-INSTALL_MANFILES += $(DOCOBJ)/advm.1
+-endif
+-endif
+
+ INSTALL_DOCFILES += $(subst $(srcdir)/doc/,$(DOCOBJ)/,$(subst .d,.txt,$(wildcard $(srcdir)/doc/*.d)))
+ INSTALL_DOCFILES += $(subst $(srcdir)/doc/,$(DOCOBJ)/,$(subst .d,.html,$(wildcard $(srcdir)/doc/*.d)))
+@@ -288,8 +252,8 @@
+ ############################################################################
+ # Common install
+
+-pkgdir = $(datadir)/advance
+-pkgdocdir = $(docdir)/advance
++pkgdir = $(datadir)/advancemess
++pkgdocdir = $(docdir)/advancemess
+
+ install-dirs:
+ -$(INSTALL_PROGRAM_DIR) $(bindir)
diff --git a/emulators/advancemess/pkg-descr b/emulators/advancemess/pkg-descr
new file mode 100644
index 000000000000..4a03e51cf5ac
--- /dev/null
+++ b/emulators/advancemess/pkg-descr
@@ -0,0 +1,22 @@
+AdvanceMAME and AdvanceMESS are unofficial MAME and MESS versions with an
+advanced video support for helping the use with TVs, Arcade Monitors, Fixed
+Frequencies Monitors and also for PC Monitors.
+
+They run in GNU/Linux, Mac OS X, DOS, Windows and in all the other platforms
+supported by the SDL library.
+
+The main difference compared with the official emulators is that the Advance
+versions are able to program directly the video board to always get a video
+mode with the correct size and frequency.
+
+Generally the Advance emulators are able to use a video mode which doesn't
+require any stretching or other unneeded effects to match the original arcade
+display.
+
+The direct video board programming is fully supported in Linux and DOS. It's
+partially supported in Windows. It isn't supported in Mac OS X and other
+platforms.
+
+See website for other improvements.
+
+WWW: http://advancemame.sourceforge.net/
diff --git a/emulators/advancemess/pkg-message b/emulators/advancemess/pkg-message
new file mode 100644
index 000000000000..b6ce3df4b590
--- /dev/null
+++ b/emulators/advancemess/pkg-message
@@ -0,0 +1,8 @@
+==============================================================================
+
+AdvanceMESS has been installed.
+
+The tools included with the distribution, their manpages and documentation are
+installed by the "games/advancemame" port to avoid conflicts.
+
+==============================================================================
diff --git a/emulators/advancemess/pkg-plist b/emulators/advancemess/pkg-plist
new file mode 100644
index 000000000000..1e2a6b427a06
--- /dev/null
+++ b/emulators/advancemess/pkg-plist
@@ -0,0 +1,9 @@
+@exec for i in artwork crc image rom sample; do mkdir -p %D/%%DATADIR%%/${i}; done
+bin/advmess
+%%DATADIR%%/sysinfo.dat
+@dirrm %%DATADIR%%/sample
+@dirrm %%DATADIR%%/rom
+@dirrm %%DATADIR%%/image
+@dirrm %%DATADIR%%/crc
+@dirrm %%DATADIR%%/artwork
+@dirrm %%DATADIR%%