aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net/googlecl/Makefile7
-rw-r--r--net/googlecl/distinfo5
-rw-r--r--net/googlecl/files/patch-setup.py14
3 files changed, 14 insertions, 12 deletions
diff --git a/net/googlecl/Makefile b/net/googlecl/Makefile
index 751621d94e1a..84bafedcd6c4 100644
--- a/net/googlecl/Makefile
+++ b/net/googlecl/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= googlecl
-PORTVERSION= 0.9.10
-PORTREVISION= 1
+PORTVERSION= 0.9.11
CATEGORIES= net www python
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
@@ -21,12 +20,16 @@ USE_PYDISTUTILS= yes
LICENSE= ASL
+.if !defined(NO_INSTALL_MANPAGES)
MAN1= google.1
+.endif
PORTDOCS= *
post-install:
+.if !defined(NO_INSTALL_MANPAGES)
${INSTALL_MAN} ${WRKSRC}/man/google.1 ${MANPREFIX}/man/man1
+.endif
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README.* ${DOCSDIR}
diff --git a/net/googlecl/distinfo b/net/googlecl/distinfo
index ef2fbc550878..12d710520d62 100644
--- a/net/googlecl/distinfo
+++ b/net/googlecl/distinfo
@@ -1,3 +1,2 @@
-MD5 (googlecl-0.9.10.tar.gz) = 66872cdee0b527d23754e1df111f7836
-SHA256 (googlecl-0.9.10.tar.gz) = 03b58b0dfc03c15eea131c1f5b34a0499f872b14ade48b9ef1d0fcd70a68853c
-SIZE (googlecl-0.9.10.tar.gz) = 56564
+SHA256 (googlecl-0.9.11.tar.gz) = d09d386c545abf458fdcc89a13d614017092c8b84db378f593e8223438f3e741
+SIZE (googlecl-0.9.11.tar.gz) = 63638
diff --git a/net/googlecl/files/patch-setup.py b/net/googlecl/files/patch-setup.py
index bbeb2d4dbbea..5b636ae9d080 100644
--- a/net/googlecl/files/patch-setup.py
+++ b/net/googlecl/files/patch-setup.py
@@ -1,14 +1,14 @@
---- setup.py.orig 2010-07-24 10:30:33.000000000 +0800
-+++ setup.py 2010-08-24 21:11:15.000000000 +0800
-@@ -12,10 +12,7 @@
- # See the License for the specific language governing permissions and
- # limitations under the License.
+--- ./setup.py.orig 2010-12-11 00:04:45.000000000 +0100
++++ ./setup.py 2010-12-11 00:04:57.000000000 +0100
+@@ -14,10 +14,7 @@
+
+ from __future__ import with_statement
-try:
- from setuptools import setup
-except ImportError:
- from distutils.core import setup
+from distutils.core import setup
+ import os
+ import shutil
packages =['googlecl',
- 'googlecl.blogger',
- 'googlecl.calendar',