aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--chinese/scim-chinese/Makefile3
-rw-r--r--chinese/scim-pinyin/Makefile3
-rw-r--r--textproc/skim/Makefile6
3 files changed, 8 insertions, 4 deletions
diff --git a/chinese/scim-chinese/Makefile b/chinese/scim-chinese/Makefile
index 4bf06a740841..c01ef604dd1a 100644
--- a/chinese/scim-chinese/Makefile
+++ b/chinese/scim-chinese/Makefile
@@ -7,6 +7,7 @@
PORTNAME= scim-chinese
PORTVERSION= 0.4.0
+PORTREVISION= 1
CATEGORIES= chinese
MASTER_SITES= http://freedesktop.org/~suzhe/scim-chinese/
@@ -21,7 +22,7 @@ USE_X_PREFIX= yes
USE_ICONV= yes
USE_GMAKE= yes
USE_LIBTOOL_VER= 15
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -D__STDC_ISO_10646__" \
LDFLAGS="-L${LOCALBASE}/lib -lintl" \
PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
diff --git a/chinese/scim-pinyin/Makefile b/chinese/scim-pinyin/Makefile
index 4bf06a740841..c01ef604dd1a 100644
--- a/chinese/scim-pinyin/Makefile
+++ b/chinese/scim-pinyin/Makefile
@@ -7,6 +7,7 @@
PORTNAME= scim-chinese
PORTVERSION= 0.4.0
+PORTREVISION= 1
CATEGORIES= chinese
MASTER_SITES= http://freedesktop.org/~suzhe/scim-chinese/
@@ -21,7 +22,7 @@ USE_X_PREFIX= yes
USE_ICONV= yes
USE_GMAKE= yes
USE_LIBTOOL_VER= 15
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -D__STDC_ISO_10646__" \
LDFLAGS="-L${LOCALBASE}/lib -lintl" \
PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
diff --git a/textproc/skim/Makefile b/textproc/skim/Makefile
index e82763b3aef6..2897a8873daa 100644
--- a/textproc/skim/Makefile
+++ b/textproc/skim/Makefile
@@ -7,20 +7,22 @@
PORTNAME= skim
PORTVERSION= 0.9.3
+PORTREVISION= 1
CATEGORIES= textproc kde
MASTER_SITES= http://freedesktop.org/~cougar/skim/downloads/
MAINTAINER= gaoj@cpsc.ucalgary.ca
COMMENT= An input method platform based on SCIM library and KDE/QT
-LIB_DEPENDS= scim-1.0.3:${PORTSDIR}/textproc/scim
+LIB_DEPENDS= scim-1.0.4:${PORTSDIR}/textproc/scim
USE_KDELIBS_VER=3
USE_ICONV= yes
USE_GMAKE= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
+CONFIGURE_ENV= CFLAGS="-D__STDC_ISO_10646__" \
+ PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
pre-configure: