aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Set-Array/Makefile26
-rw-r--r--devel/p5-Set-Array/distinfo2
-rw-r--r--devel/p5-Set-Array/pkg-descr7
-rw-r--r--devel/p5-Set-Array/pkg-plist2
5 files changed, 38 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 8be40fe690c8..9e1c4ff6a558 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1001,6 +1001,7 @@
SUBDIR += p5-SVN-Web
SUBDIR += p5-Search-Binary
SUBDIR += p5-Server-FastPL
+ SUBDIR += p5-Set-Array
SUBDIR += p5-Set-Crontab
SUBDIR += p5-Set-Infinite
SUBDIR += p5-Set-NestedGroups
diff --git a/devel/p5-Set-Array/Makefile b/devel/p5-Set-Array/Makefile
new file mode 100644
index 000000000000..36944cffc143
--- /dev/null
+++ b/devel/p5-Set-Array/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: devel/p5-Set-Array
+# Date created: 2 September 2004
+# Whom: Alex Kapranoff <kappa@rambler-co.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Set-Array
+PORTVERSION= 0.12
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/R/RS/RSAVAGE
+PKGNAMEPREFIX= p5-
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Arrays as objects with set operations
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Want.pm:${PORTSDIR}/devel/p5-Want
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= Set::Array.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Set-Array/distinfo b/devel/p5-Set-Array/distinfo
new file mode 100644
index 000000000000..1f4ad64a50d5
--- /dev/null
+++ b/devel/p5-Set-Array/distinfo
@@ -0,0 +1,2 @@
+MD5 (Set-Array-0.12.tgz) = fee1f29ef28c10f33df9cf1c2dcb8b9e
+SIZE (Set-Array-0.12.tgz) = 22763
diff --git a/devel/p5-Set-Array/pkg-descr b/devel/p5-Set-Array/pkg-descr
new file mode 100644
index 000000000000..a25bcdfbf615
--- /dev/null
+++ b/devel/p5-Set-Array/pkg-descr
@@ -0,0 +1,7 @@
+Set::Array allows you to create arrays as objects and use OO-style
+methods on them. Many convenient methods are provided here that appear
+in the FAQ's, the Perl Cookbook or posts from comp.lang.perl.misc. In
+addition, there are Set methods with corresponding (overloaded)
+operators for the purpose of Set comparison, i.e. +, ==, etc.
+
+WWW: http://search.cpan.org/search?dist=Set-Array
diff --git a/devel/p5-Set-Array/pkg-plist b/devel/p5-Set-Array/pkg-plist
new file mode 100644
index 000000000000..c6988fa4409a
--- /dev/null
+++ b/devel/p5-Set-Array/pkg-plist
@@ -0,0 +1,2 @@
+%%SITE_PERL%%/Set/Array.pm
+@unexec rmdir %D/%%SITE_PERL%%/Set 2>/dev/null || true