aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--databases/Makefile1
-rw-r--r--databases/pecl-hash/Makefile31
-rw-r--r--databases/pecl-hash/distinfo3
-rw-r--r--databases/pecl-hash/pkg-descr12
-rw-r--r--security/pecl-hash/Makefile31
-rw-r--r--security/pecl-hash/distinfo3
-rw-r--r--security/pecl-hash/pkg-descr12
7 files changed, 93 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index edeccde890ec..6a6e8dbd1859 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -271,6 +271,7 @@
SUBDIR += pecl-PDO_ODBC
SUBDIR += pecl-PDO_PGSQL
SUBDIR += pecl-PDO_SQLITE
+ SUBDIR += pecl-hash
SUBDIR += pecl-memcache
SUBDIR += pecl-sqlite
SUBDIR += pgaccess
diff --git a/databases/pecl-hash/Makefile b/databases/pecl-hash/Makefile
new file mode 100644
index 000000000000..c5f0023fc455
--- /dev/null
+++ b/databases/pecl-hash/Makefile
@@ -0,0 +1,31 @@
+# Ports collection makefile for: pecl-hash
+# Date created: 2005-12-07
+# Whom: Alexander Zhuravlev <zaa@zaa.pp.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hash
+DISTVERSION= 1.1
+CATEGORIES= databases www
+MASTER_SITES= http://pecl.php.net/get/
+PKGNAMEPREFIX= pecl-
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PECL
+
+MAINTAINER= zaa@zaa.pp.ru
+COMMENT= pHASH Message Digest Framework for PHP
+
+USE_PHP= yes
+USE_PHPIZE= yes
+USE_PHPEXT= yes
+DEFAULT_PHP_VER=5
+PHP_MODNAME= hash
+
+.include <bsd.port.pre.mk>
+
+.if ${PHP_VER} == 4
+IGNORE= requires PHP version 5.0.3 or higher
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/databases/pecl-hash/distinfo b/databases/pecl-hash/distinfo
new file mode 100644
index 000000000000..3ea05932ea2d
--- /dev/null
+++ b/databases/pecl-hash/distinfo
@@ -0,0 +1,3 @@
+MD5 (PECL/hash-1.1.tgz) = cf33b7b723fed4abfefe33b0ebce74b2
+SHA256 (PECL/hash-1.1.tgz) = 56b0e7104beec4b845705f7550586f883cc8f27c079959a3b05b0be1639dfcc4
+SIZE (PECL/hash-1.1.tgz) = 100713
diff --git a/databases/pecl-hash/pkg-descr b/databases/pecl-hash/pkg-descr
new file mode 100644
index 000000000000..12d390d3882c
--- /dev/null
+++ b/databases/pecl-hash/pkg-descr
@@ -0,0 +1,12 @@
+Extension provides native implementations of common message digest algorithms
+using a generic factory method.
+At the moment it supports the following hashing algorithms:
+
+ * md4, md5
+ * sha1, sha256, sha384, sha512
+ * ripemd128, ripemd160
+ * tiger128, tiger160, tiger192 (3 and 4 passes)
+ * haval128, haval160, haval192, haval224, haval256 (3, 4 and 5 passes)
+ * crc32, crc32b, adler32, gost, snefru, whirlpool
+
+WWW: http://pecl.php.net/package/hash
diff --git a/security/pecl-hash/Makefile b/security/pecl-hash/Makefile
new file mode 100644
index 000000000000..c5f0023fc455
--- /dev/null
+++ b/security/pecl-hash/Makefile
@@ -0,0 +1,31 @@
+# Ports collection makefile for: pecl-hash
+# Date created: 2005-12-07
+# Whom: Alexander Zhuravlev <zaa@zaa.pp.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hash
+DISTVERSION= 1.1
+CATEGORIES= databases www
+MASTER_SITES= http://pecl.php.net/get/
+PKGNAMEPREFIX= pecl-
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PECL
+
+MAINTAINER= zaa@zaa.pp.ru
+COMMENT= pHASH Message Digest Framework for PHP
+
+USE_PHP= yes
+USE_PHPIZE= yes
+USE_PHPEXT= yes
+DEFAULT_PHP_VER=5
+PHP_MODNAME= hash
+
+.include <bsd.port.pre.mk>
+
+.if ${PHP_VER} == 4
+IGNORE= requires PHP version 5.0.3 or higher
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/pecl-hash/distinfo b/security/pecl-hash/distinfo
new file mode 100644
index 000000000000..3ea05932ea2d
--- /dev/null
+++ b/security/pecl-hash/distinfo
@@ -0,0 +1,3 @@
+MD5 (PECL/hash-1.1.tgz) = cf33b7b723fed4abfefe33b0ebce74b2
+SHA256 (PECL/hash-1.1.tgz) = 56b0e7104beec4b845705f7550586f883cc8f27c079959a3b05b0be1639dfcc4
+SIZE (PECL/hash-1.1.tgz) = 100713
diff --git a/security/pecl-hash/pkg-descr b/security/pecl-hash/pkg-descr
new file mode 100644
index 000000000000..12d390d3882c
--- /dev/null
+++ b/security/pecl-hash/pkg-descr
@@ -0,0 +1,12 @@
+Extension provides native implementations of common message digest algorithms
+using a generic factory method.
+At the moment it supports the following hashing algorithms:
+
+ * md4, md5
+ * sha1, sha256, sha384, sha512
+ * ripemd128, ripemd160
+ * tiger128, tiger160, tiger192 (3 and 4 passes)
+ * haval128, haval160, haval192, haval224, haval256 (3, 4 and 5 passes)
+ * crc32, crc32b, adler32, gost, snefru, whirlpool
+
+WWW: http://pecl.php.net/package/hash