aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--x11-wm/rox-pager/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/x11-wm/rox-pager/Makefile b/x11-wm/rox-pager/Makefile
index 81c93528eee4..16078613f0d0 100644
--- a/x11-wm/rox-pager/Makefile
+++ b/x11-wm/rox-pager/Makefile
@@ -7,6 +7,7 @@
PORTNAME= rox-pager
PORTVERSION= 1.0.0
+PORTREVISION= 1
CATEGORIES= x11-wm
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= rox
@@ -17,6 +18,8 @@ MAINTAINER= olgeni@FreeBSD.org
COMMENT= Pager for the ROX desktop
USE_GNOME= gtk20 pkgconfig libxml2 libwnck
+USE_AUTOCONF= yes
+HAS_CONFIGURE= yes
.include <bsd.port.pre.mk>
@@ -28,8 +31,10 @@ BINARIES= FreeBSD-${ARCH}
PLIST_SUB= BINARIES="${BINARIES}"
-do-build:
- @cd ${WRKSRC} && Pager/AppRun --compile
+CONFIGURE_ARGS= --enable-rox --with-platform=${BINARIES}
+CONFIGURE_WRKSRC= ${WRKSRC}/Pager/src
+BUILD_WRKSRC= ${CONFIGURE_WRKSRC}
+ALL_TARGET=
do-install:
@${MKDIR} ${PREFIX}/apps/Pager