aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/nasm/Makefile1
-rw-r--r--devel/nasm/files/patch-output::outelf.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/devel/nasm/Makefile b/devel/nasm/Makefile
index a6b0983350b9..de050e1020ba 100644
--- a/devel/nasm/Makefile
+++ b/devel/nasm/Makefile
@@ -7,6 +7,7 @@
PORTNAME= nasm
PORTVERSION= 0.98.38
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= devel lang
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
diff --git a/devel/nasm/files/patch-output::outelf.c b/devel/nasm/files/patch-output::outelf.c
new file mode 100644
index 000000000000..df7073f8b1a1
--- /dev/null
+++ b/devel/nasm/files/patch-output::outelf.c
@@ -0,0 +1,11 @@
+--- output/outelf.c.orig Sun Dec 14 16:25:34 2003
++++ output/outelf.c Sun Dec 14 16:26:25 2003
+@@ -1411,7 +1411,7 @@
+ the source-file, the n_desc field should be set to the number
+ of remaining stabs
+ */
+- WRITE_STAB(sptr, fileidx[0], 0, 0, 0, strlen(allfiles[0]+12));
++ WRITE_STAB(sptr, fileidx[0], 0, 0, 0, stabstrlen);
+
+ ptr=stabslines;
+ numstabs = 0;