aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--math/asir2000/Makefile8
-rw-r--r--multimedia/nuppelvideo/Makefile4
2 files changed, 11 insertions, 1 deletions
diff --git a/math/asir2000/Makefile b/math/asir2000/Makefile
index 4fd9e61f0bf7..0b079d9d102f 100644
--- a/math/asir2000/Makefile
+++ b/math/asir2000/Makefile
@@ -35,6 +35,12 @@ LIB_DATA= alpi bfct bgk const cyclic defs.h dfff dmul dmul102 \
num primdec primdec_lex primdec_mod ratint robot solve sp \
sturm sym weight xm
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386" && ${ARCH} != "amd64"
+BROKEN= "Does not compile on !i386 and !amd64"
+.endif
+
pre-install:
@${MKDIR} ${DATADIR}
@${MKDIR} ${DOCSDIR}
@@ -53,4 +59,4 @@ post-install:
@${TAR} xfz ${DISTDIR}/${ASIR_DOC} -C ${DOCSDIR}
@${INSTALL_MAN} ${DOCSDIR}/${MAN1} ${PREFIX}/man/man1
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/multimedia/nuppelvideo/Makefile b/multimedia/nuppelvideo/Makefile
index 92055b433f98..d5b9c2b4e5e2 100644
--- a/multimedia/nuppelvideo/Makefile
+++ b/multimedia/nuppelvideo/Makefile
@@ -25,6 +25,10 @@ CFLAGS+= -I${LOCALBASE}/include -I${X11BASE}/include \
.include <bsd.port.pre.mk>
+.if ${ARCH} != "i386" && ${ARCH} != "amd64"
+BROKEN= "Does not compile on !i386 and !amd64"
+.endif
+
###
## Auto detected features
###