aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net/Makefile1
-rw-r--r--net/liboping/Makefile25
-rw-r--r--net/liboping/distinfo3
-rw-r--r--net/liboping/pkg-descr7
-rw-r--r--net/liboping/pkg-plist6
5 files changed, 42 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index bbc2d6bc8fc7..9703db2acb9f 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -276,6 +276,7 @@
SUBDIR += libnids
SUBDIR += libnss-mysql
SUBDIR += libopennet
+ SUBDIR += liboping
SUBDIR += libosip
SUBDIR += libosip2
SUBDIR += libpcap
diff --git a/net/liboping/Makefile b/net/liboping/Makefile
new file mode 100644
index 000000000000..dacbde315674
--- /dev/null
+++ b/net/liboping/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: liboping
+# Date created: Sat Sep 29 03:38:37 PDT 2007
+# Whom: Matt Peterson <matt@peterson.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= liboping
+PORTVERSION= 0.3.5
+CATEGORIES= net
+MASTER_SITES= http://verplant.org/liboping/files/ \
+ http://matt.peterson.org/FreeBSD/ports/
+
+MAINTAINER= matt@peterson.org
+COMMENT= C library to generate ICMP echo requests
+
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+
+MAN3= liboping.3 ping_construct.3 ping_setopt.3 ping_host_add.3 \
+ ping_send.3 ping_get_error.3 ping_iterator_get.3 \
+ ping_iterator_get_info.3 ping_iterator_get_context.3
+MAN8= oping.8
+
+.include <bsd.port.mk>
diff --git a/net/liboping/distinfo b/net/liboping/distinfo
new file mode 100644
index 000000000000..0d809ed6a5fa
--- /dev/null
+++ b/net/liboping/distinfo
@@ -0,0 +1,3 @@
+MD5 (liboping-0.3.5.tar.gz) = 0b2581df470184424ef707d0d94e36a1
+SHA256 (liboping-0.3.5.tar.gz) = 342f0c7518a029749d634b31d9d7e928268104d4d682ae36e03f15d122333df5
+SIZE (liboping-0.3.5.tar.gz) = 336937
diff --git a/net/liboping/pkg-descr b/net/liboping/pkg-descr
new file mode 100644
index 000000000000..a327c6333280
--- /dev/null
+++ b/net/liboping/pkg-descr
@@ -0,0 +1,7 @@
+liboping is a C library to generate ICMP echo requests, better known as
+"ping packets". It is intended for use in network monitoring applications
+or applications that would otherwise need to fork ping(1) frequently.
+Included is a sample application, called oping, which demostrates the
+library's abilities. It is like ping, ping6, and fping rolled into one.
+
+WWW: http://verplant.org/liboping/
diff --git a/net/liboping/pkg-plist b/net/liboping/pkg-plist
new file mode 100644
index 000000000000..90afb14f7d00
--- /dev/null
+++ b/net/liboping/pkg-plist
@@ -0,0 +1,6 @@
+bin/oping
+include/oping.h
+lib/liboping.la
+lib/liboping.a
+lib/liboping.so
+lib/liboping.so.0