aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--security/Makefile1
-rw-r--r--security/bcrypt/Makefile40
-rw-r--r--security/bcrypt/distinfo2
-rw-r--r--security/bcrypt/pkg-descr11
4 files changed, 54 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index ef21ba1128ff..83bbbc1bbdc2 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -27,6 +27,7 @@
SUBDIR += avcheck
SUBDIR += barnyard
SUBDIR += base
+ SUBDIR += bcrypt
SUBDIR += bcwipe
SUBDIR += bdc
SUBDIR += beecrypt
diff --git a/security/bcrypt/Makefile b/security/bcrypt/Makefile
new file mode 100644
index 000000000000..929493b6c88c
--- /dev/null
+++ b/security/bcrypt/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: bcrypt
+# Date created: 11 Aug 2005
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bcrypt
+PORTVERSION= 1.1
+CATEGORIES= security
+MASTER_SITES= http://bcrypt.sourceforge.net/
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= A cross-plattform blowfish encryption utility
+
+USE_REINPLACE= yes
+
+ALL_TARGET= ${PORTNAME}
+
+LDFLAGS+= -lz
+MAKE_ENV+= LDFLAGS="${LDFLAGS}"
+
+PORTDOCS= README
+MAN1= bcrypt.1
+PLIST_FILES= bin/bcrypt
+
+post-patch:
+ @${REINPLACE_CMD} -E 's/^(CC|CFLAGS|LDFLAGS|PREFIX)\ /\1?/' \
+ ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MANPREFIX}/man/man1
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/bcrypt/distinfo b/security/bcrypt/distinfo
new file mode 100644
index 000000000000..c62f826b72e3
--- /dev/null
+++ b/security/bcrypt/distinfo
@@ -0,0 +1,2 @@
+MD5 (bcrypt-1.1.tar.gz) = 8ce2873836ccd433329c8df0e37e298c
+SIZE (bcrypt-1.1.tar.gz) = 36781
diff --git a/security/bcrypt/pkg-descr b/security/bcrypt/pkg-descr
new file mode 100644
index 000000000000..7a7d31298e2b
--- /dev/null
+++ b/security/bcrypt/pkg-descr
@@ -0,0 +1,11 @@
+Bcrypt is a blowfish file encryption utility which aims for cross-platform
+portability.
+
+In addition to providing 448-bit encryption, bcrypt overwrites input files with
+random garbage before deletion in order to make low-level data recovery much
+more difficult.
+
+WWW: http://bcrypt.sourceforge.net/
+
+- ehaupt
+ehaupt@critical.ch