aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net/pear-SOAP/Makefile23
-rw-r--r--net/pear-SOAP/distinfo6
2 files changed, 24 insertions, 5 deletions
diff --git a/net/pear-SOAP/Makefile b/net/pear-SOAP/Makefile
index 5a05242f7c65..fa28ff2e12b2 100644
--- a/net/pear-SOAP/Makefile
+++ b/net/pear-SOAP/Makefile
@@ -6,15 +6,21 @@
#
PORTNAME= SOAP
-PORTVERSION= 0.10.1
+PORTVERSION= 0.11.0
CATEGORIES= net www pear
MAINTAINER= bg1tpt@gmail.com
COMMENT= PEAR SOAP Client/Server for PHP
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
+ ${PEARDIR}/HTTP/Request.php:${PORTSDIR}/www/pear-HTTP_Request
RUN_DEPENDS= ${BUILD_DEPENDS}
+LATEST_LINK= pear-SOAP
+OPTIONS= PEAR_MAIL "PEAR::Mail support" off \
+ PEAR_MAIL_MIME "PEAR::Mail::Mime support" off \
+ PEAR_NET_DIME "PEAR::Net::DIME support" off
+
CATEGORY= SOAP
FILES= Base.php Client.php Disco.php Fault.php Parser.php \
Server.php Transport.php Value.php WSDL.php \
@@ -33,5 +39,18 @@ EXAMPLES= attachment.php client.php com_client.php \
_EXAMPLESDIR= example
.include <bsd.port.pre.mk>
+
+.if defined(WITH_PEAR_MAIL)
+BUILD_DEPENDS+= ${PEARDIR}/Mail.php:${PORTSDIR}/mail/pear-Mail
+.endif
+
+.if defined(WITH_PEAR_MAIL_MIME)
+BUILD_DEPENDS+= ${PEARDIR}/Mail/mime.php:${PORTSDIR}/mail/pear-Mail_Mime
+.endif
+
+.if defined(WITH_PEAR_NET_DIME)
+BUILD_DEPENDS+= ${PEARDIR}/DIME.php:${PORTSDIR}/net/pear-Net_DIME
+.endif
+
.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
.include <bsd.port.post.mk>
diff --git a/net/pear-SOAP/distinfo b/net/pear-SOAP/distinfo
index 850a1228ec01..78d92d558a4c 100644
--- a/net/pear-SOAP/distinfo
+++ b/net/pear-SOAP/distinfo
@@ -1,3 +1,3 @@
-MD5 (PEAR/SOAP-0.10.1.tgz) = a6326d910a4193d41b76904503b2f0c6
-SHA256 (PEAR/SOAP-0.10.1.tgz) = 0a4ba23c6d3e0505506ed6dc8ca7f32a3dabcccdb97c796cc95b187a560f8442
-SIZE (PEAR/SOAP-0.10.1.tgz) = 70965
+MD5 (PEAR/SOAP-0.11.0.tgz) = 0e846e2279d8c49bf37e7e01fb71a115
+SHA256 (PEAR/SOAP-0.11.0.tgz) = 2a7505522e49a423689bd57747ade9df29cefb97c5da2ec8fdd906d853c37679
+SIZE (PEAR/SOAP-0.11.0.tgz) = 69948